No available Apps

#1

Hi,

I just purchased the PR41000 NAS and on setting it up, I cannot access any of the Apps (am trying to find and install Plex).

When I clock on the “Apps” tab, it shows me “No available Apps.”

I have searched the forum and web and have completed all the following to no avail.

  • rebooted (multiple times)
  • tried different LAN connection ports
  • reset device (both through the web dashboard as well as using the reset button on back of unit)
  • turning off various settings and seeing if that helped (none did)
  • turned off Firewall
  • tried different browsers (Chrome, Edge) and turned off all extensions

As far as I can tell, I am unable to connect to some WD site that should allow me to download the App library?

I am on the latest Firmware (2.30.183) - no updates show from Settings option.

The help suggestions of WD are not working and I am now at an impasse as to how to install local apps (Plex in particular).

Any help would be most appreciated

1 Like
#2

Hi,

I’m having the same problem.

Tried to download the XML file to my PC from http://download.wdc.com/apps/MyCloudPR2100/bbcl.xml (for my device) and that had a HTTP 503 error. I assume the site is down?

#3

The site is now back up and running!

#4

Same problem here , I have a brand new pr4100, with firmware 2.30.183
It is really unprofessional, sorry to say it, but it is like that !

WD please help !!!

BR.

Nicolai

#5

Yep - working for me now too.

Thanks all - glad it wasn’t something on my end.

I think WD need to add some comment into FAQ or improve their error messaging (and fix the ACCEPT dialog as that should proceed irregardless of whether apps are downloadable or not in my opinion).

#6

Yes I agree.

  • If there’s an error code returned from the site, it should be displayed.

  • The fact that the software won’t allow you beyond the T&C dialog should be regarded as a serious bug. Not allowing manual installations because of the lack of Internet access is wrong!

#7

I have this problem today as well. I don’t see any Apps from the page and had issues clicking the T&C.

I never solved that but did find a config file where you can edit an xml file to have accept it so you can actually install an app.

its in /usr/local/config/config.xml

There is an entry for <eula_apps>0</eula_apps>

Change the 0 to a 1.

You will then need to reboot the NAS. One reboot it seems to copy that contents of this directory to /etc as /etc looks like it is running out of a RAM disk.

Once I did this I was then able to install Plex through the GUI and off and running.

I do hope this helps others.