Install App Manually Fails Can't Get Past ACCEPT button


#1

With a recent prompt to update Plex this was my experience with Firmware 2.31.163 ( I have successfully done this process with the previous WD firmware without issue)

Outline of Apps Issue:

I was prompted to update Plex

Download Plex Update

Went to Apps within WD EX2 Ultra

Click install manually

Prompt comes up to ACCEPT terms. Scrolled all the way down to the end for the terms and Accept button does not function

I try this in two other browsers IE, Edge and again in Firefox, same issue unable to Accept Terms

I go to WD support site, states uninstall the Plex App

I make a Backup Config first of the entire setup I have in place

Uninstall the Plex App

Try again, same issue cannot install manually Accept button doesn’t work, no access to the App Store which states No More Apps and No Plex

I call support they state to do a Full test.

Instead I opt to Import my Backup File

System reboots, takes awhile while re-importing

I can now access the App Store and Manually Import the new Plex App.

A most unreliable product. after 3 weeks of troubleshooting dropped audio files, a System Only restore within the WD EX2 Ultra was the solution that fixed the issue.


#2

I tried a System Only restore. It did not fix my issue.

But, that said, I have fixed this issue on my EX2 Ultra. It’s a weird solution and I don’t know where the true root cause is, but this is what I have to do when this happens to me.

  1. Hibernate (shut down my NAS)
  2. Physically change the Ethernet port the NAS is connected to my Broadband Internet provider’s router
  3. Reboot my Broadband Internet provider’s router
  4. Start my NAS

After that process, I am able to see the application list over the Internet AND I am able to accept the Licensing Terms and Conditions, necessary to manually install an application (like Plex).

My Internet provider uses a Technicolor DPC3848V DOCSIS 3.0 Gateway. It’s 4 port Ethernet and 1 WAN (cable - coax). I have 3 devices plugged in (including my NAS), so it’s fairly easy for me to swap the port. I tried playing with the UPnP setting and other port mapping features and none of that worked. Weird.