Can't install any apps via WD dashboard

Hello,
I’m running latest dashboard, and I can’t install any apps. Apps supported by WD won’t load and if i try to add apps manually after clicking on accept terms of use button nothing happens.

I tried rebooting my nas several times even restoring to default (system only) nothing helped.

Please see enclosed video.

Did you ever get this resolved? I’m having the same issue.

Chad

OK. I have fixed this issue on my EX2 Ultra. It’s a weird solution and I don’t know where the true root cause is, but this is what I have to do when this happens to me.

  1. Hibernate (shut down my NAS)
  2. Physically change the Ethernet port the NAS is connected to my Broadband Internet provider’s router
  3. Reboot my Broadband Internet provider’s router
  4. Start my NAS

After that process, I am able to see the application list over the Internet AND I am able to accept the Licensing Terms and Conditions, necessary to manually install an application (like Plex).

My Internet provider uses a Technicolor DPC3848V DOCSIS 3.0 Gateway. It’s 4 port Ethernet and 1 WAN (cable - coax). I have 3 devices plugged in (including my NAS), so it’s fairly easy for me to swap the port. I tried playing with the UPnP setting and other port mapping features and none of that worked. Weird.

1 Like

Hello!
Same here.