Missing Apps - help required


I’m a new owner of a EX4 and first time owner of a NAS. I’ve been having a daily exchange with WD technical support out here in Asia and have not been able to solve a problem of “no apps available” when I try to add a app from the app menu.

My specific interest was in installing squeezecenter but I can’t see any apps listed nor can I add manually when downloading from the WD download page.

Based on instructions from Tech support, I’ve

a) reinstalled latest firmware

b) system restore based on factory defaults

c) Check access using IE and Chrome (my default is Firefox)

d) Check access using different computers

Nothing ghas worked so far. Anyone has experience with this problem or suggestions?

Thanks - Jen

Welcome to the Community.

Where are you located? There are times when specific Internet traffic and connections are monitored in filtered, which limits Internet-related features and services based on geo-location. China is an example.

I am in Singapore. I’ve tested remote access to mycloud from my daughter in the US and connection works. Tried loading apps manually and still no apps. Faulty unit?

WD was nice enough for me to RMA the unit but unfortunately, the new unit has the same problem - apps do not show up.

Tried loading squeezecenter manually but does not work on downloaded file.

Anyone tried loading squeezecenter manually? instructions appreciated as I couldn’t find any WD documentation on this.