NFS broken after firmware 4.00?

Is anyone able to use their MyCloud over NFS after the firmware upgrade? I can mount the shares at /nfs fine to my Ubuntu box, and can write files to the share, but as soon as I try to read a file, it hangs. On the mycloud I can see 4-5 nfsd processes all running at 10-50% CPU when this happens (typically total host cpu for system/wait is around 50%/50%) in this case.

The hang goes on for a long time - eventually the read on by Ubuntu box times out, but the nfsd processes keep wailing away.  Ocasionally I can read a few bytes, but as soon as I try to copy several MB, same result.

CIFS/SAMBA seems to work fine.

I should add that the bevaior isn’t completely consistent. It always fails for a large enough file, but sometimes it succeeds in copying 1 MB, somtimes more. For example, I just created a 100 MB file from /dev/urandom on the device over NFS (no problem, writes don’t seem to be the issue). I tried to read it back (after dropping the local FS cache) and it got to 85 MB before hanging with the symptoms described above.

Anyone out there using NFS, even on the 3.x firmware?

My wdmycloud is so unresponsive ATM I cannot even get to the web interface to find out what firmware I’m on!

I’m connecting to NFS from OSX and it’s sucking, I also see multiple nfsd processes using CPU when I see the “server not responding” message on the client.

I took a guess at finding the version…

WDMyCloud:~# cat /etc/version


Works fine for me on Ubuntu 14.04.01 with the latest firmware on the My Cloud.

It works fine for me on FreeBSD 9.3 with the latest firmware on My Cloud. I am able for instance to NFS mount a private share and to use rnapshot (rsync) to backup a PC on my LAN to this share on My Cloud.

kubuntu 14.04 I have the same problem. 4 nfsd processes on mycloud freezes when I try to copy big file over nfs.

Same problem here, I can easily copy big file to NAS but when I try to get it back it hangs after copying 2-3 megabytes…

Running 04.00.01-623

Use MyCloud for few days only so can’t say if older firmware have that problem or not, but I’m not sure if firmware is to blame here, my file manager which I use become unresponsive and I simply can’t delete associated processes by any means.

Are those who experience similar bug in the same situation?

I’m running into this same problem and its very annoying.

I run Linux exclusively and utilize NFS for all of my shares.

When I mount the My Cloud with the cifs protocall all is well. But if I mount with the NFS protocal it will write fine but will hang up the drive when reading large files.

If there is a a fix for this issue I could use it as soon as possible.

1 Like

I’m seeing exactly the same issue. Playing video over NFS from the mycloud will work for a little while, but then everything hangs. I can see ~4 nfsd processes with high CPU on the mycloud, but the overall CPU load looks ok. I tried increasing the NFSDCOUNT on the mycloud which might have helped a bit, but it’s still unusable.

I can’t tell if it’s a firmware issue as this is a new drive so it came with a fairly new firmware anyway.

I’d be interested to know in what way Daveyk15’s setup is different from mine (client mount options for a start) as I’m also on Ubuntu 14.04.1.

1 Like

So far I didn’t find solution and have to use CIFS(frankly saying I didn’t tried to find it).

The only solution seems to downgrade firmware to version 3, but I’m not sure if situation there really differ or people who report that NFS works there just lucky.

I have the same problem.

Running Linux Mint 17.1, I originally compared NFS vs SMB and found NFS to be faster, so I set it up and loaded the MyCloud with hundreds of gigabytes from my local HD as well as from USB harddrives locally connected to my PC.

Writing to the WD MyCloud via NFS was no problem.

But when I try to copy data from the MyCloud back to my local harddrive, the copying process freezes after the first file.

As described by the others, even if the local OS manages to cancel the operation locally, there are still several nfsd processes running on the MyCloud with high %CPU, see below an extract from TOP output.

5828 root 20 0 0 0 0 S 33.7 0.0 4:39.76 nfsd
5826 root 20 0 0 0 0 R 25.1 0.0 2:56.51 nfsd
5824 root 20 0 0 0 0 S 23.1 0.0 3:13.55 nfsd
5827 root 20 0 0 0 0 R 22.5 0.0 3:20.01 nfsd

I’m using a WD MyCloud 3TB, with the most recent firmware v04.01.02-417.

Any ideas?

NFS has always given me better performance. All of my devices are *nix so it just makes sense. The My Could was using NFS just fine until this most recent firmware (v04.01.02-417) update, my previous firmware was still a 4 series but not sure of the exact version. But this appears to have effected CIFS as well. I have noticed degraded performance compared to the previous firmware, it doesn’t hang up like NFS but it does temporarily stall quite often. This kind of defeats the purpose of having the “Media Server” functions. At this point my environment would be better if I had saved $100 and just got the USB external drive.

FWIW I gave on on NFS after spending a few hours trying to diagnose the issue and went with CIFS mounts, which seem to work OK.

Meanwhile, I google-searched, and played around with various options for the mount commands.

Somewhere it was suggested to change nfs server option from “sync” to “async” in the exports file on the MyCloud, but this did not improve anything for me.

I found two solutions:

  1. Use the (nfs) mount option “udp”.

Strangely, it would not be accepted as sole option, but only accompanied by option “nfsvers=3”.

  1. Use the (nfs) mount options “rsize=8192,wsize=8192”.

Without specifying these, the are negotiated to “rsize=32768,wsize=32768”.

Either of these methods worked for me, i.e. no freezes of the copy/read process anymore.

Yet, they also made the read speed drop to around 40 MB/s, compared to the 60 MB/s I had before.

Btw, with a single huge file I have read/write speeds of 40/20 MB/s with SMB, and 60/40 MB/s with NFS.

1 Like

I had a problem mounting the NFS share in fstab on boot, but when I mount manually all is fine.  i use this command:

sudo mount -o soft,intr,rsize=8192,wsize=8192 XXX.XXX.XXX.XXX:/nfs /home/######

where XXX.XXX.XXX.XXX is the IP of the wdmycloud and /home/###### is the path to the mount point.

1 Like

Thank you eugenkss, for pointing me in the right direction. I had planned on digging deeper, but haven’t had the time.

With your suggestions I was able to do some load testing and am now almost back to the performance and reliablity that I had originally.

Here are my results.

I do not reccomend the “udp” option. It is excellent for burst throughput (basically the first few seconds of file transfer) but it hinders sustained throughput quite a bit. For a “media server” and large files you are going to want the sustained throughput more. I would recommend using the rsize and wsize fix.

The rsize and wsize provided are 1/4 the “default” values and will reduce your throughput, I went with 1/2 values and it makes a significant impact.

I finally settled on the following settings in the fstab for those that want to try this.

XXX.XXX.XXX.XXX:/nfs/Public /media/RemoteStorage nfs rsize=16384,wsize=16384,soft,intr,user 0 0

XXX.XXX.XXX.XXX being the ip of your MyCloud.

This config has given me the best performance/reliablity I could obtain with the current “broken” nfs function of the MyCloud.

And once again NFS is still outperforming CIFS even with these “limitations”.

Thanks eugenkss for doing the leg work. Saved me the time I appreciate it.

1 Like

Thanks folks for sharing your solutions!
I’ve tried both 16384 and 8192 and only latest worked for me as with 16384 system still froze after a moment of reading file from mycloud, writing works just fine but it was working without issues before.

so in the end here is what I’m using right now:

sudo mount -o soft,intr,rsize=8192,wsize=8192 $HOME/nfs/

I’m also having this problem.

I’m running Ubuntu 14.04 64bit with latest patches installed.

My computer has 16Gb of RAM.

In NFS case, when I try to move about 20 Gb of .mp3 from one directory on WD My cloud to other directory on WD My cloud, Ubuntu hangs with 70% probability.

I also see 5 nfsd processes on WD My Cloud.

Overall speed of the operation - 18Mb/sec.

But this problem exists only on 1Gb network. If I change connection speed in Ubuntu to 100Mb, everything works.

But, I’ve found, CIFS is working faster for me.

In my case, downloading big files from WD My Cloud over CIFS to local SSD drive is performing at 65 MB/sec.

Uploading to WD My Cloud over CIFS is about 100MB/sec - it can not be faster on 1Gb network.

I’m working in simplest home setup - one router (TP-Link 1043) and UTP-5e Ethernet cable to WD My Cloud and Ubuntu.

WD My Cloud has latest 4.0 firmware.

So, I’ve decided to give up NFS - it can not speed up anything for me.