NFSv4 on My Cloud

There are a few previous threads on this topic, mostly around the EX4 device. The short answer is that it doesn’t work, or doesn’t work right.

I recently purchased a My Cloud 3TB and found, to my surprise, that NFS was enabled but configured for anonymous access only. Given that the web management interface has nowhere to configure NFS and anything prior to NFSv4 would be a support nightmare for WD, it was a pleasant surprise that even anonymous NFS worked.

I did a bit of poking around the device after finding that we can enable SSH access and login as the root user. I didn’t change anything but I did start to look around.

The OS appears to be a modified version of an older Debian Linux distribution (anyone who can take advantage of that information probably already knows that). The version is sufficiently old that it is using init for system startup instead of systemd (which is good if you want NFS to work properly until the systemd folks sort things out).

As for NFSv4 …

The rpc_pipefs tool is missing. This tool is needed to create the communications link (named pipe) between the nfsd kernel module (that provides NFS server functionality) and rpc.idmapd (that provides name-to-id mapping). Without this tool, rpc.idmapd crashes on startup and you can’t map userids to names.

Either, WD accidentally removed the rpc_pipefs tool from their build or did so on purpose to disable NFSv4. Either way, it means we can’t get name-to-id mapping working and, sadly, can’t use NFSv4 to it’s full potential.

I can understand the oversight of the missing rpc_pipefs tool. I can also understand intentionally limiting NFS on these devices. These are consumer devices and the number of consumers who would want to make use of NFS is undoubted small compared to the market while at the same time possibly making a higher percentage of support calls due to NFS not working as expected. NFS prior to v4 is easy to set-up but relies on all systems having matching user-ids (which can be a challenge for many). By giving us anonymous NFS access, WD is showing some concern for us, so we should be happy they went that far.

NFSv4 can be a bit more tricky to setup than NFSv1, although not nearly as complicated as properly configuring NFSv3 (in my opinion). And I do wish they supplied us with the tools to enable full NFSv4 functionality even if it’s not a part of the web interface.

Thanks for your feedback.

Indeed; full NFSv4 access/control does have a few benefits and drawbacks at once, which is the reason why WD’s current stance is reasonable. Still, a suggestion can be made for future reference or implementation.

I didn’t outright say it in my original post, but my implied suggestion is for WD to include all the tools needed to fully implement NFSv4 (preferably including GSS/Kerberos support for host authentication) but not necessarily include those features in the web management interface.

The people who are likely to want NFS and who have the ability to understand how to adjust the system from the command prompt, are probably less likely to need technical support directly from WD.

The warning we get when we enable SSH access should help us clue in that we can’t call support if we mess up the NFS server settings.

1 Like

Are you sure? Only the default “public” share allows anonymous NFS access on my 4TB MYCLOUD.

I worked my way through the components that make up NFS with the intention of a more robust NFSv4 on my device. I found that rpc_pipefs is missing from the system, rpc.idmapd is there but disabled, and exports is configured to map all NFS connections to nobody/nogroup and to provide only the default, “public” share.

The version strings suggest that the kernel nfsd should be capable of speaking NFSv4. So, it should be possible for someone with experience to modify the configuration to support NFSv4 more fully (unless that old bug is still present).

I didn’t actually reconfigure anything on my device. I tried to manually start rpc.idmapd. I didn’t look for or test gssd since I don’t currently bother with that level of authentication in my home network.

I am as sure as I can be without actually making the needed changes and adding rpc_pipefs to the system (which I expect would technically void the warrantee).


I can’t get anon to access anything beyond what is in “Public.”

What troubles me most is that this 5 years later is still not supported …

Some versions of NFS are supported, just not on the first gen v4.x firmware single bay My Cloud unit which is End of Life and not receiving any more software updates. A WD Support Knowledgebase Article on NFS.

How To Configure NFS Service on My Cloud

My Cloud NFS Information

  • NFS v3 is supported
  • NFS is not supported on single-bay My Cloud (firmware 04.xx.xx-xxx)
  • NFS is not supported on My Cloud EX4
  • NFS Service is enabled by default on My Cloud (firmware and cannot be turned OFF and ON
  • Multiple or “Range of IP address” configurations are not supported
  • SSH command line configuration and modification of NFS related files are not supported

If one is using a My Cloud device that is running the OS5 firmware, see the OS5 User Manual for more information on NFS and how to enable it.

My Cloud OS 5 User Manual (HTML)

A search on NFS topics in the OS5 subforum section may yeild more information about OS5 NFS support and what if any updates were made to it in the OS5 firmware.

WD Product Software Support Status

Yes - NFSv3 with public access is the only thing just barely working - just as it did in WD OS2 2014… (NFSv4 has been around since 2012…, the problem with NFSv3 is not NAT’able (depending on random ports and UDP in its most basic form… (as in “WD form” - on top of that * Multiple or “Range of IP address” configurations are not supported, making it impossible to secure in any decent way)

… since 2012 internet came along and “Cloud” is a word WD uses so I unfortunately expected these basic things to be in place now 2021… and 3 major OS versions later - especially when going for the PR (PRO version just to ensure things like this are not blocked to end-customer) I guess $2500 just went down the drain for me…

A good number of My Cloud models (7 out of 13) are end of support and won’t see future firmware updates:

If you have a My Cloud model that supports OS5, then see (if you haven’t already) the dedicated OS5 subforum ( for your device and see if there is further information on NFS support, and or if it has even been updated with additional features in OS5.

Otherwise if one wants support for things WD, for what ever reason, didn’t include (or hasn’t ever updated to (newer versions, one can try their hand at rolling their own firmware using the GPL firmware (if available) for one’s My Cloud model.

Yes I got OS5 with PR4100 and 4x10tb 3 days old and already redundant it seems, yes I have checked that OS5 forum, there is no info there, mostly posts on how you roll back to OS3, the manual has no info either, support chat hang up on me after waiting 37 minutes,

but I do thank you for the information from OS2 that you posted it seems it is still valid, and seems to confirm I have have some ebay selling todo…

Personally (if keeping the unit - and it was missing a critical feature/option) I’d give it a try on rolling my own firmware from the GPL firmware, if I had an expensive multi bay unit like the PR4100. That way I could update the various modules, or include new one’s, that WD hasn’t or won’t update.

Latest OS5 GPL firmware for the PR4100:

WDMyCloud_PR4100_GPL_v5.10.122_20210224.tar.gz -

One can roll their own third party apps GPL’s as well to include updates WD hasn’t included in its versions of the third party apps. See the support page for your device for those GPL files.

I will certainly look into that path forward, thanks for advice Bennor !

After two weeks of trial and error it seems like dropping OS5 and everything WD- and go with FreeNAS is the way forward to get some value out of this hardware, first need to upgrade RAM to 16GB, ill post back with results here.

Friends, try FreeNAS - runs right out of the box on PR4100, does everything as WD does - but better and
then a 100 things more… I just swapped - i got everything working within one singe night, that i have spent weeks on struggle with support and forums to try get working on WD OS5…