New Release - WD My Cloud Firmware Release 3.01.04 (11/5/2013)

WD is pleased to announce the update release of My Cloud Firmware Release 3.01.04.

  • Please follow the instructions when doing the update.

Please feel free to post your questions and experiences in this thread.

1 Like

What’s new! 
Firmware Release 3.01.04 (11/5/2013)

  • Resolved issue to access shares through remote web access from Windows XP computers.
  • Resolved issue in some instances where Twonky® does not correctly scan for media files.
  • Resolved issue of slow file transfer performance or intermittent remote web access connection.
  • Resolved issue of USB external drives that are not mountable when connected to the My Cloud USB expansion port.
  • Resolved issue of WD My Cloud™ mobile app is not able to connect to the My Cloud drive.

So I did the upgrade, it was successful and the drive initialised fine.

Then I was happy for around 30 minutes, when I had to soft reboot. It seems it does not like the idea to come back to life again - stuck to white light.

Going to bed soon and leaving it on through the night. Option: if it is still like this in the morning maybe I’ll be determined enough to throw it away after all. It broke my bones and I lost too much time during the last few weeks anyway.

I wish I could apply this. My dashboard no longer works. It worked fine when I installed the box two weeks ago. I’ve tried reinstalling the software and resetting the box. Any idea why Dashboard wouldn’t run?

Bill_S wrote:

WD is pleased to announce the update release of My Cloud Firmware Release 3.01.04.

  • Please follow the instructions when doing the update.

Please feel free to post your questions and experiences in this thread.

Great, But.  I drove over a hundred miles to purchase a new 3T WD My Cloud in an emergency. Could not get it to install. Telephoned support and explained the emergency.  They promised I would be called back right away. Nothing. Emailed support, explained the emergency again. Received an email from WD with online survey. Explained the emergency problems again. Still no phone calls and no emails from WD. They promised 1) right away, 2) by the next business day. Its been a week. Nothing. Can’t get my WD My Cloud up and running, can’t risk accessing my files from the 2nd failed 2T My Book until I can get my legal files transferred over to the 3T WD My Cloud.  Can anyone out there help me, Please?  Thanks for your time in considering my request. lawcorner.


It woud be more helpful to explain what your issue is.

What is the MyCloud doing or not doing?  What are you trying to do that’s not working?

I had the same problem… i upgraded…rebooted. the drive got stuck at the white light…

tried a whole buch of stuff… eventually was able to access the dashboard but it stayed at initializing…

Alarm showed, unable to mount data volumes…I LOST ACCESS TO ALL OF MY 1.8TB OF DATA.

luckily i still have my second old MBL drive that still had my stuff… I tried a whole bunch of stuff on the wd cloud drive…

Luckily i had just gotten the drive a week ago… took it back to the store and returned it…

Same error here, WD support didnt even answer in the last 24 hours.

  1. Everything worked fine

  2. Installed the new FW still worked well

  3. Set some users and renamed some directories in web ui

  4. Directories name did not change on the drive, so I restarted the Cloud

  5. Worked, but it was pretty unstable, for example I tried to login the web UI, and it accepted my password, saw the main page (users, shares, etc) and just throw me back instantly to the login page, and asked for my password again. I tought I might set wrong password (but it accepted it)

  6. Reseted the router (pressed button for 40 seconds)

  7. Cloud restarted, blinking yellow led, and did not see the router, and router did not see the cloud

  8. Reseted again (40 seconds)

  9. White led (booting), ethernet was working (blinking green),  I was happy and waited to boot up. Waited 40 mins, nothing happened, so I went to work, and after a day the led is still white.

  10. Now I try to reset, but it seems it does nothing anymore, not even when I press the reset button for 60-100 seconds.

My problem is that the Cloud was only 5 hours old when got this error, and the cost of RMA is pretty much in my country, and I am verry frustrated, because they didnt even answer me. :frowning:

I am still having issues with my MyCloud disappearing off my network and having to reboot it to get it back. 

Can’t web into it, can’t ping it, can’t ssh into it, doesn’t show up in DHCP table of router.

Have entered case in support.  

Please share if you’re having same issue.  Seems there was a thread in 3.01.03 firmware of people having this issue.

The stuck on white light happened to me when I tried to reboot.  Doesn’t turn blue.  Unable to ping.  Here’s what I found out.

It seem to be related to heat.  Don’t reboot immediately.  Power it off.  Wait 30mins or more.  The idea is to let everything cool off.  Then power it on.  Give it 10mins or so.  Cross your fingers.

1 Like

Umm, heat…my cloud’s case wasnt even tepid. (HDD was max 49°C)

New Cloud is online since Thuesday, and I’m afraid of rebooting it, thats not cool  :frowning:

Unbelievable! I just upgraded and after rebooting, my device is bricked! I’m so frustrated! What is wrong with the development team for WD?! With these complains, they should pull the firmware. It’s bad enough that they’re horrible at bug testing (and probably development), but to allow it to persist like this is just negligent.

I managed to remove the overlay for the web interface and disable/enable SSH. I then got access to the drive and saw that fsck.ext4 is using most of the CPU resources. It seems it’s doing a file system check?! What kind of a check, a sector by sector deep scan of my 3TB drive using a 80MB/s (at best) interface? That’ll take at least half a day!

Update: While the fsck.ext4 task was running, I proceeded to add Transmission and did apt-get update (BUT NOT UPGRADE as I have heard that it can update things that end up breaking WD). About 15 minutes into the procesess, the fsck.ext4 task ended (assumed completed) and the device finished booting (which includes mounting the ext4 partition). Everything returned to normal. However I’m afraid to reboot my device.

You can skip that one too, because I let my NAS working for 32 hours with white led, and nothing happened.

Anyone who has experienced issues with the new firmware had any luck troubleshooting through Support?

I submitted a case on the web.  Never heard back.  Tried to call and just see if they are working on a patch.  The rep. tried walking me through all the steps, one by one.  I was not able to do so because I am not on same LAN.  MyCloud is home, I am at work.  Fear that the whole process will eat up hours of my life and end fairly unfruitfully.

BullZeye, why don’t you try my technique of disabling then renabling SSH. You have to first remove the overlay when signing in (you can do this via Chrome using developer tools inside the menu). Then you may want to try killing the fsck.ext4 task or at least sending a quit signal to it. Maybe it’ll finish booting for you or you can manually mount the ext4 partition to recover your files and then do a full reset.

Once the overlay is removed, you may also be able to reset the software on the device (just don’t mix it up with wiping out the drive).

I don’t think it’s wise to kill fsck – it’s doing it for a reason.  Checking the boot logs would tell you why, and killing it may do more harm than good depending on what it’s doing at the moment you kill it.

Any news about the new FW upgrade that fixes white led problems? I’m afraid of rebooting the NAS, or putting on family pictures…

I have rebooted a few times and have had no further issues. Perhaps the first reboot after installing the firmware is done without properly dismounting the drive causing fsck to run on the next reboot. Everything seems to be perfect now. I even got a call from Western Digital about my post. I sent them my logs and they are taking a look. That really impressed me!

I also should add that the day before I installed the new firmware, there was a snow storm that caused the power to fail (I have since installed an APC UPS for my WD My Cloud). Perhaps the new firmware ran fsck because it detected a bad shut down or corruption.

File system check or fsck is a system utility for checking the consistency of the file system. It runs if the OS was shutdown incorrectly as well as periodically as preventative maintenace. It could take a long time to complete depending on the number of files on your drive. For me it took about 20 minutes (I’m using about half of the 3TB of space), and has not needed to run since.

for whatever’s worth. If you saw my other posts, i had bricked my first drive also by updating.

The replacement drive was updated and has been rebooted like 30 times already and no problems.

The failure trend from what i can see is that most people had some sort of mods done to the drive via ssh. Then they updated and instead of the drive being simply getting restored to stock FW. it ended up being bricked with the white light or even in yello / red in some cases.