New Release - Firmware Version 2.01.06 for My Book Live (8/2/11)

WD is happy to announce the latest firmware updatefor the My Book Live. For information about the firmware update, please check out the release notes.

Please feel free to post your experiences in this thread.


I’m trying to install the firmware update but it seems to be stuck.  The light on the MBL is that whitish-purplish color and on the Mybook live page, it says “upgrading” but there is no progress.  It’s been like this for at least an hour now and the progress indicator has not moved at all.  The drive is making access-type sounds.  What should I do?

Well, now 30 minutes later, it all of the sudden finished up and seems to be working fine.  I have a Time Machine backup going now (I’m on Lion) and it seems to be progressing, and all of my other data is intact on the drive.

But that was a harrowing 90+ minutes waiting for the firmware upgrade to finish!

Firmware updated alright. I am having one issue though… At first when I turned TimeMachine back on my “Oldest backup” and “Last backup” times were reporting correctly. Though as the countdown began to start the next one the dates dissapeared and changed to None.

If I check my console, the backup still exists and is at 149 GB.  Though now when I enter time machine there are no backups.  Any ideas as to how to get TimeMachine to start saving to the old backup set?

EDIT: I stopped the backup from running and turned TM off again in hopes that I’d be able to re-connect to the previous set without overwriting anything.



I just FINALLY got the 2.00.35 firmware to install yesterday. Can one of you official types tell us why this firmware was released so quickly after the major release just a few days ago?

Still no upgrade to Twonky 6? Please, focus on the problem with .mkv streaming video. Twonky v.6 works!

All good here. Performing a time-machine backup in Lion as I type.

Thanks to WD staff for their hard work on the update and the excellent communication throughout. We are lucky to have access to a forum like this that is frequented by WD experts.

I’m trying to install the firmware update but mine too looks to be stuck.  The light on the MBL is the whitish-purplish color, and on the Mybook live page it says “upgrading” but there is no progress.  I left it overnight, so this has been going on for about 10hours and counting…  The progress indicator has stopped moving at 1/10 of the way…   What can I do to make this complete?  When I go to the finder I am able to access the public folder on the drive.

From my observation of following this closely;

It was planned out and we were told this would happen. They were waiting on Netatalk 2.2 to be finalized before they could release the OS Lion fix, and it was finalized late July, got their testing done and released ASAP. The major update prior to that, was for the major changes to Mionet no longer being utilized and other items, that was already planned out before the OS Lion issue, so instead of the unknown release date of Netatalk, they decided to pull the trigger on the major update, and it just so happened that third party Netatalk finalized their product, allowing WD to address the OS Lion problem.

Joel… im not an official type but as a Mac user I know WD was pushing to get OS X and Time Machine support working for Lion users. See release notes below.

Firmware Version 02.01.06-26

Resolved Issues:

• Resolved issue with Time Machine incompatibility in Mac OS® X Lion™ update 

• Resolved issue with incorrect Japanese language translations 


Has the Time Machine incompatibilty only been resolved for the backup volume on the MBL?

I have a sparsebundle sitting on another volumn and when I try to backup with TM I get the following message:

Time Machine could not complete the backup.

The network backup disk does not support the AFP features.

The firmware has only been updated for the MyBookLive, what drive are you using?

I’m using the MyBookLive…

Sorry when I say volume I mean share…they referred to volumes in osx.

So I have a share that is separate from the preconfigured backup share where I have manually created a sparsebundle for Time Machine. When I select this share for TM I get the message posted above.

It worked fine before upgrading to Lion. I assumed that this firmware update would sort it.

A suggestion. During ther update process get the LED on the front of the MBL to actually do something to show that the update process has not halted. Maybe a specific sequence of flashes?  Something like three flashes and then a short pause?  There is not a lot of reassuring feedback to show that the update is actually happening.

I was on 1.02.03.  Went to dashboard, settings, update, check for update.  Found new version and clicked install.

MBl downloaded and installed 1.05.07.  Update was flawless, MBL correctly rebooted when finished.

Then went back to dashboard, settings, update, check, and it’s stuck on the “please wait” progress circle.  I’ve rebooted the router and still not working.  I suppose I will just get the manual download file to go from 1.05.07 to 2.01.06.

Did you perform the update right after the previous update?

Do you have a lot of data on your drive?

If so, that may be the issue. When an update is performed, the firmware has two copies of itself in a Raid array. When you do the update, it breaks the Raid and updates the firmware. Once the firmware updates, it re-establishes the raid and re-synchronizes itself. This can take up to 20+ minutes for that process to complete. Usually it is a matter of time before it will resume.

1 Like

well after 1.05.07 update I shut off the laptop and left the house for 6 hours while the WDC finished whatever and went to sleep (set to 30 minutes)

came home, went to dashboard, MBl woke back up, and still no luck.  I’m trying the manual update now and it’s been stuck on the Importing File prompt for 15 minutes.  I haven’t rebooted the MBL since the auto reboot after 1.05.07.

error.  KB 5657.  not sure what that is…

cman, I am experiencing something similar to you.  I also do not have a large amount of data, about 10% usage.  I have rebooted a couple of times after the first successful update to the same version yours updated to.

However,  I was unable to update to the next one.  I’m at work now so I will attempt again when I get home but would like to see a solution if someone else finds a fix.  Just hangs when “Checking for update” or “Importing File” for a manual update.

Also after the first upgrade last night, it was stuck on the yellow light for a long time, had changed back to green when I woke up in the morning and turned on the computer, still could not update to the latest version though.

well on a whim I tried the “find updates” from settings menu again and it looked like a dead end but it eventually came up with the install screens for 2.00.35.  Agree to uninstall MioNet, etc.  So I went ahead with that, but now it’s frozen on the please wait screen again.  could just be a big file?  I dunno, guess I’ll let it keep spinning over night.