New Release - Firmware Version 2.01.06 for My Book Live (8/2/11)

Cool, I’ll try to be patient tonight and leave mine spinning for lengthy hours / half a day before I touch anything.

For those having trouble updating, try this (assuming you have access to a Windows PC):

I couldn’t get a previous firmware update to work via the UI (browser) in Mac OSX Lion (Safari/Chrome) nor in Windows (IE 9). I tried both the auto update and from file methods. In the end, I got it to work via the Smartware software in Windows. I installed the latest version of Smartware, rebooted the drive, then when I clicked on the icon in the taskbar there was an “update” option listed under the drive. Click on update. Nothing obvious happens, but when you click on the taskbar icon again in the popup it should say “dowloading” with a percentage completion, and eventually it will say “updating” with a percentage completion. During the update the LED on the drive should flash red. The whole process took about 30-45 minutes.

http://www.wdc.com/wdproducts/wdsmartwareupdate/NAS.asp

Dear WD

Could you, please, explain, better in release notes, should I install updates one by one or they are cumulative?

What will happen if I manually install latest update without installing intermidiate?

PS: running stock firmware 

After upgrading to the latest firmware I have an odd problem that might be an IOS problem. I use SmartStor FusionStream ( http://itunes.apple.com/us/app/smartstor-fusion-stream-dlna/id410280827?mt=8) and TwonkyMediaAPP to access my files from the MyBookLIVE DLNA Server to stream movies to my IOS devices.

I also use my XBOX 360 to access the files on the Twonky Media Server. My XBOX, PC, MAC all see my files and can access them, but all of my IOS devices (IPHONE4, IPAD2, IPHONE3G IPOD4 Touch)can no longer see the Twonky Media Server, doesnt even show up in the list of DLNA servers.

Is this because of the Apple change to their AFP fileserver or did something get modified in the MyBookLive firmware that changed this?

In the UI for MBL, shows that the devices are listed, and I have even done a rescan of devices.

Anyone else having this problem?

You can install the latest firmware - everything is cumulative. I know with the flurry of releases it can get confusing, but yes they are cumlative. Please note that if you download the file off the web site, you should take note that we are moving the remote access from MioNet to WD 2go, so you will need to download a new WD Photos app and the new WD 2go app form Android market place or the App store.

Has the Time Machine incompatibilty only been resolved for the backup volume on the MBL?
 
I have a sparsebundle sitting on another volume and when I try to backup with TM I get the following message:
 
Time Machine could not complete the backup.
The network backup disk does not support the AFP features.

 I’ve now sorted by problem out…

I used shh and found the location of the MBL backup volume and the name of the sparsebundle created for Time Machine. I then created a new sparsebundle and then used rsync to replace the orginal sparsebundle on the MBL.

For those of you wondering why I wanted to do this it’s because the default size of the sparsebundle will be the maxium size of the partition you select for Time Machine - in my case 2TB. I only have 200GB to back up from my laptop so created a smaller sparsebundle for Time Machine.

If anyone wants a step by step guide then let me know.

easey-peasey, and my MyBook Live works with Time Machine again.

Always have to do a manual upgrade, but that’s a small price to pay in order to have Time Machine working again.

Thanks!

Agreed.  My upgrade was a harrowing 90-minute process that I thought would never end, or, worse, require me to restore the drive to factory state, but in the end, it worked.

I’m very pleased to have my Time Machine backups working again.  Thanks to WD for getting this update out so quickly after the Lion release.

Don’t understand, WD work so hard to get the firmware done, but make so hard for user to install. I tried various ways, still no luck on install the new firmware. :cry:

I informed Twonky (of my previous issue posted), and their response was

Kiran, Aug-05 02:46 (PDT):

Hello,

Thanks for reporting this issue. We are working on it and will get back to you soon.

Thanks,
Kiran

Hi Lymedo,

I have the exact same problem as you did.  And I did it for the same reason.  Would be most grateful if you could send me your step-by-step directions.

Cheers.

My upgrade worked flawlessly, and took less than 20 minutes. No issues noted so far. I do have a Time Machine back up (From Leopard), and a SmartWare backup as well as iTunes and photos on the device. probably 25% used so far of a 2TB box.

I agree, Thanks for the fast update to 2.01.06

Yeah, post your step-by-step so other can learn

Thank you WD for getting the Firmware out to us.   We do appreciate the trouble this has caused us, and apologize for some of our impatience.   Your support is greatly appreciated.    Again, thank you!

You are welcome.  Obviously, situations aren’t always perfect, and we’re not always perfect, but we do understand and sympathize with the frustrations you go through.  We’re glad when we can turn things around, and thankful that you appreciate it when we do.

2 Likes

Bill S,

Were you able to check out my issue with the DNLA Apps (on IOS devices) that cannot access twonky after the update? XBOX had an system update and is able to see the devices, but none of the IOS apps can.

Looks like my problem was back-to-back upgrades.  I tried to cram them all in one night.  This worked (but took substantial time) up until the 2.01.06 update.  How I ended up resolving the problem was unplugging the MBL (as I don’t know of another way to reboot it when it’s locked in a unmoving upgrade), plug it back in, leave it alone for a day.  When I came back from work and tried installing the upgrade last night it worked.  Timemachine is now back up and running and all is well.  It would be great if WD could provide some better upgrade instructions on their web-site.  As well as maybe having the GUI upgrade button make the MBL straight upgrade to the latest version of the firmware, as opposed to step us through incremental upgrades.  I would also like to mirror some of the feedback from other posters, with expressing a big thank you to WD for the super fast firmware upgrade.

whitewater2 wrote:

Bill S,

 

Were you able to check out my issue with the DNLA Apps (on IOS devices) that cannot access twonky after the update? XBOX had an system update and is able to see the devices, but none of the IOS apps can.

That’s because Microsoft probably wrote an app to work as a discovery service for the XBox to access Twonky.  iOS don’t have any discovery service to make them dnla compliant.  Apple would have to write something.  However, you can download and use WD 2go to access the My Book Live from any of your iOS devices.  With this update we got rid of MioNet and replaced it with WD 2go.  I think you’ll find it far better for serving up your music and other files on your iPhones, etc.  Now, WD 2go doesn’t work with Twonky, but it will access any folder on your MBL as long as you have the permissions set for it.

hello bill, can you give me an indication when the new firmware will be available for the my book white light? unfortunatelly i cannot use the timemachine on my macbook, but i think you already kwow about this problem ;-). in advance, thank you for your answer! erik.