Notice (9/30/11) - WD Still Working on Firmware Update for My Book World

Due to requests from some of our users for a thread to consolidate posting until the firmware update is released for the My Book World, I’m opening up this thread.   Some considerations:

  • We had to pull firmware version 1.02.10 due to networking issues with certain networks.
  • Though that firmware was meant to fix the AFP issue with Lion for Time Machine, we are now looking forward to that fix in the next firmware update.
  • Understand that any work-arounds discussed in here is really at your risk.  If at all possible, make sure you have secondary backups for your data.
  • There will be no ETA, since it all depends how things go with testing.  But (and that’s a big but), I do know we are pushing to get it out ASAP.

Please feel free to use this thread to continue your discussions for the My Book World.


Is there a way to downgrade to the 06 version ?

I don’t think so.


  • 2 weeks to think about it??
  • company policy by Pied Piper
  • my last WD purchase !!!
1 Like

Muy mal wd, muy muy mal

2 semanas para solucionar un problema? ( y lo que queda).

WD----> 0$


I’d rather they think about it than kneejerk and put a fix out that breaks something else. 

Bill, while I appreciate the work you are doing here, I really have to say that this doesn’t put a very good light on WD.

All these problems WD is having with getting the MB World in a workable state again doesn’t shed a very good light on the lifetime of the device - is the MB World becoming legacy soon? Is it a product that will be phased out in a few weeks anyway?

Granted, WD does have a competitive advantage as no other NAS vendor has a product on the market that could compete with the MB World/Live family in price for the same feature-set. But the MB World is still on sale at many shops, is still regarded as a product with a very decent value for the price, not taking the available optware extensions into account.

Me personally, I can’t rely on hacks or other ways to make my drive workable again. So I’ve been like a sitting duck here, not willing to risk my drive and its data by downgrading the firmware and waiting for a fix for the fix.

Considering that I could’ve been able to get timemachine running again by installing a more recent netatalk version via optware, bypassing the firmware update entirely, this is even more frustrating.

So what you got here is an official firmware breaking an otherwise functioning product for a lot of users, who are gathering on these forums with many more just reading along, not wanting to jump through the hoops of registering just to say “yeah I suffer from this too”.

I’d really appreciate if the exact problem could be communicated much more openly, making the actual progress of the new firmware a more transparent effort. Would it really hurt to tell us the technical details of what the actual problem looks like (having an IT degree with specialisation in network technology I’d really like to know what those ‘timing issues’ are that make the network interface not being able to renew its DHCP lease), what the engineers are trying to do to fix it and how far we are into the testing phase? I for one could just refresh the respective thread once a day and get at least the feeling that the problem is really being worked on with the utmost effort.

1 Like

Honestly, Juno75, I don’t have an answer for you.  All I can say is that we do realize the hit we’re taking on this.  Moreover, because of the firmware we released, there’s no doubt for me that we’re committed to fixing it.  But concerning transparency, that’s a hotly debated concept.  Anyone that works in as competitive a field as we are in, knows the potential risks involved.  I think over time, we, like so many other technology companies, will learn where we can loosen up our communications and where we can’t.  And, hopefully, our users will learn that too.  In this case, our acknowledging what the issue was is a big step forward in being as transparent as we can.  I’m sure there will be more to come. 

1 Like


If I can just say, I had this problem, raised a ticket with WD and an extemely nice lady from WD Help desk contacted me, did a remote access onto my laptop and performed the downgrade for me, the only caveat being that she did tell me that SSH (which was used by her to access the NAS) was unsupported and she could not guarantee she would be able to implement the downgrade. I guess it took about 5 days from raising the ticket to get this done.

I assume with so many effected users WD will not be able to offer this sort of personal service to everyone, but you may get some joy by raising a problem report with WD, it certainly worked for me.

I (like everyone else) have been extemely fed up with WD’s slowness to respond to the initial problem reports, but I have to say once I got the attention of WD by raising a problem ticket they did come to my aid and fix the issue for me.

So finally WD, thank you for your help, you were slow , but you got there in the end.

1 Like

josem wrote:


So finally WD, thank you for your help, you were slow , but you got there in the end.

With all my problems with that nasty firmware, I’m stil happy replacing my D-Link NAS drives x 3 to MBWII x 2!

Those guys released 7 beta to fix AFP issue as well as support for HDD > 2 TB and then stopped since May 2011!!! Nothing NADA! I was browsing their forums last night and people there have gone nuts!

Thank you for your reply Bill, considering what you said about the competitive field, the amount of secrecy still kept is understandable, but also regrettable. So nothing else to do but wait for the engineers and qa finishing their work…

Does the coming update fix the Bug “too much time for logging on the Device via afp”?
It takes over 30 seconds!

Before the last update it took only 1 second.

I have upgraded my firmware to the latest, 06.10, now my drive is inaccesable, it doesnt even show under connected devices on my sky router, so I contacted WD, and the nice gentleman said I should raise an RMA, and get the MyBook replaced under warranty, but why should we, the end user have to pay, £20 or so at least, to get the old drive sent back, WD should pay postage both ways, its their mess up here. I’m very annoyed at the moment, if there was a way to downgrade the the firmware myself I would, for £20 I could probably get a decent sized usb drive, or even a case for the one inside the MyBook…

regards Chris


Cornishrelic, I feel exactly the same way as you. I only bought it a couple of months ago and was having a problem with a stalled download I thought a firmware fix was going to help. I am surprised that WD would push out a faulty update, but at the same time the tone here at least keeps hopes alive that it is salvageable without returning it. Not to mention the priceless value of my backups…

Glad I have a flickr pro account, will be pushing up all my photos tonight!

follow-up if you dont want to wait. ofcourse theres the “at your own risk” situation.


   Your stalled downloads could be your router rather than the drive itself.   I had an issue early on with this product when it was connected to my network (d-link DI-624).  But, the drive worked fine when connected directly (null cable) to my machine.  Turned out my router could not handle the newer IP protocols.  When I update the router firmware everything worked great.


Juno75 and Bill_S,

     I have my MB World II set to a STATIC IP and the router (DI-624) set to not issue an IP for the MB World II’s MAC.  I still have the network problem where the link keeps bouncing up and down.  I have cleared the condition by power cycling the router.  Connection will last anywhere from a few minutes to 12 hours and then it starts bouncing again.


Bill_S wrote:

Anyone that works in as competitive a field as we are in…


shoud also know that issues like this and extremely poor management of issues destroy completely customer loyalty to the brand. I will not buy anymore WD products for myself or my comany. I guess I will not be the only one…

1 Like

Bill - 

Surely you can put out .06 again, calling it .10A or something so the drive sees it as an upgrade, to apease the masses? Beats having an unusable drive… the work arounds don’t work for me and tech support tell me to keep resetting with a pin which lasts about 45 minutes at a time…

Bill, do you think we could get some kind of progress report on the fix and your testing.  some sense of progress would be nice. even an ETA that gets updated would serve us all well to extend our patience.  ( the greater the transparency, the better we will all handle it.)

or even some details on the cause. (many of us have the technical ability to prevent the causes within our own networks)

having been an architect for a number of product support centers, I can tell you that the black eye you are getting over this is not because you released faulty code, that happens to all technology rich products.  it’s how the organization handles the fallout.  

frequent progress updates, details on what the triggers are, and a generally open attitude would have made all of us your allies in this process.  stonewalling, claims that you are protecting yourselves from other vendors and silence all serve to ratchet up our perception that the difficulty is one of competence (particularly as most of the posters here are skilled technicians in our own right)

just telling us that your people are working on it , without the background

( eg “we’found a trigger in  x y z module that mishandles pink packets and registers an interface error that causes the system to close the interface.  we are now testing a new release in the lab and expect to be testing with a select group of users tomorrow night.  if those are successful, we will try a beta release two days from now” )

something like that would make us all quite a bit calmer and happier.

1 Like