New Home Modem/Router now cant access WDMyCloud remotely from PC


I recently changed my Modem/Router. Previously I had no problem accessing my device remotely from work via my (Windows) PC.

Now although I am able to sign in to my account (proved by succesful login and display of my email address at top right hand corner) I cant access the drive and I am getting the “Can’t connect to WDMyCloud” message. I have tried the “Accept your devices security certificate” option and I have also tried the security settings change (SSL) because I am using Firefox. Still no joy.

The device is up and online - I know this because I am able to access the device from my iPhone (MyCloud app using passcode) - the issue is accessing from the PC now (, which was available before.

Any ideas please?

Depending on your My Cloud Remote Access configuration, you may have to enable port forwarding within the router to pass two port traffic streams to the My Cloud. See the My Cloud Remote Access settings for the configuration and port’s selected then use those port numbers when setting up port forwarding within the router administration screen.

Many thanks.

Gulp…I will have a look when I get home. I assume if this were the issue it is specific to accessing via a PC and would not affect the remote access via the iPhone which is working fine?

The remote access configuration is something one should look at just to ensure its properly configured.

Try a different web browser on the computer if you haven’t already. Its even possible a browser plug in or extension could be affecting the website so if possible start the problematic web browser without plug-in’s and extensions to see if that clears the issue.

Okay thanks again - I’ll investigate both scenarios / suggestions.

WOA !! just tried it in Explorer and its working fine :blush: any idea of the specific plug-in or extension that might be causing the grief in Firefox or is it a case of hunting through the lists in Firefox config to see are there any MyCloud specific exclusions anywhere?

Some have reported having problems with certain ad blocking software, or script blocking software and the My Cloud Dashboard.