Can`t connect to my WDMyCloud

I bought a WDMyCloud 4TB saturday, and have spent the hole weekend installing an move stuff in to it. Its up and running on my home computer, my and my children`s mobile phones, and i have tested the connection no the mobile devices outside my network. Every thing seems fine. But when I want to log inn to it from a web browser, (I have tested Crome and Internet Explorer) it tells me that my device is offline, and Can not connect to WDMyCloud whit some suggestions on what to do. The 3. suggestion is to accept you devices security certificate but when I click on this, I only get Your connection is not private
Attackers might be trying to steal your information from wdmycloud.device
*** (such as passwords, email or credit card). NET :: ERR_CERT_AUTHORITY_INVALID**

There is no were I can go form here.
My setup is by he book, it i ticked off for remote access, it works fine on mobile devices. Have installed it on my computer, I use Windows 7. My only issue is access trough web browsers.

I will be really happy for suggestions and advice. :slight_smile:

Hi @Sokrates_NO

sounds like your device still has the older firmware installed. Please do a firmware update. You will see it on the web interface of the My Cloud, available under http://wdmycloud or http://wdmycloud.local from a Mac (if you onw the one-drive My Cloud). If you onw the Mirror, it would be http://wdmycloudmirror or http://wdmycloudmirror.local

Thanks Joerg_A! It says that i should upgrade firmware and offers a link. But when I try to cklick it, it only says! Ups something whent wrong, pleace try again later, or contact support. This when i sign in from a web browser. Maybe there is an other way to install the uppgrade? I shall try the link when I get home on my network again. **never give up :slight_smile: **

Regards Sokrates_NO

You can download the latest firmware file from the WD Support web site (link below) and manually update the My Cloud via the Dashboard > Settings > Firmware > Manual Update. Make sure to select the correct firmware for your My Cloud since there are two different single bay My Cloud versions (v4.x and v2.x).

Thanks Bennor. Ill try! :slight_smile:

Hm. It says I have the laste updated firmware.
v03.04.01-219 but how do I know if its v4.x or v2.x?

Sorry but I dont know much about computers and stuff :slight_smile:

And the date of firmware installed is Tuesday, February 18, 2014 11:03:07 PM, so I think it needs updating. :slight_smile: But I dont understand witch I should use?

Since you were using v03.04.01-219 then download and try to install the latest v4.x firmware.

It worked! Thank you so much! :sunny: :smile:

Regards Sokrates_NO

Hm. Itsn not working form other internet then my home network…
It still appears offline form my work computer…


Hi @Sokrates_NO

Check the Settings for Cloud Connection in Settings of the My Cloud Interface. If your Cloud connection is “connected”, then check if the user’s email address in Cloud Access Menu is correct, maybe you need to resend the invitation email again.

Hi. The problem isnt solved yet. When I got to work, I couldnt log in to my cloud after all.

This is what I have done til now:

Updated Firmware

  1. Rebooted the device two times
  2. Reinstalled WDMyCloud om my machine
  3. I have made the IPadress static and made it static in my router as well
  4. I have verified that UPnP is enabled.
  5. Restarted my computer again.

But still my husbound cant log in form work. So I have to check as well at work tomorrow.
I have no clue on IT systems, IP, DNS, Gateways, UPnP, etc. Its an miracle that I have done all this and it is still working on my computer! hehehehe. (Better laughing then crying…) bah