Can't connect to WDMyCloudMirror drive remotely & certificate issue

I’m not able to login or access to drive remotely( It gives an error like “Can’t connect to WDMyCloudMirror” and trying to accept device security certificate but it results in connection time out.

Hi dharmesh09,

We have sent you a message. Please check your Community Message Inbox.

Hi Brandon,

I face the same issue - can you please advise?


hey Brandon,
I also have the same Problem. can you help?


Hi dharmesh09,
We have sent you a message. Please check your Community Message Inbox.

I wish people wouldn’t do this. Now we don’t know what the suggestion was or if it worked!

Does anyone else know a workaround for this problem? Brandon seems to have left the forum,

There’s no “WorkAround” but in my case, I have a Netgear AC1750 Cable Modem Router and at least once a month, remote access to My Cloud does not work. I have to reboot the router and everything returns to normal for both the web and iOS mobile app. Apparently, (as i have read in other forums, this router has UPnP issues and looses it’s port mapping every now and then. For me it’s once a month +/- 5 to 6 days. The KBA that I found below doesn’t address router issues, but network reboots are mentioned.

Remote Access - Device Offline or Cannot Connect to My Cloud

Answer ID 4148

Same issue for me, tried the router reboot but it did not help. Anyone else find an option that worked for them?

I too have this same issue, tried rebooting router and MyCloud Mirror to no avail. The Cloud Service is on & connection status is ready. If it make any difference my router is a Virgin Media Hub 3.
Any help would be appreciated.
Thank you

Hi, I also have this issue.
And I have Fixed IP and Port forwarding configured in my router. Everything is perfect configured.
This is a certificates issue with MyCloud website and how they manage this thing to work.
When does this gona get fixed?

Hi again. When is this going to get fixed?
This issues is around for very long time.

I am also experiencing the same issue, this is quite frustrating, please help.

I have the same issue , does anyone know how to fix this.

Hi. Any solution? A month ago I was able to access all my drives, today not a single bit.