Connection issue - no idea what's wrong!

Hi, I have a My Cloud 2 device. Here is what I have going on…

  • I can connect to dashboard using : http://wdmycloud/ link, but even tough I could sometimes connect it from “network” on my PC (Win 10) I cannot now. I have twonky server screen. I think it is linked to the next issue.
  • I click on the settings and cloud access connection status is failed. (It is sometimes connected but I don’t know what triggers. One time I removed ethernet cable and put it back, it worked, the next time I tried, it didn’t for instance). (Should I set up manually?)
  • When I check my modem, the device is well connected to the internet.
  • I get the error can’t connect to WDMYCLoud from browser access:
  • I can access some files, the general files from my computer’s “my computer”, that is on the same LAN (even though I cannot modify or delete anything) but cannot reach the ones I created put under my username. (Do I need to authorise the specific pc with the remote account somehow?)
  • I tried setting my mobile app, I can access all files even though my computer cannot access anything.

Please help I am going mad trying to figure what’s wrong!

Now that I reached the end of writing once more it established a relay connection and recommends me enabling UPnP - which is already enabled from my modem but there I see nothing related to WD.

@rosengela What type of router or modem/router do you have? Who is your internet provider?

In Windows 10, File Explorer, what is showing under Network>Computer?

I am in France with Orange as provider. The router is their standard.

I just set up a static IP and manual ports, now I seem to be connected. Hope it will stay this way! I will let you know!