New Formware - Again?

Woke up this morning to an email notification that my MyCloud Firmware update had completed sucessfully.  Interesting since I have Auto-update turned off AND I had already done the recent 303 update (which, I have to say went well…)   MyCloud dashboard now shows that I am at v04.04.00-307

Anyone know what the changes from 303 to 307 are - couldn’t find any reference to it on WD site…and then there is the mystery of the auto-update when auto-update is turned off…


… of course, that should say “New Firmware - Again?”.

It doesn’t surprise me that there’s an upgrade so recently after such a major change; I’m surprised they didn’t go up an entire version to v5.

But the auto-upgrade when auto-upgrade is turned off is a concern.

I’d raise it as a support job.

Today my My Cloud updated software to 04.04.00-307.  I was previously on version 422.  Not sure why it never

upgraded to version 303.   I’ve noticed on version 303 and 307 the device wakes up and saves the the /var/log/user.log.

From 8:02AM until 9:26AM the system logged 580 of the following message.

2015-09-25T08:02:43.130058-04:00 di=TCG2w1CF6F notice restsdk[6431]: watch.go:109: Stat(), error: stat /tmp/dynamicconfig.ini: no such file or directory

This message is being generated by the restsdk-serverd process.  I stopped the restsdk-serverd and the messages stopped.

I will add more later.


That sounds like tightened security to me: not allowing the use of a credentials file.

I experienced the permissions issue first thing this morning but all seemed OK after a graceful reboot.


Here’s how I made my unit fast again

I’m guessing multiple layers of firmware on top or firmware on top of firmware was my issue.

After my scan completed, the thing is like brand new again.

How long does it take to complete the scan?  Mine is still scanning 3 / 162529 since this morning (about 4 hours ago).  Will it be that slow without typing those command to make it faster?  

After this update to v04.04.00-307

Now extremeley slow been scanning now over a day. now  unable to use DLNA  as it not detected on tv

tried turning off WD Cloud still now joy now have tow wait again for it to scan

got external drive plugged in

Now includes the capacity of the extenal drive and the WD MyCloud as space

 4tb WD MY CLOUD drive Gives following info now

used 4.4 tb and still got 410gb space free?

Diagnostic say OK but only have 12% free and gives warning if no usb hdd is plugged in

I’m still having same problem, not been able to delete or drag and drop into the drive since friday’s update :frowning:

Still waiting for support to get back to me…

We have passed along this information to WD Support.



Just checked it looks like wd have changed the firmware this moring, i guess it’s time to test and see if what wasn’t broke before has been fixed!

This new firmware was a farce the only thing that i noticed was a new web UI which was no use to me as i don’t use it.

Surprise! it Still don’t work! good job guys.


Current Version WDMyCloud v04.04.00-308 : Core F/W

Last Update Tuesday, September 29, 2015 4:31:23 AM

To my surprise, a support staff from WD called me today in regards to the issue.  

I eventually rebooted the device twice after waited the scanning for hours without progress.  The Content Scanning is now complete.  It is the first time that I see the word “Idle” in the Content Scan box.  

The WD Photos was not able to show the thumbnails and I wasn’t able to view the picture on my Andriod device.  These problems seem to be resolved now.  I notices the device is now on firmware v04…308

It is finally doing what I have purchased it for.

Thanks for the call from the support team.

Woke up this morning, checked firmware it’s still the same 308, tried to drag a file to drive still having same problem ‘access denied’

I contacted support on friday when this happened today is midweek and still nothing despite a mod on here saying he passed the issue on to someone and me sending more mails to support i’ve heard nothing

I’m getting extremley frustrated now at the lack of so called support from WD you guys should hang your head in shame

This is now beyond a joke i want something done NOW! 4 days I’ve not been able to use this drive that you guys broke with your firmware update.

Firmware Version 04.04.00-308 (9/28/2015)

Resolved Issues: Resolved issue of unable to create new folders or write to folders after firmware update


Thanks but if you look at my post the firmware in my drive 308 and i’m still having the same problems as stated this has not fixed the issue that WD created.

It is still broken even with the new firmware even after reboots after the 308 firmware even after shutting down the device it still don’t work

Updated to .308 yesterday. I keep ALL media settings to off; all shares and Media in settings off. However after 24 hours the drive never sleeps. I checked that the Drive Sleep option is ON as before. But LED is always on steady blue.

Look at the /var/log/user.log you will see that the restsdk-serverd is generating a message frequently enough

to not allow the device to sleep.  Go to /etc/rc2.d and sh S20restsdk-serverd stop

That will help.


rac8006 wrote:

Look at the /var/log/user.log you will see that the restsdk-serverd is generating a message frequently enough

to not allow the device to sleep.  Go to /etc/rc2.d and sh S20restsdk-serverd stop


That will help.



This is what’s in that log

2015-09-30T08:01:05.953176-04:00 di=fCsfuU9oQi notice logger: exit standby after 197 (since 2015-09-30 07:57:48.398463001 -0400)

2015-09-30T08:01:16.896283-04:00 di=fCsfuU9oQi notice logger: Rotated atop, atop_size=9236092 atop_upload_size=2327

2015-09-30T08:17:34.306393-04:00 di=fCsfuU9oQi notice logger: exit standby after 8 (since 2015-09-30 08:17:26.878463001 -0400)

2015-09-30T08:47:32.360416-04:00 di=fCsfuU9oQi notice logger: exit standby after 8 (since 2015-09-30 08:47:24.928463001 -0400)

2015-09-30T08:58:10.431972-04:00 di=fCsfuU9oQi notice logger: exit standby after 26 (since 2015-09-30 08:57:44.348463001 -0400)

The log does show that your device is going to sleep.  Problem is its waking up a few seconds later.  On my device

after the upgrade to .308.  I let the system run for about 12 hours before I started looking at the logs.  I did the following command  grep exit /var/log/user.log.  There were no exits in the log.  All I had was error messages about a missing file

used by restsdk-serverd.

I would run top to see if anything is using a log of cpu.  You log shows that the device woke up at 8:17:34 and did something until 8:47:24.  Could your system still be indexing files?