Netflix doesn't work since updating firmware


#1

Okay, I was told to post in the Firmware section so this is essentially the same as a thread I have in the General section. I also posted in an earlier thread about firmware bugs but received no response. I apologize in advance if this is out of place.

I am unable to use Netflix since updating. I deactivated the hub on my Netflix account and have tried to reset the services on the hub but I don’t think the “reset all services” option is resetting anything. When I try to access Netflix it says “connecting to Netflix…” then “Retrieving files…” and then I get a message saying it cannot connect and I should try again later. If the services are actually resetting I should get asked to login to my Netflix account. Any ideas, I really don’t want to reset the entire hub.


#2

Hmmm.  I’ve never seen it say “Retrieving Files.”   I wonder what THAT’S about.

Start by making sure your firewall on your router isn’t blocking anything to the WD…


#3

It’s the Netflix startup screen that says that. Nothing was blocked by the firewall prior to the firmware update and it doesn’t appear to be blocked now. The hub has full access to the internet. It appears to me that the Netflix service on the hub has not been reset and is trying to login and failing.


#4

The release note say:

Netflix users are required to re-register their device after this update. 

Did you do this.

Why don’t you want to do a complete reset?


#5

Yes, as stated in the original post i deactivated the hub on the Netflix website and tried to reset the services on the hub. Doing so should allow me to reactivate the device and login to Netflix. It does not.

Originally I did not want to reset the whole hub in fear I would lose my metadata. I have since been told by WD that I should not lose any metadata. I hope this is indeed true. If anyone knows otherwise please let me know. Anyway, I will find out tonight when I give it a shot.


#6

YES YOU WILL!!!

The XML files won’t be deleted, but if you retrieved info via GET CONTENT INFO, the MEDIA LIBRARY that contains certain elements of the metadata WILL BE PURGED, and will NOT be restored from the XML.

CAUTION!


#7

That’s what I thought. I just asked that same question to WD Tech support and they said it would not delete any data at all. Crud! What now?

I have read in several different threads today that many people didn’t have to re-register their devices to access Netflix, they just had to redo their login. The same was true for me with my Live+, no re-registering involved.I think I’m going to roll back my firmware, re-register the hub, upgrade the firmware and then try to access netflix without re-registering.

I wish I’d have tried that to start with instead of followoing the instructions in the release notes.


#8

No problems for me on 4 Hubs after upgrading each one’s firmware. All I had to do was to login to Netflix again.

I really like the new Netflix screen for Instant play.  Shows more info more efficiently. For example, I have all seasons of The Cosby Show on Instant play.  Before, each season had its own icon. Now, all seasons are grouped together. I did have to explain to my wife what S1E2 meant, tho.


#9

Sounds nice, can’t wait to get mine working. Wish I would have tried to just connect after I updated my firmware. Stupidly I tried to do what the release notes indicated. Who knows, maybe it would have happened anyway.


#10

Tony,

Earlier I posted about doing a rollback on the firmware to see if I could get it working. Apparently no one else tried to re-register their device like I did and had no problems. (See 2 posts up)  Any thoughts?


#11

Sorry, ivork…  I have no idea.   

I’m kindof thinking that rolling back won’t do much.  

But I also kinda think that you could have already recovered your lost metadata by now if you had tried the reset from the beginning… :wink:

It’s up to you at this point.  :)


#12

LOL, That had occured to me too. Thanks for your input. :stuck_out_tongue:


#13

ivork wrote:

It’s the Netflix startup screen that says that. Nothing was blocked by the firewall prior to the firmware update and it doesn’t appear to be blocked now. The hub has full access to the internet. It appears to me that the Netflix service on the hub has not been reset and is trying to login and failing.

ivork:  You and I see two very different things.

I don’t see **ANY** text on Startup…

Only a screen that has the “NetFlix” logo, and some bouncing boxes on the bottom indicating loading status.

No “Connecting to Netflix,” no “Loading Files.”

Anyone else see those prompts ivork describes?


#14

Rolled back the firmware and I was able to reactivate Netflix. Everything worked fine. Upgraded again to the latest firmware and I have the same issue. Next, I’m going to rollback the firmware and deactivate Netflix from there and then upgrade the firmware. My thinking is that the new firmware is not resetting my online services like it is supposed to and hopefully the earlier version will.


#15

No such luck. No matter how I update the firmware the latest version will not login to Netflix. I am going to just rollback the firmware and stick to that. I was really looking forward to the Netflix 3.0 interface.


#16

Go to SETUP / ABOUT / ONLINE SERVICE INFO and make note of the Netflix ESN. Is it the same in both versions? You might try calling Netflix with that info and see if they can purge it…


#17

Yup, I’m planning on giving them a call today. I agree, I think it’s a Netflix issue not deactivating my device from their database/records so that I can login with the updated Netflix app. Although, I am curious why it seems to work for so many others. I will post a followup.


#18

Sorry if you already tried it but you can log into your account on Netflix.com and deactivate devices from there.

-edit-
Scratch that, should have read the entire thread and not just the last page!

Disconcerting that the people experiencing the most issues are those who actually follow WD’s instructions the closest!

I’m one of those that simply updated, entered my email address and password and was up and running with Netflix 3.0 no problem.

It doesn’t seem like the new Netflix interface HAS an activation process.


#19

If you’re having issues getting Netflix to work in Canada, can you please PM me your Netflix ESN and tell me exactly what your problem is? You should be able to find the ESN in the About screen in Setup. Please also note roughly what date and time of day you were trying to use Netflix.

Thanks.


#20

I am in the US.