New Release - Firmware Version 1.04.31_B for WD TV Live Plus (4/12/11)


#1

WD is happy to announce our latest firmware update for the WD TV Live Plus Media Player.  

 

Please post your experiences here in this thread.


#2

YAY Netflix 3.0 and search  :)

any idea when we can expect  hulu plus?


#3

bill_s wrote:

WD is happy to announce our latest firmware update for the WD TV Live Plus Media Player.  

 

Please post your experiences here in this thread.

Another 4 hours or so of work time on the West Coast (US) so will have to wait a while to try the update. :cry:

Bill_s, can you say if any of the reported “issues” noted in 1.04.31_V version (those applicable) have been addressed in this release?

Thanks.


#4

@tjkaz

If you click on the link and goto the product update page you will be able to read the realease notes

  Please see Release Notes for details.


#5

Netflix Canada works!  :dizzy_face:


#6

nutbar wrote:

Netflix Canada works!  :dizzy_face:

Is that what you see with the new firmware update?

If you say it works then I think its a bug and soon as netflix finds out it will be removed. I dont believe its official NET FLIX CANADA is not on the new firmwares release notes.


#7

I can log into Netflix Canada, but when I try to watch a movie I get this:

I get the same message on my Live Hub and my Live Plus


#8

Well Net FLIX 3.0 is supported on THE WD TV LIVE HUB

Firmware just released today. The 3.0 might have something to do with Canada.

Netflix users are required to re-register their device when moving from Netflix 2.0 to Netflix 3.0.


#9

Lawrence wrote:

Well Net FLIX For canada is supported on THE WD TV LIVE HUB

Firmware just released today.

Please post your experiences at the link below.  

 

http://community.wdc.com/t5/Firmware/New-Release-Firmware-Version-2-05-08-for-WD-TV-Live-Hub-4-12-11…

Actually, I get exactly the same message on my Live Hub as I get on my Live Plus.


#10

Try giving them a call…

Net flix customer support (800) 585-8131


#11

Canadian dudes are going to be verry happy with the new firmware update Netflix is available in Canada !! lol :smileyvery-happy:


#12

Three questions before I try this new firmware:

1 - Why was the PLUS version released 6 days after the non-plus version ?

2 - Is there any difference between the 2 versions and should we expect the same problems being reported in the non-plus thread ?

3 - Is a direct rollback to .22 possible ?


#13

Lawrence wrote:

Try giving them a call…

 

Net flix customer support (800) 585-8131

I called.  They told me WD TV is only supported in the USA.  :angry:


#14

blueribb wrote:> 1 - Why was the PLUS version released 6 days after the non-plus version ?

I’d guess because the PLUS version needed to have the new NetFlix API compiled in once it got released, whereas the Live didn’t.

2 - Is there any difference between the 2 versions and should we expect the same problems being reported in the non-plus thread ?

I’d guess yes, for the most part… we’ll have to see what users report.

3 - Is a direct rollback to .22 possible ?

Like this?


#15

@ nutbar

Did you reregister your device after the firmware update?


#16

Lawrence wrote:

@tjkaz

If you click on the link and goto the product update page you will be able to read the realease notes

  Please see Release Notes for details.

I read the notes - and not what I asked.  Specifically not what I asked.

For example, do you read anything in the 1.04.31_V release notes about washed-out/too bright screens, purple images, and the litany of other issues/complaints contained within the 18 pages (and counting) of posts under that release announcment?


#17

Lawrence wrote:

@ nutbar

 

Did you reregister your device after the firmware update?

It was never activated on Netflix in the first place.  Under the old activation code system, you couldn’t even log into Netflix Canada, except when there was a bug on the Netflix activation servers from April 1st to April 8th 2011.  I didn’t renew my Netflix account in the bug window, so I missed out.


#18

Still does not work for VOB from network shares!

I’m going to return it back to store


#19

All my VOB’s play perfectly from network shares - as long as they’re in VIDEO_TS folders and you press PLAY on the folder, not the individual VOB files. If I try and play an individual VOB file by itself, I sometimes get stuttering and loss of audio.

WD TV Live Plus

Yamaha RX-V765 AV Receiver (2010)

Sony KDL-46XBR6 (2009)

Current FW: 1.04.22_B

Windows XP & Windows 7

Verizon FIOS Wired 10/100 Network - Actiontec MI424WR


#20

Just received my new WD TV Live Plus and I updated to firmware 1.04.31_B

Using a Synology NAS on wired 100Mbit/s network pressing play on the VIDEO_TS folders:

  1. The menu system does not work–it skips directly to the movie.

  2. The “Options” has the menu option greyed out for every movie.

The movies play correctly, I just cannot get to the menu which is annoying for multi-episodic DVDs and no bonus features.

Anyone having the same issues?