Netflix does not work with firmware 1.04.31_B

After the upgrade to 1.04.31_B, netflix does not play any more. The retrive bar stops before the middle and it does not go any where.

I’m able to play any other internet media, but netflix. Anyone knows how to solve it?

Thank you

In the release notes it says:

General Info:
Netflix users are required to re-register their device after this update.

Did you do that?

Yes, I did. I’m able to  navigate throut  netflix menu, including my sugestions, my instante Queue and every thing else. I’m just not able to watch the show and movies as the retrive bar stops before de middle.

I use to be able to watch it with previuw firmware.

I am also having trouble with Netflix after upgrading to 1.04.31_B.  Initially Netflix was working fine, including the new 3.0 interface with search capability.  Earlier today when accessing Netflix,  I got a tan screen with a message saying my TV Live plus was unable to connect to Netflix, with optons to try again later or cancel.  After verifying that other internet services were working,  I rolled bac to the previous 1.04.22_B firmware.  Netflix began working again, of course without the new Netflix interface.

I tried updating to the new firmware again and the problem came back again.  Again I rolled back to the previous firmware and Netflix works again.

I am totally stumped as to why 1.04.31_B worked initially but later died at least for Netflix.

Any suggestions or assistance would be greatly appreciated.

did you guys try reset to factory defaults after updating the firmware?

Yes I did.  Made no difference in Netflix behavior.


My reset to factory also dos not solved the netflix issue. Firmware has not changed and still shows the latest update.

NetFlix makes use of the AMAZON CDN.   

The failure on Thursday may be responsible for some issues…

EDIT:  Nevermind…  NetFlix has reported that this outage did NOT affect them.

I am having the exact same issue, and I have not been able to downgrade to an earlier firmware…

wxman007 wrote:
I am having the exact same issue, and I have not been able to downgrade to an earlier firmware…

Why not?

Download the firmware from the link below and follow the instructions.

Because I was D/Ling the wrong firmware.  LOL

However, I have now tried both 1.04.22B and 1.04.18B and am still getting the same error.  I can connect to Netflix with every other device on my network (iPad, laptop, Wii, iPhone), and I deauthorized my WD Live+ in an attempt to see if it could be readded, but no joy…any other thoughts?

The same happened to me. With firmware 1.04.31_B it does not work. When I go back to the previus version, it works again.

I have given up and I will wait to a new firmaware realease, hopping they will fix it.