Netflix is gone since I updated Firmwaire to 3.03.13


Same here. I just updated and it is GONE. Netflix is my main reason for using the WD live, and I am not a happy camper this evening!! Help indeed!!

Have you both tried doing a factory reset?

Have done a factory reset, still no Netflix…

Where are ya’ll located?

I have the same problem = No Netflix since last update.

I am located in Denmark, so I know I should not be able to see Netflix. However, I bought my Hub was in the US and it has worked with Netflix so far. I use us-unblock to change my DNS-settings.

What do I need to change now in order to watch Netflix on my Hub again?

I am in Antigua and Netflix is available here so there shouldn’t be a location issue

I actually posted this observation on the firmware 3.03.13 thread (page 3) before this thread was created. I think they removed all U.S. only services to those not in the U.S. I’m from the Philippines and all U.S. only services are gone. To be specific, I have 27 Services on the previous firmware but now 6 which are all U.S. only services are removed (Netflix, Blockbuster, Hulu, CinemaNow, Vudu and Pandora), 1 is added (MLB) and the newly supported Skitter which is also a U.S. only service is not added so I have a total of 22 Services in this firmware.

The question is how they determine if you are eligible for those apps or not. I want to find out so I can get them back!

Giro413 wrote:

The question is how they determine if you are eligible for those apps or not. I want to find out so I can get them back!

How did you install your firmware, through the hub itself or through USB drive? If you installed it  through the hub, I think one way WD can determine our location is through the IP address of our internet connection. Why don’t you try downgrading and see if it will come back and if it comes back and you still want to upgrade to the latest firmware, try upgrading it using a USB drive while the hub is disconnected from the internet.

Thank you! That sounds like the thing to do (or at least try). Where do I get a hold of the previous firmware?

Ok, I found the firmware page. Will definately try this during the weekend and will leav feedback here.

have a good one. :slight_smile:

Sorry for the stupid question but how do I roll back to a previous firmware version?

Here you go:

Thanks a lot, I’ll give that a try when I am home later.


I am in Canada and we do indeed have Netflix. My geographic location should not be an issue. I too udated the firmware over the network and not from a USB key. I will try the above when I am home from work and see if downgrading works.

Roll  back worked and Netflix is back.

Cheers for the help

I am having the same problem, however, I am a U.S. user, I live in Michigan.  Why would my services disappear?  It sounds like rolling back the firmware may work from what I’m reading here, but something else must be wrong.

I also succesfully rolled back to the previous firmware with Netflix reappearing. I then tried reupdating to 3.03.13 from a usb-drive (with the ethernet cable unplugged). I did this to test if my IP address was the reason why the America-only services disappeared. However, even then services like Netflix did not appear. So I am back on the previous firmware. It is really weird that even people in the states are experiencing this problem. I really hope someone will crack this soon.

This is just a really wild thought I had…

Those that can’t see Netflix after the update…

 Check your setup in parental controls…it MIGHT be blocked somehow even if you havent set it to be the update might have done something…like I said it’s just a thought I had. Mainly because i read here yesterday about using the parental controls to block the services you’re not using so you don’t have to keep seeing them in the menu.

just syain’…it could be