Myy Cloud Gen 1 not connecting - please help

Hi recently purchased second hand gen 1 single bay, it powers on ok & has solid blue light, but it won’t connect to my account & I can’t seem to access the online control centre, any suggestions, I have tried the old my cloud website but nothing I have done seems to work, I have downloaded every android app I can see to no avail?

Since the unit is second hand, if it was me, i would do the 40 reset to clear out all the previous owners settings and information.

The 40 second reset restores all the following to factory defaul … Admin user name, admin password, device name, SSH, remove all guest users, all share permission, network mode, remove all alerts, mobile app account association, WD Sync association, Backup jobs, and Safepoint jobs.

After that’s done, then proceed to set it up on my network, with my shares and settings.

thanks for your reply but I have tried that twice, it doesn’t mark a difference, it seems that the websites are down for the older os 3 version

@Solcutter Have you checked the Knowledge Base to see if there is anything there to help? try the link below.

My Cloud (

I’ve sorted it, my bad I hadn’t reset it correctly, it’s now connected & setup just installing a firmware update, thank you all for you help & suggestions