MyCloudOS3 connection issue with My Passport Wireless (NOT PRO)

I am using My Passport Wireless (Not Pro, old version), with a bit old firmware (1.02.17).
Since the WD Green hard disk didn’t survive till 2022, the disk was replaced (and newest firmware doesn’t support that).

The device works perfectly, and can be connected from my Macs, Windows etc…
However the iOS App can’t detect it after all ‘local network’ setting and disable all wifi privacy setting.

The app still has the icon for the 1st gen. My Passport Wireless, but seems have issue.

Is there any minimal firmware restriction for using app or another things to check?

What did you “replace” the disk with - same brand and model? And did you partition and format the disk properly, before installing new firmware on it?

These devices use OS/3.

The OS/3 software is obsolete; and no longer supported.
WD has announced an end to their server support for all OS/3 devices by 4/15 (i.e. next week)

For “current” devices, WD has an upgrade path to OS/5.
Unfortunately, these cool devices (all the MyPassport Wireless models) didn’t make the cut.

( I don’t think there was a formal announcement regarding the MyPassport Wireless. . .but there has not been a firmware update for these things for YEARS) - - -and I think it is off the websites.

@NAS_user Thanks.
I am a little confused, since I con’t need OS3 functions, but need to access file through Cloud app when I connected to the Wifi network of Passport Wireless.
The app seems to support it, and actually requested the local network access, but can’t detect the Passport wireless.
Is it normal?


I tried first with Samsung 840 Pro and it worked perfectly with old firmware.
However it never works with newer firmware.

I will test with WD blue ssd next week.

Is there any ‘custom’ firmwares for use 3rd party SSD?
They released GPL version of their firmware.

The WD Blue NAND SSD series is most probably the way to go. Afaik the disk has to match the controller type on the PCB, however, I can only speak for the Pro series, where I succesfully have replaced a 1TB HDD with a 2TB WD Blue NAND SDD. So partitioning the disk with an ExFAT partion, leave 4TB space unallocated, and reflash firmware via an SD-card may do the trick.

If you have the time and the skills, I am sure you can examine the GPL version of the code and find out, if there is a hardware check. The “compatible SSD brand/model” is just a faster route, if you have that option.

Sorry - - I was a bit unclear in my previous message. Allow me to expand my previous message.
ALSO - I am in no way associated with WD - - -much of what I type is rank speculation.

The WD Wireless Pro “Cloud App” is the WD OS/3 app - - the app that was originally designed for their “MyCloud” line of products.

Their are two components at work here. . . the NAS software (and also the WDWP software) and the WD Server/App software.

About two years ago; WD began a systematic upgrade of their entire software eco-system architecture. For the NAS line, they “upgraded” OS/3 to OS/5. There were two drivers;

  • Elimination of a raft of security vulnerabilities
  • A refresh of the feature set to facilitate eventual subscription services.

At the device level. . . … . . .the software transitioned from a customized version of a woefully obsolete Linux distribution to a customized version of a much-newer-but-still-obsolete Linux distribution.

IMPORTANT: Not all WD hardware could handle the new software (dubbed OS/5); a bunch of older WD hardware was “declared at End-of-life” with the release of OS/5, and OS/5 won’t load on those machines. Note: this is more than just a "planned obsolescence move: Some of the older hardware that was NOT declared EOL had major problems running OS/5. . . . and a number of users reported the devices becoming bricked as a result (much of this involved human error; but the root cause is the fact that the devices can’t effectively run the software)

At the server level. . . . .WD started from the ground up and designed a Fresh! New! app to incorporate the new features of the O/S. . . and to support an eventual subscription software model. Fundamentally, an “old” app was transitioned to a “new” app.

This overall transition has been happening over two years. The final phase is the shutdown of the OS/3 cloud app. . . .which is supposedly happening on 4/15.

  • Nowhere is the WDWP or the earlier WDW mentioned in the OS/5 transition: But I do know the App was the same one I used to access WD OS/3 NAS units. And I do know that the MWPW has not had any firmware update for many years. . . so I think it was silently transitioned to EOL.

  • I strongly doubt either of these wireless devices has enough processing power to handle OS/5.

  • I referenced subscription services: This is speculation on my part; based upon things I was seeing from a year ago. For a variety of reasons. . . .the effort seems to have died; and I don’t see it happening.

  • There is an OS/4: This is for the WD MyCloudHome line of products. Best served to ignore the entire product line.