MyCloud Share has gone missing

I keep video files on my MyCloud drive and access them via a KODI box. I was updating the KODI today and when I finished I see it streaming OK, but was no longer able to access the Folder/Share. Kept getting weird messages that the video file was not available do I want to delete it. I opened the WD Dashboard and saw a icon saying I needed to update the firmware, so me being a non-techie old senior… updated. Had some confusion about the password but eventually found it… but the “MyMedia” share was gone, and a new share called Michael (me) was listed. There’s nothing in that share. So I’m looking to find out where all my files are and how to reinstate them correctly. I did not select any option to delete a Share, I just don’t want to lose it because aside from some videos that I can restore, there are a load of family video clips and event movies that I created over the past few years that are needed.

Hi,

Check inside the dashboard the exact number of shares you have, and also access the Cloud from the computer File Explorer instead of the KODI box.

Sorry for the delay. And thank you for trying to help out. Just wish this stuff was more intuitive. I should point out that I’m using a MAC not a PC. Wasn’t quite sure about what you meant by “access the Cloud from the computer File Explorer instead of the KODI box.” I’m dealing with two problems here, the first and most important one is reinstating the “missing” share with all my video stuff on it. Once thats restored, I should be able to point the Kodi box at the IP of the WD 3TB MyCloud and more specifically, to the “MyMedia” share.

OK, for some reason, I couldn’t access the Dashboard using the normal http://wdmycloud.local/ link, so I typed in the IP of the drive. Seems to access the dashboard. This is a 3TB drive and its showing 2TB free. There are five (5) shares, but the share with all my video files is not showing up. I had tried adding a share with the same name “MyMedia” in hope that it would “connect” but that share is almost empty. Now seems that the media files are there because almost a TB isn’t accounted for in dashboard, but I’m at a loss as to how to restore the share properly.

Was wondering if I should do a paperclip reset? Since I didn’t hear back with further instructions, I did a safe “System Restore” but again… the original “MyMedia” share was not restored.

Anyone else want to jump in and explain how to restore a “missing” share, please do. I really need to get this 1TB of data accessible.

Can you find the missing Share with Mac Finder? Is the missing Share listed in the My Cloud Dashboard > Share page? How is Kodi accessing the My Cloud? Using DLNA or using SMB/similar file access? If using DLNA is the Share configured for Media Serving in the My Cloud Dashboard Shares page?

If one wants to reset the My Cloud they can perform a 40 second reset. More information on both a 4 second and 40 second reset can be found at the following WD Support document.

http://support.wdc.com/KnowledgeBase/answer.aspx?ID=13986

If you are having trouble accessing the My Cloud Dashboard using http://wdmycloud or http://wdmycloud.local then try using the My Cloud’s IP address, for example http://192.168.1.10. One can usually find the My Cloud IP address through their router’s administration screen in the DHCP lease section.

Bennor…

Thank you for trying to help. I’ve made some progress. By using the 40-second fix, the missing share re-surfaced! But… I’m still having an issue with the Admin function. When I click on the drive in Finder, it shows “Guest” and when I try to login as administrator I get a pop-up telling me it can’t be accessed. Maybe you can tell me how to reset the Admin user name and password. I think I’ve tried the obvious method, but it doesn’t seem to be working.

I can’t seem to access the dashboard using the normal IP address or Dashboard using http://wdmycloud or http://wdmycloud.local. You said you can usually find the My Cloud IP address through their router’s administration screen in the DHCP lease section? Can you simplify that for me? How do I bring that up on the mac?
Mike

Perform an internet search for your router brand/model to find more information on how to access your router’s administration page and its DHCP client listings.

One can also try using WD Access to find their My Cloud on the local network if they are having trouble accessing it. For the Mac version of WD Access see the following link:
https://support.wdc.com/downloads.aspx?p=254

My Router is an Apple Airport Extreme Gigabit Tower. I can see WORKGROUP in the WINS tab, but nothing is listed underneath as a WINS Server… should the WDMyCloud be there? The WDMyCloud is hard-wired ethernet right to my Netgear switch.

How is the switch connected to the Airport? To one of the three Gigabit networking ports on the back of the Airport? Is the Netgear switch a “unmanaged” switch or “managed switch”? No you do not input the My Cloud as the “WINS Server”.

The airport is connected to the Gigabit Netgear switch directly from a Gigabit port on the router. This entire system worked up until about a week ago. I have this idea that somehow the WDMyCloud drive(s) shut down on their own and restarted perhaps? I think I have properly reset the drive and the old shares are back in Finder, but I can only login as guest… I have tried various names for the admin login including “Admin” and “admin” so what I need now is some help on trying to reset the admin to default “admin” and the password to default “none” (meaning I don’t type in a password.

The Netgear ProSafe Gigabit Switch is a Model GS108 v.3 and its an “unmanaged” switch.

So I just tried to access the drive via dashboard and it has reverted back to the wrong settings. It tells me I have 2TB free, and does not show the correct “MyMedia” share. I then went into Finder, and clicked on the drive, accessed as guest (see above why) and I can no longer see the correct shares which were listed last night. This is getting crazy. The data is all there showing up after the 40-second reset, and now its reverting back to the wrong share info.

Lets focus on that and not how my switch is connected to the router. The connections I have have not been disturbed and have worked with all the same equipment (router, iMac, MyCloud 3TB, Switch, etc.) flawlessly for at least 18 months. All I did was try to update the firmware, probably should have left well enough alone.

I need help to do the following:

  1. Reset the login for Administrator.
  2. Fix whatever is making the drive NOT show all the data on shares.
  3. Make sure I can get an IP address for the drive.

See the following WD Support document that explains how to perform a 4 second reset which will reset the Administrator password, and a 40 second reset which will reset most of the features/options/settings to default.

http://support.wdc.com/KnowledgeBase/answer.aspx?ID=13986

I’ve done both the 4-second and the 40-second switch deal (up above about 4 posts ago). The 40-Second restored the shares for a while, then it reverted back to the wrong shares… and it didn’t allow me to reset the administrator to default settings. I’ll do it it again… but tell me why it didn’t last 24 hours the first time?

No idea. What version of My Cloud do you have? The older v4.x or the newer v2.x? Have you made any prior changes to the My Cloud using SSH, if so what changes?

As a troubleshooting step one could connect the My Cloud direct to their computer’s networking port and then attempt to access the Dashboard again to view the Shares page within the Dashboard to see if it lists he Share. Also when directly connected to the computer one could use Windows File Explorer or Mac Finder to access the Shares.

Generally once one performs a 4 second/40 second reset the admin password should default to “admin” and the password is blank.

You say everything worked up till a week ago. What changed a week ago? Did you add any new networking hardware, make any changes to the network/My Cloud/router, make any changes to your computer(s) a week ago?

OK… here’s what you asked:

  1. Version - v04.04.05-101
  2. Haven’t made any changes prior to this that I can recall… but it was working before the firmware upgrade and the shares were the same for the past 18-24 months.
  3. Just tried this, still the same; Dashboard shows all the wrong info, 1 TB not accounted for (my media files).
  4. Finder approach still not letting me login.
  5. As noted previously… outside of normal mac maintenance, nothing has happened since weeks ago. The only mistake I made (sigh) seems to be updating the MyCloud firmware. I see in Google that its not always a easy thing to do. Some people have actually lost TBs of data. My data seems to still be there, just have to figure out how to make that share pop up again.

One option is to activate SSH through the My Cloud Dashboard, then access SSH and search through the /DataVolume/shares directory for your missing Share (or missing files). There are various programs like Putty or WinSCP that can be used to access the My Cloud using SSH. By using SSH one will access the My Cloud at the root/firmware level and may be able find Shares that are there but for what ever reason are not being displayed properly by Samba/AFP.

There was another recent thread where using various SSH commands were used to find Shares and their size. One can review that discussion to learn some of the relevant commands that may help them search the /DataVolume/shares folder for their missing content.

https://community.wd.com/t/my-cloud-4tb-is-full-can-not-free-up-space/192273/

Otherwise you may want to contact WD Support directly and speak to WD directly. This forum is generally a user to user support forum.

https://support.wdc.com/contact_phone.aspx

You haven’t made any Changes …but WD did for you with new firmware v04.04.05-101 I own 2 of the same My Clouds and my mistake was to update the firmware on one. It will be a pain and after 3 days of reboots and resets to get it all back working do your self a favor and TURN OFF firmware auto updates

Think I’m going to call WD Tech Support to see if they can walk me through this. I have no clue about what SSH is or what it does… all I saw was a warning about using it. I don’t want to jeopardize losing the files I’m pretty sure are still there. Thanks for trying.