MyCloud Ex2 Ultra will not connect to Desktop App

So I have and odd issue. Up until yesterday everything still worked just fine. Now today I cannot get into WD My Cloud app for Apple OS using a MacBook Pro. Usually it connects right away without me having to do anything. But now I am shown the login screen, where it says underneath that no devices were found in my network. But once I put in my email address and password in, it does find the device, but refuses to connect to it simply sending me back to the login screen with the note that no connection could be established.

Weird thing is: I can access the device through my Finder without any problems and can simply connect through “connecting with Server”. But I am on the road a lot and use the desktop app for watching movies etc.

What I have tried already:

  • Turn device on and off
  • Resetting device via the reset button
  • Resetting my router
  • uninstall and re-install the app

Nothing has worked so far and I am currently just hoping that it “goes away” at some point. Anybody here had a similar issue before?

I’m getting the same thing using Windows 7 on several different computers only with mine it refuses to find the units (I have 2 in separate locations on the same account) or log in. I can log in using the same ID/PW using the web browser but not the dummy proof desktop app my employee uses. Just started this week.

So I actually heard back from some people saying that the desktop app does not work anymore period since the last firmware update about a week ago. I have also tried via my Windows 10 laptop… same issue. Mobile app via iPhone still works like a charm. Maybe they just stopped supporting the app. But if so: where is the alert about this. Is there going to be a brand new app made perhaps?

That would explain it. I have a message in to support to see what is going on. I hope they didn’t discontinue the App but we’ll see. Maybe it is just a glitch in the firmware update.

i have the same issue, contacted wd and they just told me the desktop app hasnt been supported since June 2016 which is bs because it worked fine up until update 2.31.149. told me it wasnt possible to roll the firmware drivers back and that you need to access the drive using the mycloud web portal
https://files.mycloud.com/login.php

pretty stupid they stopped updating the desktop app tbh as im sure alot of people prefered it

Actually it has not been “officially” supported since 2016. But it still worked just fine. I also would not have an issue using the web version, except that you cannot stream anything through but rather have to download anything you want to watch or look at… and at this day and age this is simply not acceptable.

i agree completely…

Ive been trying to find an alternative way to stream files from the nas but even mapping the drive on a external computer still requires the files to be downloaded or opens up the webplayer in the browser window with limited controls, also tried streaming directly to vlc but it wont accept the ftp username & password :frowning:

hopefully someone find a fix soon

Same here the latest firmware renders the desktop app for os x and windows useless only ftp , cloud dash or WD sync work now. They blamed it on my computer but i have 6 WD ext2 in 5 different locations and half of them showed the behavior and 3 didn’t so couldn’t be my hardware. I put a request in for getting the previous firmware bin file and got refused to get one.

Response There is no officially tested way to downgrade/rollback the already installed firmware.

We do not support or in any way advise the customer to do it since this may brick the device and void it’s warranty.

I call that bullshit all in.

There was a security issue with this app, right from the start, every time it opened you gad a security warning, which they could not fix. Guess they abandoned it in
You cant download it anymore as not listed.
I am working on changing to professional cloud service this was a nice idea but WD cant support it at anything other than for home use, as they can spin you all sorts of bullshit. Bussiness would not put up with rubish like this.