MyCloud crashes my Windows 7 laptap every time

I have a Windows 7 laptop with 100s of GBs of data that I decided I should finally back up. I just bought the 3 TB WD My Cloud model, hooked it up to my wireless network, configured it (not very intuitive), and finally got it so I could at least drag-and-drop folders and files into my “share” on the drive. At that point I hooked it up to a wired router with Ethernet cables so I could transfer large amounts of data faster as recommended by a sheet inside the package. By the way, the documentation in the package is virtually non-existent (1 large sheet of icons and arrows with some URLs).

No matter how I tried, my Windows desktop (Windows Explorer) eventually started restarting at the slightest prod. For example, when I first installed the software on my laptop, I moved the installed icons to where I wanted them on my desktop and then right-clicked (wanted to select “Refresh” to save their locations) and Windows Explorer IMMEADIATELY restarted. I finally got it to stop doing that and eventually got the icons to where I wanted and refreshed, but it took a lot of doing. I really do not know how an average consumer could possibly get this product to work; I have a Computer Science degree and have been able to do anything needed with my family’s Windows PCs and laptops for nearly three decades.

After hooking up the drive with an Ethernet cable to a wired router, I dragged-and-dropped all the folders in my Documents folder onto my “share” on the My Cloud drive and everything started to copy. Right off I noticed it was extremely slow copying individual small files (0-64 KB) at about 1 per second (I had 20K files to copy); however, when it came to some multi-GB files I had, it was tearing through them at about 10 Mbytes/second over a 100 Mbps connection for about 80% network utilization. However, while watching the megabytes count off, I noticed the file transfer stopped at 999 MB for 25 seconds, then continued for the next almost 1 GB, then paused for another 25 seconds, etc, and kept doing this until between 9-10 GBytes of total data transferred (not just a single file). I have inserted a screen capture of the network utilization chart produced by Task Manager that shows the behavior, if WD is interested.  By the way, the narrow gap just past the middle is the end of one multi-GB file and the start of the next multi-GB file.

After the about 8-10 GBytes total copying, my desktop Windows Explorer started restarting again and then different system processes spat out windows with errors that had killed them, etc. Eventually, without exception (I tried this four times), I received the “blue screen of death” (BSOD).

At this point, I am ready to return this product to Best Buy. I have 260 GB of laptop data to back up and my wife has probably double that on her desktop, and it is very apparent we will not be able to get this to work. The My Cloud drive itself seems to work, excepting the 25-second pauses (I think it is copying data to RAM and then writing the 1 GB of data to disk during the 25 seconds because I can hear the drive seeking), the near constant Windows Explorer restarts, and the horrific BSOD every 8-10 GBytes of data.

Since dragging multiple folders onto a “share” on the WD My Cloud results in the drive first creating every folder and sub-folders BEFORE copying any data files, I cannot tell where the file copying died, and I am not going to open 260 folders in a hierarchy to figure it out and then try to copy individual files and folders to try to get it to work. I have not got that kind of time.

Has anyone else had trouble like this?

This may be a little late but using it made mine easy to set up, My Cloud │ How it Works. I also read the User Manual prior to setting it up. I bought my My Cloud from Best Buy too, a little over a year ago.

Posted by,
cat0w (USA)

Do you have media sharing disabled?  The media server could be causing issues or CPU bottlenecks on the drive.   There are two BS tasks indexing files and thumbnailing pictures that are terrible.  Most disable them to get better performance.

Also SMB support is terrible on this drive for a lot of people.  10MB/s on fast ethernet is actualy amazing.

Yes, Turn off all services within the dashboard on all shares (Media, Twonky. etc.). As you load up the My Cloud with data the services are trying to scan everything … create Thumbnails, etc… As mentioned above the My Cloud is known to have CPU bottlenecks if everything is running. Also if you have updated your firmware lately I would suggest a “System Only Restore” to get the My Cloud operating at it’s peak (well … kinda), this has helped me several times, you will not lose any data. After you load up the My Cloud then you can turn on the services you want, just be aware that it takes a lot of time for the My Cloud to do an initial scan of everything you uploaded … so be patient at this point in time.

This has happened to me since purchasing the drive in August of 2014. It happens on my laptop and personal computer. After several firmware and software updates by Western Digital it continues to occur ONLY after opening WD My Cloud to browse directories on the drive.  This is unacceptable and should have been fixed by now.


  1. Explorer RARELY crashes to the point it seems like never.

  2. Open WD My Cloud once.

  3. Explorer crashes regularly afterwards.  Many times I can’t even browse a directory or just right click on a file.

how are you copying the files? just use file explorer. all the programs they tell you to install are optional and some have issues of there own.

the slow speed on small files is normal on any Windows system, even if the copy was to a 2nd internal disk