Mycloud access issues

I’ve looked at all the similar posts on here and followed all advice but no joy. Talktalk technical support didn’t understand what a NAS drive was so no help there…

I have a WD Mycloud and Talktalk Fibre150 with WiFi hub and the openreach modem. Mycloud worked fine with BT ISP but now doesn’t fully work with Talktalk which I’ve just joined.

I can: map a network drive to the mycloud over WiFi, works 100%ok

Android phone will connect to mycloud via WiFi, can see and open files but can no longer play music. Doesn’t work remotely over 4G

Iphone wont connect to mycloud at all wifi or 4G

Sonos system also connected to WiFi accesses and plays music from mycloud fine.

Mycloud device dashboard reports it has no Internet connection.

I have: got a static IP for the mycloud. Setup portforward TCP 9080/9443 in the mycloud dashboard and connection settings.

On the WiFi hub I have: setup same portfoward settings to static IP of mycloud. Changed the firewall to allow incoming/outcoming traffic on those ports.

Ethernet cables all 100% quality Cat5e.

Had no problems before with BT so really hoping I can get this working with Talktalk OK.

Appreciate any help!

It would be useful if you explained some of uncommon names you use (Talk Talk / BT ?) . From what I can gather you switched UK ISPs from BT → TalkTalk and now some devices have issues connecting to your WD MyCoud. I would first suspect maybe new ISP blocks SMB v1.0 and maybe your old ISP Talk Talk did not ?

I know nothing about UK options and what UK ISP provide. I suggest you post on UK Talk Talk ISP message board.

First troubleshooting step is to turn off Cloud Access/Remote Access in the My Cloud Dashboard > Settings. Wait a few minutes. Then reenable Cloud Access/Remote access and wait to see what the Conection Status indicates.

If you have changed the Cloud Access setting to Manual and are using port forwarding, then you should check and make note of the the External Port values in the My Cloud Dashboard. Then check the port forwarding settings within the network router and ensure the External Port values (two of them) match what is being used on the My Cloud. One typically uses internal ports of 80 and 443 when port forwarding. Note that the external port values may be different than the internal port value. In some cases one’s broadband provider may block the default external ports used by the My Cloud forcing the user to use alternate external ports while keeping the internal ports at 80 and 443.

There is an general example of how to setup port forwarding on first gen single bay My Cloud (4.x firmware) at this post:

thanks very much for responding!
@thetick yes you are correct: BT is my old UK ISP (worked fine) TalkTalk is the new ISP (does not work). I did also post in TT forum but they are not as quick to respond :slight_smile:
You could be right about the SMBv1 (this is new terminology to me). Online others seem to have had issue with this and fixed by changing TT firewall settings to low or high? from medium. I did try this in addition to @Bennor suggestion but no luck…

@Bennor I did not have it set correctly as you described (I had the same value for external/internal). I think I have corrected it now but sadly does not work still…
I now have:
mycloud>settings>general>cloud access-configure>manual:external1=9080, external2=9443
mycloud>settings>network>portforward>HTTP:external=9080, internal=80, HTTPS:external=9443, internal=443
talktalkrouter>portforward: external9080/internal80, external 9443/internal443
talktalkrouter>firewall custom settings: local port80/remote port 9080, local port 443/remote port 9443
I did also try setting the firewall to default settings of low/medium/high

So what is your latest status ?

I will caution I do not recommend enabling SMBv1.0 as it is an extremely insecure file sharing protocol designed in 1983 to share data between DOS PCs. Reference : SMBv1.0 . No joke it is that old! It exists today because almost every system implemented it until fairly recently. Windows Server 2016 and Windows 10 were first Windows OSes to drop support siting security issues.

After setting up port forwarding one can see if the ports are actually open by using port checking sites like https://canyouseeme.org/.

If you haven’t done so already, you may want to see the TalkTalk article on how to setup port forwarding with their devices:

On the issue of SMB1.0/CIFS, that generally used on your local network and typically not related to remote access issues.

Generally with remote access issues it comes down to one of the following problems.

  • Broadband provider is blocking inbound port traffic to prevent their customers from using servers.
  • The WD My Cloud Cloud Service/Portal website is down.
  • Incorrectly configured manual settings in the My Cloud Cloud Access setting.
  • Incorrect configured port forwarding rules on the router.
  • In rare cases there may be a local network configuration issue/error where there are multiple IP subnets/ranges being used.
  • The Cloud Access/Remote Access service is not enabled in the My Cloud Dashboard > Settings.

Sometimes, particularly when one changes broadband providers and their equipment, it helps to do a 40 second reset which does not affect user data and reconfigure the My Cloud Dashboard settings. A 40 second reset just resets the My Cloud Dashboard settings back to default values.

How to Reset a My Cloud (single bay) Device
https://support-en.wd.com/app/answers/detail/a_id/24022

And on the issue of using a static IP for the My Cloud. Sometimes its better not set the static IP using the My Cloud Dashboard. Instead leave the Dashboard setting at default (DHCP) and instead access the network router and reserve an IP address for the My Cloud within the router’s administration settings for the router’s DHCP server.