[MyCloud 4TB] No shutdown option & sleep mode not working?


For years, I have a 2 TB “My Book Live” (an old one with a lan connection). As it is almost full I just purchased a brand new 4TB “My Cloud”. First thing I did: an upgrade to the latest firwmare 2.xx

It there an easy way to shutdown the device (easy != ssh command :wink: ) ?

I turned off all internal services (DLNA, cloud stuff, auto update…) but the HDD never sleep. It is just spinning 24/7 despite the sleep setting turned on and the fact I do not access it from anywhere. Why ?

It is very surprising as my old “My Book Live”, has a shutdown option in its dashboard, and it goes to sleep after an idle time of few minutes (both devices are in the exact same environnement: my house). Why are these two features - shutdown and sleep - either removed or not working on a newer device ?

Thanks in advance for your answers.


Do a search of this subforum using the magnifying glass icon upper right. Both issues have been well discussed in numerous prior threads. The Shutdown option is missing (hidden by CSS coding) from the My Cloud Dashbaord in the current v2.x firmware for the single bay My Cloud. The current workaround is to either use the WD QuickAccess software which has a shutdown option for the v2.x single bay My Cloud, use SSH to issue the shutdown command, or open up the Dashboard and modify the CSS code each time to unhide the Shutdown option so it can be selected.



The sleep issue affects both the older generation v4.x single bay My Cloud and the newer generation v2.x single bay My Cloud units. There are a variety of methods, mostly using SSH to turn off certain services, to try and deal with the sleep issue. Here are a few prior threads discussing the sleep issue.






Thank you for your answer.

Yesterday, I disabled the NTP service and reapplied the latest bios from a local file as described in one of these subjects. And it worked, the drive went to sleep about 10 minutes later. It stayed asleep about an hour… Then I access it, and 12 hours later it is still awake.

That is enough.

I’ve spend more than $200 on this piece of…hardware. Basic functionalities must be working as intended without the need to workaround or hack into the system. If basic functions - as the sleep one - don’t work, how can I trust the whole thing? That kind of hardware must be trustworthy. It is not.

Moreover, these issues are more than a year old. The latest firmware is more than a month old. Since its release: no official fix, no official message about it. My conclusion is: WD just don’t care. I do not give my money to companies which do not care about their products nor their customers.

I suppose the next FW will remove the sleep option from the dashboard. Apparently that’s the WD way to fix bug, as they did with the shutdown option: let’s hide the option, users won’t see it is not working.

I’ll send back this product, get a refund, and look elsewhere.

1 Like

Did you ever get your to sleep reliably? I am also a new owner and like you I’m not willing to keep this if it can’t sleep reliably.

Yes I did, almost miraculously. I have the package ready to get my refund but I decided to give it a last try (mostly because I did not find any other hardware fulfilling my needs as the MyCloud does).

Somewhere in the settings menu there is an option to reinstall the system - without losing file content. I did it, then I reconfigure everything and in the settings, I disabled everything that can wake-up the MyCloud (ntp, media server…). Then I rebooted the NAS once.

After 24 hours of intense HDD activity, it goes to sleep!

Since then I’ve tried to activate the “extended logging of activities” (which requires a reboot)… and the disk did not sleep anymore. I disabled the “extended logging” (revert to the original setting) - it does also requires a reboot - but it still doesn’t sleep… Even after two days.

I had to re-apply the “reinstall system”, set all the settings again (which include users and password, but not the shares which remain intact), reboot… and the drive sleep correctly after about a day of HDD activity. I did not touch anything since then.

My newly recertified 3tb mycloud frequently wakes up shortly for no reason throughout the day. I have an older WD My Book Live Nas on the same network stays asleep fine. My concern is that frequent spin up and spin down would lessen the lifespan considerably of this drive. Can anyone advise me steps to take that would be great! Thx. I have Cloud/DlnA Services disabled as well as network clock

Look up thread at my post above that has several links to other discussions on how to try and deal with the My Cloud sleep issue. Or use the forum search feature, magnifying glass icon upper right, and search for “sleep” and you will find numerous discussions on the problem with a variety of potential workarounds, most involve using SSH to issue commands to disable certain My Cloud services.

Your first step should be to access the My Cloud Dashboard Settings and enable/turn On Drive Sleep.


It needs some time to rescan content and (except in rare cases) it will sleep. And wake up. And sleep. And wake up. Every. Few. Seconds.

It’s better to leave it work 24/7. It works much better.

It’s either WD people being too lame to improve on that or it is a feature to break down the WD Red inside quicker.

Too bad noone at WD didn’t do that just to “break the system” which allows that. It would be so pro of them.