WD My Cloud randomly wakes up the drive when Drive Sleep is enabled


#1

Hi. Two days ago I bought WD My Cloud 4TB (WDBCTL0040HWT-EESN), and updated it to the newest version: “WDMyCloud v04.04.02-105 : Core F/W”.
Unfortunately, I’m experiencing problems with the Drive Sleep. It randomly wakes up, even when it’s not used, for example at night. I have disabled all features like: “DLNA”, “Mac Backups”, “iTunes”, and even “Cloud Access” for test. It didn’t help at all. I don’t use the WD My Cloud Desktop or Mobile App, only smb on Windows and Android to access the files. The drive is still waking up at night or in day, when it’s not used… I have got very sensitive ears. Even though the drive is not that loud - it woke me up around 3 times last night. I would really like to fix this problem, instead of refunding the NAS.
Here is the last night log (the cloud was not accessed during this time, and the Cloud Access was disabled):
2016-02-25T01:31:51.372614+01:00 di=H10IhkTgem notice logger: exit standby after 8 (since 2016-02-25 01:31:43.738525000 +0100)
2016-02-25T02:17:09.659403+01:00 di=H10IhkTgem notice logger: exit standby after 2107 (since 2016-02-25 01:42:02.318525000 +0100)
2016-02-25T02:28:34.348600+01:00 di=H10IhkTgem notice logger: exit standby after 74 (since 2016-02-25 02:27:20.788525000 +0100)
2016-02-25T02:47:06.380364+01:00 di=H10IhkTgem notice logger: exit standby after 8 (since 2016-02-25 02:46:58.698525000 +0100)
2016-02-25T02:59:51.255567+01:00 di=H10IhkTgem notice logger: exit standby after 154 (since 2016-02-25 02:57:17.408525000 +0100)
2016-02-25T03:16:14.009033+01:00 di=H10IhkTgem notice logger: exit standby after 7 (since 2016-02-25 03:16:06.471949001 +0100)
2016-02-25T06:53:30.678214+01:00 di=H10IhkTgem notice logger: exit standby after 12425 (since 2016-02-25 03:26:25.071949001 +0100)
2016-02-25T07:17:09.898959+01:00 di=H10IhkTgem notice logger: exit standby after 197 (since 2016-02-25 07:13:52.881949001 +0100)
2016-02-25T08:01:09.511267+01:00 di=H10IhkTgem notice logger: exit standby after 2028 (since 2016-02-25 07:27:20.991949001 +0100)
2016-02-25T08:01:19.568527+01:00 di=H10IhkTgem notice logger: Rotated atop, atop_size=3198659 atop_upload_size=8290
2016-02-25T08:40:35.747237+01:00 di=H10IhkTgem notice logger: exit standby after 1755 (since 2016-02-25 08:11:20.721949001 +0100)
2016-02-25T08:58:23.366455+01:00 di=H10IhkTgem notice logger: exit standby after 396 (since 2016-02-25 08:51:47.881949001 +0100)
2016-02-25T09:34:09.196538+01:00 di=H10IhkTgem notice logger: exit standby after 741 (since 2016-02-25 09:21:48.741949001 +0100)
2016-02-25T10:05:24.688940+01:00 di=H10IhkTgem notice logger: exit standby after 1264 (since 2016-02-25 09:44:20.221949001 +0100)
2016-02-25T10:29:54.662875+01:00 di=H10IhkTgem notice logger: exit standby after 859 (since 2016-02-25 10:15:35.651949001 +0100)

And the day log:
2016-02-25T16:37:54.286606+01:00 di=H10IhkTgem notice logger: exit standby after 8 (since 2016-02-25 16:37:41.602290001 +0100)
2016-02-25T16:59:18.859231+01:00 di=H10IhkTgem notice logger: exit standby after 57 (since 2016-02-25 16:58:16.282290001 +0100)
2016-02-25T17:17:09.620577+01:00 di=H10IhkTgem notice logger: exit standby after 455 (since 2016-02-25 17:09:29.912290001 +0100)
2016-02-25T17:40:13.971321+01:00 di=H10IhkTgem notice logger: exit standby after 768 (since 2016-02-25 17:27:20.892290001 +0100)
2016-02-25T18:00:33.325076+01:00 di=H10IhkTgem notice logger: exit standby after 603 (since 2016-02-25 17:50:25.382290001 +0100)
2016-02-25T18:16:03.575815+01:00 di=H10IhkTgem notice logger: exit standby after 8 (since 2016-02-25 18:15:50.892290001 +0100)
2016-02-25T18:29:11.237483+01:00 di=H10IhkTgem notice logger: exit standby after 171 (since 2016-02-25 18:26:15.102290001 +0100)
2016-02-25T18:55:28.837338+01:00 di=H10IhkTgem notice logger: exit standby after 17 (since 2016-02-25 18:55:11.132290001 +0100)
2016-02-25T19:05:57.801571+01:00 di=H10IhkTgem notice logger: exit standby after 17 (since 2016-02-25 19:05:40.182290001 +0100)
2016-02-25T19:20:29.699286+01:00 di=H10IhkTgem notice logger: exit standby after 16 (since 2016-02-25 19:20:13.812290001 +0100)
2016-02-25T19:30:58.680971+01:00 di=H10IhkTgem notice logger: exit standby after 17 (since 2016-02-25 19:30:41.012290001 +0100)
2016-02-25T19:31:12.973476+01:00 di=H10IhkTgem notice logger: Tally daemon not installed, exiting tally function
2016-02-25T19:50:31.444185+01:00 di=H10IhkTgem notice logger: exit standby after 545 (since 2016-02-25 19:41:26.822290001 +0100)
2016-02-25T20:00:49.961751+01:00 di=H10IhkTgem notice logger: exit standby after 7 (since 2016-02-25 20:00:42.732290001 +0100)
2016-02-25T20:14:35.832643+01:00 di=H10IhkTgem notice logger: exit standby after 214 (since 2016-02-25 20:11:01.082290001 +0100)
2016-02-25T20:41:10.608759+01:00 di=H10IhkTgem notice logger: exit standby after 983 (since 2016-02-25 20:24:47.032290001 +0100)
2016-02-25T20:42:22.783336+01:00 di=H10IhkTgem notice logger: Tally daemon not installed, exiting tally function
2016-02-25T21:01:43.358280+01:00 di=H10IhkTgem notice logger: exit standby after 548 (since 2016-02-25 20:52:35.902290001 +0100)
2016-02-25T21:35:09.626208+01:00 di=H10IhkTgem notice logger: exit standby after 1395 (since 2016-02-25 21:11:54.542290001 +0100)
2016-02-25T22:16:42.625212+01:00 di=H10IhkTgem notice logger: exit standby after 1882 (since 2016-02-25 21:45:20.732290001 +0100)
2016-02-25T23:15:50.569421+01:00 di=H10IhkTgem notice logger: exit standby after 2936 (since 2016-02-25 22:26:54.272290001 +0100)

Please note that sometimes it wakes up after 7 seconds or less than 5 minutes, while I’m not using it at all…

I read many topics about this problem, unfortunately I didn’t find the working solution. Someone recommended to modify monitorio.sh and add:
sync
sync
sleep 10
after “touch /tmp/standby”. Unfortunately it didn’t help too - I was just getting “exit standby after 17” instead of “exit standby after 7”…

If anybody knows a solution for this problem, I would very appreciate any help.


MyCloud does not go to sleep/standby - perhaps the solution
Drive Stopped Sleeping
MyCloud won't Sleep after update! Help
Disk standby and (or) shutting down WD My Cloud
WD my Cloud 4TB Harddisk keep running
I have a My Cloud it is NOT hibernating
[MyCloud 4TB] No shutdown option & sleep mode not working?
Was sleep ever fixed on GEN 1 devices?
How can I disable the thumbnail building and scanning?
Pas de Passage en mode veille MyCloud 2To
Firmware 4.05.00-315 Discussion
DLNA drive sleep
#2

One solution is to use the following command. When the system seems to be idle. It is updating the inode atime for the files that is is executing. This causes a lot of kjournal writes to disk.
“mount -o remount,noatime,nodiratime /dev/root /”

RAC

PS the 7 second sleeps appear to be because the files used my monitorio.sh get rolled out during the running of different jobs. When the system wakes up it needs to reload some code or data files.


#3

Dear rac8006, thank you very much for the reply.
I’m not a linux expert, could you please explain me a few things?

When exactly should I put the mentioned command, when the drive is “sleeping”, or it doesn’t matter?
What exactly the “mount -o remount,noatime,nodiratime /dev/root /” does? Is this safe to use, or might cause some problems with the normal drive usage?
If it will fix my problem, is it possible (and is it smart) to execute this command automatically every time time I reboot My Cloud?


#4

This command can be executed any time. It will be necessary to do it on every boot. The noatime and nodiratime are timestamps in a files inode. They keep track of when ever a file is accessed or a directory is accessed. It is one of the things that helps with the sleep issue.

RAC


#5

Thank you for the explanation.
Here is a log from this night, after using the “mount -o remount,noatime,nodiratime /dev/root /” command.

2016-02-26T03:15:36.216135+01:00 di=H10IhkTgem notice logger: exit standby after 8 (since 2016-02-26 03:15:28.589999001 +0100)
2016-02-26T03:32:24.825918+01:00 di=H10IhkTgem notice logger: exit standby after 397 (since 2016-02-26 03:25:47.359999001 +0100)
2016-02-26T04:11:39.094583+01:00 di=H10IhkTgem notice logger: exit standby after 1743 (since 2016-02-26 03:42:36.249999001 +0100)
2016-02-26T05:27:53.768221+01:00 di=H10IhkTgem notice logger: exit standby after 3963 (since 2016-02-26 04:21:50.219999001 +0100)
2016-02-26T06:17:10.343005+01:00 di=H10IhkTgem notice logger: exit standby after 2345 (since 2016-02-26 05:38:05.139999001 +0100)
2016-02-26T06:35:57.807047+01:00 di=H10IhkTgem notice logger: exit standby after 516 (since 2016-02-26 06:27:21.469999001 +0100)
2016-02-26T06:49:27.016695+01:00 di=H10IhkTgem notice logger: exit standby after 197 (since 2016-02-26 06:46:09.499999001 +0100)
2016-02-26T07:48:30.231358+01:00 di=H10IhkTgem notice logger: exit standby after 2932 (since 2016-02-26 06:59:38.039999001 +0100)
2016-02-26T08:01:09.988068+01:00 di=H10IhkTgem notice logger: exit standby after 148 (since 2016-02-26 07:58:41.289999001 +0100)
2016-02-26T08:01:20.099776+01:00 di=H10IhkTgem notice logger: Rotated atop, atop_size=3907618 atop_upload_size=66701
2016-02-26T08:45:29.723414+01:00 di=H10IhkTgem notice logger: exit standby after 2048 (since 2016-02-26 08:11:21.249999001 +0100)
2016-02-26T09:01:31.530733+01:00 di=H10IhkTgem notice logger: exit standby after 350 (since 2016-02-26 08:55:41.309999001 +0100)
2016-02-26T09:47:34.859245+01:00 di=H10IhkTgem notice logger: exit standby after 2152 (since 2016-02-26 09:11:42.589999001 +0100)
2016-02-26T13:12:37.465288+01:00 di=H10IhkTgem notice logger: exit standby after 11692 (since 2016-02-26 09:57:45.949999001 +0100)
2016-02-26T13:42:22.166634+01:00 di=H10IhkTgem notice logger: exit standby after 8 (since 2016-02-26 13:42:14.549999001 +0100)

Seems like it still wakes up at random times, when it’s not used. Are there any other solutions for this problem?

Can I add the “mount -o remount,noatime,nodiratime /dev/root /” to /etc/rc.local so it will be executed after reboot, or I should use some other files?


#6

Do you have any other devices/computers that are active on the local network at the times the My Cloud wakes up? Could be one of your network devices is polling the My Cloud causing it to wake from sleep.


#7

I have got only My Cloud connected to the router, nothing else. The laptop was turned off at night (not in any sleep mode or hibernation - literally shut down). and I also switched off wifi in my smartphone.
Can I somehow track connections to My Cloud, so I would know the wake up source?
Could anyone else share the user.log from ver. v04.04.02-105 with enabled Drive Sleep, so we can compare if it’s my problem, or the problem related to the newest firmware?


#8

If you look into the cron files you will see that the system always wakes up at 3:00 AM this is when it checks for new firmware and other house keeping functions. It also wakes up every 8 hours to do log rotates for atop. Also after the firmware check a random wake up is setup.
As for running the command after reboot. Look at the file /etc/rc2.d/S98user-start. This file does not get changed on firmware upgrade. It gets run as the next to last script on reboot. Below are two shell scripts to display the sleep times in an easier to read list. Save these two files with the name shown above them in the Pulic directory. After they are saved you can just sh sleeptime.sh and it will display the sleeptimes.

RAC

PS The printf statement after Total = Total + $8 should be on a single line not 2 lines.

sleeptime.sh
cat /var/log/user.log.1 /var/log/user.log|/nfs/Public/sleep.awk

sleep.awk
awk ’
NR==1 { a=substr($1,6,2); b=substr($1,9,2); c=substr($1,12,8); y=substr($1,1,4)}
{if ($7 ~ /after/){
hh1=int($8/3600)
mm1=int(($8%3600)/60)
ss1=($8%3600)%60
Total = Total + $8
printf “%2s %2s %8s %8s %5d %2d:%02d:%02d\n”,substr($1,6,2),substr($1,9,2) ,substr($11,0,9),substr($
1,12,8),$8 ,hh1,mm1,ss1}}
END {
hh1=int(Total/3600)
mm1=mm1=int(($8%3600)/60)
ss1=($8%3600)%60
printf “Total Sleep Time: %2d:%02d:%02d\n” ,hh1,mm1,ss1
start= a “/” b “/” y " " c
“date +%Y”|getline year
end= substr($1,6,2) “/” substr($1,9,2) “/” year " " substr($1,12,8)
$1=start
cmd=“date --date=”"$1"" +%s"
cmd|getline st
printf “Start %s\n” ,st
$1=end
cmd=“date --date=”"$1"" +%s"
cmd|getline end
printf “End %s\n” ,end
Total=end-st
hh1=int(Total/3600)
mm1=mm1=int((Total%3600)/60)
ss1=(Total%3600)%60
printf “Total Up Time: %2d:%02d:%02d\n” ,hh1,mm1,ss1
}’


#9

Thank you. I set the /etc/rc2.d/S98user-start file, and got the sleeptime.sh working:

02 26 02:49:56 02:50:04 8 0:00:08
02 26 03:15:28 03:15:36 8 0:00:08
02 26 03:25:47 03:32:24 397 0:06:37
02 26 03:42:36 04:11:39 1743 0:29:03
02 26 04:21:50 05:27:53 3963 1:06:03
02 26 05:38:05 06:17:10 2345 0:39:05
02 26 06:27:21 06:35:57 516 0:08:36
02 26 06:46:09 06:49:27 197 0:03:17
02 26 06:59:38 07:48:30 2932 0:48:52
02 26 07:58:41 08:01:09 148 0:02:28
02 26 08:11:21 08:45:29 2048 0:34:08
02 26 08:55:41 09:01:31 350 0:05:50
02 26 09:11:42 09:47:34 2152 0:35:52
02 26 09:57:45 13:12:37 11692 3:14:52
02 26 13:42:14 13:42:22 8 0:00:08
02 26 13:56:38 13:56:45 7 0:00:07
02 26 14:06:56 14:07:04 8 0:00:08
02 26 14:24:28 14:24:36 8 0:00:08
02 26 14:34:47 14:44:45 598 0:09:58
02 26 14:54:56 15:17:10 1334 0:22:14
02 26 15:30:24 15:39:09 525 0:08:45
02 26 15:49:21 16:01:09 708 0:11:48
02 26 16:11:20 16:25:22 842 0:14:02
02 26 17:04:11 17:04:18 7 0:00:07

I’m just worrying about those short wake-ups, if they don’t decrease the hard drive life.
I checked with: smartctl -a /dev/sda, and it shows:
4 Start_Stop_Count 0x0032 100 100 000 Old_age Always - 114

114 within 3 days isn’t a good score…


#10

Before firmware 105 I could get the MC to sleep 23 hours. Waking up only at 3:00AM. That was when I first got the unit. It is not easy to see why the 8 second sleeps are being done.

RAC


#11

What rac8006 didn’t tell you is the following services are stopped in addition to the mount command. You will need the following:

/etc/init.d/nfs-kernel-server stop
/etc/init.d/nfs-common stop
/etc/init.d/upnp_nas stop
/etc/init.d/mDNSResponder stop
/etc/init.d/wdphotodbmergerd stop
/etc/init.d/wdnotifierd stop
/etc/init.d/wdmcserverd stop
/etc/init.d/wddispatcherd stop
/etc/init.d/restsdk-serverd stop

Kill the above services and your Cloud should sleep between 7 seconds to 82913 seconds (23 hours). The last line is probably the worst one for waking up the cloud but may or may not have been corrected with the latest firmware.

edit: Just checked my ArchiveServer and the longest sleep time is 225,127 = 62.54 hours = 2 days and 14.54 hours


#12

Thanks. I tried:

WDMyCloud:~# /etc/init.d/nfs-kernel-server stop; /etc/init.d/nfs-common stop; /etc/init.d/upnp_nas stop; /etc/init.d/mDNSResponder stop; /etc/init.d/wdphotodbmergerd stop; /etc/init.d/wdnotifierd stop; /etc/init.d/wdmcserverd stop; /etc/init.d/wddispatcherd stop; /etc/init.d/restsdk-serverd stop
[ ok ] Stopping NFS kernel daemon: mountd nfsd.
[ ok ] Unexporting directories for NFS kernel daemon…
[ ok ] Stopping NFS common utilities:.
[…] Stopping upnp nas device: upnpnasdNo process in pidfile ‘/var/run/upnp_nasd.pid’ found running; none killed.
failed!
[ ok ] Stopping mDNSResponder: mDNSResponder.
[ ok ] Stopping wdphotodbmerger: wdphotodbmerger.
[ ok ] Stopping wdnotifier: wdnotifier.
[ ok ] Stopping wdmcserver: wdmcserver.
-bash: /etc/init.d/wddispatcherd: No such file or directory

Should I just skip the wddispatcherd?

Every time I type without “wddispatcherd”:
“/etc/init.d/nfs-kernel-server stop; /etc/init.d/nfs-common stop; /etc/init.d/upnp_nas stop; /etc/init.d/mDNSResponder stop; /etc/init.d/wdphotodbmergerd stop; /etc/init.d/wdnotifierd stop; /etc/init.d/wdmcserverd stop; /etc/init.d/restsdk-serverd stop”
it shows:

[ ok ] Stopping NFS kernel daemon: mountd nfsd.
[ ok ] Unexporting directories for NFS kernel daemon…
[ ok ] Stopping NFS common utilities:.
[…] Stopping upnp nas device: upnpnasdNo process in pidfile ‘/var/run/upnp_nasd.pid’ found running; none killed.
failed!
[ ok ] Stopping mDNSResponder: mDNSResponder.
[ ok ] Stopping wdphotodbmerger: wdphotodbmerger.
[ ok ] Stopping wdnotifier: wdnotifier.
[ ok ] Stopping wdmcserver: wdmcserver.

With the green [ ok ].
Does it mean those services are automatically re-launched? If yes, how can I prevent it?


#13

There is no wddispatcherd that I’m aware of.


#14

yes, they took out wddispatcherd in OS3 but I kept it in my scripts anyways just in case :stuck_out_tongue:

and yes, if you reboot, all these services are restarted.

Anyways @rac8006 will probably tell you to put it in a startup script which you can try and thereby blame rac8006; I’ll let him interjet on how to do that.

recently after finally upgrading my firmware to OS3, I found that update-rc.d is still installed despite everyone posting up on the forum that it is gone. So you can definitely give it a try and the syntax is as follows.

update-rc.d wdphotodbmergerd disable
update-rc.d wdmcserverd disable

Thus they are permanently disable until you upgrade your firmware.

Good luck…


#15

Okay, I tried:
WDMyCloud:~# update-rc.d wdphotodbmergerd disable
update-rc.d: warning: start runlevel arguments (none) do not match wdphotodbmergerd Default-Start values (2 3 4 5)
update-rc.d: warning: stop runlevel arguments (none) do not match wdphotodbmergerd Default-Stop values (0 1 6)
Disabling system startup links for /etc/init.d/wdphotodbmergerd …
Removing any system startup links for /etc/init.d/wdphotodbmergerd …
/etc/rc0.d/K86wdphotodbmergerd
/etc/rc2.d/K14wdphotodbmergerd
/etc/rc3.d/K86wdphotodbmergerd
/etc/rc4.d/K86wdphotodbmergerd
/etc/rc6.d/K86wdphotodbmergerd
Adding system startup for /etc/init.d/wdphotodbmergerd …
/etc/rc0.d/K86wdphotodbmergerd -> …/init.d/wdphotodbmergerd
/etc/rc6.d/K86wdphotodbmergerd -> …/init.d/wdphotodbmergerd
/etc/rc2.d/K14wdphotodbmergerd -> …/init.d/wdphotodbmergerd
/etc/rc3.d/K86wdphotodbmergerd -> …/init.d/wdphotodbmergerd
/etc/rc4.d/K86wdphotodbmergerd -> …/init.d/wdphotodbmergerd
WDMyCloud:~# update-rc.d wdmcserverd disable
update-rc.d: warning: start runlevel arguments (none) do not match wdmcserverd Default-Start values (2 3 4 5)
update-rc.d: warning: stop runlevel arguments (none) do not match wdmcserverd Default-Stop values (0 1 6)
Disabling system startup links for /etc/init.d/wdmcserverd …
Removing any system startup links for /etc/init.d/wdmcserverd …
/etc/rc0.d/K85wdmcserverd
/etc/rc2.d/K15wdmcserverd
/etc/rc3.d/K85wdmcserverd
/etc/rc4.d/K85wdmcserverd
/etc/rc6.d/K85wdmcserverd
Adding system startup for /etc/init.d/wdmcserverd …
/etc/rc0.d/K85wdmcserverd -> …/init.d/wdmcserverd
/etc/rc6.d/K85wdmcserverd -> …/init.d/wdmcserverd
/etc/rc2.d/K15wdmcserverd -> …/init.d/wdmcserverd
/etc/rc3.d/K85wdmcserverd -> …/init.d/wdmcserverd
/etc/rc4.d/K85wdmcserverd -> …/init.d/wdmcserverd

Is this disabled correctly now?

The problem is, every time I type for example:
WDMyCloud:~# /etc/init.d/nfs-kernel-server stop
[ ok ] Stopping NFS kernel daemon: mountd nfsd.
[ ok ] Unexporting directories for NFS kernel daemon…
WDMyCloud:~# /etc/init.d/nfs-kernel-server stop
[ ok ] Stopping NFS kernel daemon: mountd nfsd.
[ ok ] Unexporting directories for NFS kernel daemon…
WDMyCloud:~# /etc/init.d/nfs-kernel-server stop
[ ok ] Stopping NFS kernel daemon: mountd nfsd.
[ ok ] Unexporting directories for NFS kernel daemon…
WDMyCloud:~# /etc/init.d/nfs-kernel-server stop
[ ok ] Stopping NFS kernel daemon: mountd nfsd.
[ ok ] Unexporting directories for NFS kernel daemon…

It shows this green [ ok ]. If I understand it correctly, those processes are automatically re-launched, otherwise it would show something like: “error nfs-kernel-server is already stopped”?


#16

That is scary isn’t it, which is why I don’t use it :stuck_out_tongue:
but rest assure, there are tons of people using that command to stop the services permanently and we haven’t seen them back here on the forums complaining, but then again …

Anyways,

The services should be stopped … theoretically :stuck_out_tongue:

You can always do the following…

/etc/init.d/wdphotodbmergerd status
/etc/init.d/wdmcserverd status

Remember you can use the update-rc.d for all the services to disable them permanently.

Finally, you can reboot the cloud to see if those services started up again.

Also I noticed that for the latest firmware, if you turn on the media switch, the services re-start themselves; very insidious indeed.


#17

None of the scripts checks to see if the process is running. They just execute the script. Which is why you see the stopping message.

RAC

PS I prefer to use S98user-start to stop the scripts. This way if WD support wants to look into your system all you have to do is change the user-start script in /CacheVolume back to the original file.


#18

Everything related to linux is scary :slight_smile:

Thanks again for help, it seems that those services are really stopped now:

WDMyCloud:~# /etc/init.d/nfs-kernel-server status; /etc/init.d/nfs-common status; /etc/init.d/upnp_nas status; /etc/init.d/mDNSResponder status; /etc/init.d/wdphotodbmergerd status; /etc/init.d/wdnotifierd status; /etc/init.d/wdmcserverd status; /etc/init.d/restsdk-serverd status
nfsd not running
all daemons running
[FAIL] upnp nas device is not running. … failed!
[FAIL] mDNSResponder is not running. … failed!
[FAIL] wdphotodbmerger is not running. … failed!
[FAIL] wdnotifier is not running. … failed!
[FAIL] wdmcserver is not running. … failed!
restsdk-server is not running

except the “all daemons running” (/etc/init.d/nfs-common status), but I’ll skip it for now.

If I understood correctly, if stopping those services help me with the drive sleeping problem, I can add all those stop commands to file: “/CacheVolume/user-start” (/etc/rc2.d/S98user-start)? Or it’s not very safe?
EDIT: Thanks, I think RAC confirmed it in his previous post.


#19

Give us a feedback about the sleep times. Does it look better now? I have the same problem but my started when i changed my router and none of the sollutions helped in my case. I’m affraid that my new router is somehow generating network pings and wakes wdmycloud. I decided to let mycloud work all the time instead switching on and off every 15 minutes.


#20

Ping does not wake up my MC.

RAC