MyCloud does not go to sleep/standby - perhaps the solution

I had the problem. I did the system restore. And at least the full factors restart (what is maybe a good thing to do right away)

After that my Cloud was going to sleep mode, but after the first upload not more. Than i went to the dashboard, to try to turn off any “constant connections” that may hold my cloud turned on.

I went to Settings > General and there is under Language and clock the option “NTP Service” (i´ve turned it off) and under Cloud Access the option “Cloud Service”

After i turned off these two thing my cloud was going to stand by mode. But i wanted to know what of these two is the problem. I turned on the NTP Service (because i think that a Clock Service would not make such a big issue, and i saw much people talking about this for years and WD dos not give an answer)

After that my cloud was still going to sleep, i turned the Cloud Service on and it was not going to sleep. Now it´s turned off.

I don´t know if this is a problem that this option is turned off, but the cloud is now making his job.

PS: BE PATIENT IT TAKES TIME

How are you determining your My Cloud is actually going to sleep?

This sleep problem is a vexing one for many of us. There are quite a few threads that cover various ways and methods people are trying to get their My Cloud to sleep for longer than 10 minutes at a time. There are several background services within the My Cloud that cause it to wake up at random times breaking the sleep cycle. Those services cannot be shut down through the Dashboard, instead one has to use SSH to connect into the My Cloud and disable or shut them down. There is also the issue of the My Cloud waking at 2am or 3am to check for firmware even though a user may have disabled the check for updates option.

Another user created a script one can run to see how often their My Cloud actually sleeps and for how long, it may surprise many to see how little their My Cloud sleeps in default configuration.

https://community.wd.com/t/new-sleep-awk/153431

Do a subforum search for “sleep” and you’ll find lots of discussion on this issue with mixed results. Here is one of those threads:

https://community.wd.com/t/wd-my-cloud-randomly-wakes-up-the-drive-when-drive-sleep-is-enabled/152748

How i determining? After one hour of not working the Blue LED slowly goes on and off.

I wrote “PERHAPS the solution”, it can be something other, until the all mighty WD give us an explain about this.

You think they know…?

While the blue LED may be pulsing on and off indicating the drive is supposedly sleeping, that doesn’t mean the drive is actually sleeping and for how long the drive is sleeping. If one watches that front LED for a long length of time, they’ll see their My Cloud come on all by itself without any user intervention, stay on for a period of time then go back to what appears to be sleep mode.

Unfortunately WD typically doesn’t comment on these kinds of bugs/issues. Which leaves it to we users to try and fix the sleep problem(s) ourselves. Like my prior post indicates and the links discuss, one can find out exactly how often their My Cloud is actually going to sleep using the sleep.awk and sleeptime.sh scripts mentioned in those links. Chances are most will be surprised at how infrequent their My Cloud is actually sleeping.

Typically the My Cloud I use, and which doesn’t have any services disabled via SSH, sleeps for only about 15% to 20% of the time during good days during long unused periods. Often I can hear the drive spin up without any user intervention which is frustrating. Supposedly the sleep period time out is set for 10 minutes within the firmware which means each time the firmware kicks the drive on, it will take 10 minutes of inactivity before the drive will try to go back to sleep.

Have you issued the following command:
“mount -o remount,noatime,nodiratime /dev/root /”
Without the root partition set to these options. Every time a file is accessed on the root partition a kjournal entry is written to the disk. This could cause the disk to never sleep. I don’t use my My Cloud that much. It sleeps over 70% of the time. I do have some processes stopped. Before firmware version 303 my MY Cloud would sleep up to 23 hours. Only waking up at 03:00 in the morning. WD added the atop program with firmware version 303. This program causes the device to wake up every 8 hours. If you stop the process. It gets restarted again later. The 8 second sleeps seems to be caused by the fact that the programs that the monitorio.sh script use get flushed during heavy processing like what is done at 03:00 AM. So monitorio.sh puts the disk in standby mode. Then monitorio.sh checks to see if it needs to do anything. In the process of checking it need a program that has been flushed. Now the disk is woke up to bring the program back into memory.

RAC

Yeah I’ve issued that command in the past and while it made some difference the My Cloud still had trouble staying asleep for long periods of time. I’ve experimented with many of the SSH issued commands mostly to mixed success. Currently I have the firmware at default though and will at some point go back and meddle with the sleep issue. Just stupid that we users are forced to do this in the first place.

If you have it set to default. I’m surprised it sleeps at all. I’ve seen two different cases where samba would access a file about once a minute. I’ve seen a problem where the S20restsdk-serverd would generate error messages every few minutes.

RAC

haha good question

Yeah it amazing it sleeps at all. :-/

/DataVolume/shares/Public$ sh sleeptime.sh
04 04 11:20:27 11:21:23    56  0:00:56
04 04 11:31:35 11:38:37   422  0:07:02
04 04 11:48:49 11:57:24   515  0:08:35
04 04 12:08:38 12:08:46     8  0:00:08
04 04 12:18:58 13:05:10  2772  0:46:12
04 04 13:25:34 13:38:36   782  0:13:02
04 04 13:48:48 13:49:47    59  0:00:59
04 04 13:59:59 14:02:00   121  0:02:01
04 04 14:12:12 14:17:15   303  0:05:03
04 04 14:52:58 14:53:05     7  0:00:07
04 04 15:13:29 15:25:09   700  0:11:40
04 04 15:35:22 15:55:56  1233  0:20:33
Total Sleep Time:  1:00:00
Start 1459753222
End 1459799760
Total Up Time: 12:55:38 14% Sleep 86% Wak

Remote access is disabled. Lots of restsdk errors in the log(s):

2016-04-04T15:02:10.156234-04:00 di=NqJQ6FTJD8 notice restsdk[7159]: watch.go:109: Stat(), error: stat /tmp/dynamicconfig.ini: no such file or directory

At the point now where if it sleeps more than 15% to 30% either stock or with the various SSH end task commands its been good.

You need to stop the S20restsdk-serverd script. “sh /etc/c2.d/S20restsdkserverd stop”
This will get rid of the restsdk errors.

RAC

PS I have no idea why they added this script in firmware version 303.

Yes, know that I have to stop the restsdk entery to stop the log errors. Just haven’t bothered to really dig in to do it at startup other than previously to do so for testing purposes. Currently I’m leaving the My Cloud in stock mode for the time being.

The easiest way to do it at startup. Is edit the /etc/rc2.d/S98user-start file and add the following command.
sh /etc/rc2.d/S20restsdk-serverd stop

Then save the file. Now every boot will stop the process.

RAC

Again, know that. :wink: Just haven’t done it other than for testing purposes a month or two ago when trying to get the sleep issue resolved. Reverted back to default and haven’t taken more time to review thie sleep issue. Like mentioned above it was a mixed deal, while turning off the restsdk at startup and one or two other commands worked others did not. Sleep is still hit or miss on my My Cloud.

No one thing will fix the sleep issue. Here is my sleep time for April.
04 01 19:32:42 00:30:12 17850 4:57:30
04 01 00:40:24 03:00:12 8388 2:19:48
04 01 03:15:20 03:15:28 8 0:00:08
04 01 03:25:40 08:01:11 16531 4:35:31
04 01 08:11:23 10:19:40 7697 2:08:17
04 01 10:29:52 15:17:49 17277 4:47:57
04 02 15:28:01 00:30:11 32530 9:02:10
04 02 00:42:27 03:00:12 8265 2:17:45
04 02 03:15:17 04:17:26 3729 1:02:09
04 02 04:27:38 08:01:11 12813 3:33:33
04 02 08:11:23 08:59:12 2869 0:47:49
04 02 09:09:25 09:17:11 466 0:07:46
04 02 09:27:23 10:06:22 2339 0:38:59
04 02 10:16:34 10:47:05 1831 0:30:31
04 02 10:57:16 11:21:57 1481 0:24:41
04 02 11:32:09 11:34:16 127 0:02:07
04 02 11:51:36 11:52:01 25 0:00:25
04 02 12:12:24 12:16:07 223 0:03:43
04 02 12:26:19 12:35:50 571 0:09:31
04 02 12:46:02 13:03:33 1051 0:17:31
04 02 13:13:45 13:19:59 374 0:06:14
04 02 13:30:11 13:33:10 179 0:02:59
04 02 13:43:22 13:49:49 387 0:06:27
04 02 14:00:01 15:50:40 6639 1:50:39
04 02 16:00:51 16:01:10 19 0:00:19
04 02 16:11:22 16:26:30 908 0:15:08
04 02 16:46:53 18:55:49 7735 2:08:55
04 02 19:06:00 23:20:16 15256 4:14:16
04 03 23:30:28 00:00:11 1783 0:29:43
04 03 00:12:27 00:12:34 7 0:00:07
04 03 00:22:46 00:30:11 445 0:07:25
04 03 00:40:24 00:40:32 8 0:00:08
04 03 00:50:44 00:57:11 387 0:06:27
04 03 01:07:23 01:17:11 588 0:09:48
04 03 01:27:23 03:00:11 5568 1:32:48
04 03 03:15:17 08:00:11 17094 4:44:54
04 03 08:10:23 09:01:44 3081 0:51:21
04 03 09:11:55 12:36:10 12254 3:24:14
04 03 13:14:57 13:17:12 134 0:02:14
04 03 13:27:23 13:44:12 1009 0:16:49
04 03 13:54:24 14:13:30 1146 0:19:06
04 03 14:23:42 15:19:43 3361 0:56:01
04 03 15:30:56 15:56:29 1533 0:25:33
04 03 16:06:41 19:26:09 11968 3:19:28
04 03 19:36:21 19:53:32 1031 0:17:11
04 04 20:03:44 00:01:12 14247 3:57:27
04 04 00:11:24 00:30:11 1127 0:18:47
04 04 00:40:23 00:40:31 8 0:00:08
04 04 00:50:43 03:00:12 7769 2:09:29
04 04 03:15:17 03:17:11 114 0:01:54
04 04 03:27:23 08:01:11 16428 4:33:48
04 04 08:11:23 10:08:57 7054 1:57:34
04 04 10:19:09 10:56:34 2245 0:37:25
04 04 11:06:46 11:10:28 222 0:03:42
04 04 11:30:51 12:05:48 2097 0:34:57
04 04 12:16:00 13:42:56 5216 1:26:56
04 04 13:53:07 14:10:02 1014 0:16:54
04 04 14:20:14 15:08:25 2891 0:48:11
04 04 15:25:46 15:57:44 1918 0:31:58
04 04 16:07:56 16:10:27 151 0:02:31
04 04 16:30:50 17:00:35 1785 0:29:45
04 04 17:10:47 18:14:59 3852 1:04:12
04 04 18:25:11 18:30:30 319 0:05:19
04 04 18:40:42 19:17:37 2214 0:36:54
04 04 19:27:48 21:08:49 6061 1:41:01
Total Sleep Time: 737:41:01
Start 1456685306
End 1459818529
Total Up Time: 870:20:23 84% Sleep 16% Wake

RAC