My wd cloud failed to boot the operating system, HELP NEEDED

Hi, I have a wd Mycloud (2TB) that does not work with my new AT&T router (Pace 5628ac). However when I plugged mycloud to my notebook, it can be recognized.
After google the internet and I found a solution, which cause the cloud to fail to boot.
The solution is

  1. Enable SSH on mycloud
  2. put “post-up ethtool -s eth0 speed 1000 duplex full autoneg off” to the last line of /etc/network/interfaces.
    After reboot, the wd Mycloud is flashing white light.

After that, I had to get the HD out of the box and hook it to PC, and removed the last line of /etc/network/interfaces. The problem is still there.

Any help needed?

If the drive is in the case, try doing a reset and see if that helps.

If you use the search icon, top right, and do a search on the AT&/T router you should find topics on this problem.

The My Cloud being inaccessible when using an AT&T supplied router has been well discussed in this subforum. Use the forum search feature (magnifying glass icon upper right) and search for Uverse and you’ll find numerous past discussions on this and the workaround (attached the My Cloud to a switch that is in turn connected to the ATT router).

The WD Support Knowledgebase even has an entry on this issue…

1 Like

Thanks for the reply.
In fact I did a lot of research to fix the problem that My Cloud is not accessible to AT&T supplied router. I bought a TrendNet 5-port switch and put it between the router and mycloud. It did not work.
Then I tried to use ethtool to change NIC settings. Now the wdcloud failed to boot.