My Cloud -Zugriff von aussen Verständnisfrage

Hallo,
Ich bin auf dem Gebiet völliger Newbie und auch nach lesen des Handbuchs und alle gefundenen Infos bin ich nicht wirklich schlauer.

Bei anderen NAS und Apps mit nicht direkt zugehörigen Apps habe ich gelesen, dass der Router für den Zugriff von aussen entsprechend mit Portforwarding, quasi als VPN eingerichtet werden muss.

Bei der my Cloud und der App habe ich sowas nicht gelesen. Ich werde die myCloud hoffentlich demnächst geliefert bekommen und beschäftige mich schonmal damit.

Funktioniert der Zugriff von einem fremden Netzwerk von aussen nur über die App, ohne am Router noch rumbasteln zu müssen? Quasi ähnlich wie teamviewer?
Oder müssen am Router noch Einstellungen vorgenommen werden?

Wenn hierzu jemand Infos hätte wäre ich dankbar.

Vorab vielen Dank für die Mühe!

Wie stellst Du Dir denn den Zugriff vor? Wie Teamviewer? Was willst Du da sehen?

Also zunächst einmal, das UserInterface, also die Webseite zum Konfigurieren der Cloud ist nur im eigenen Netz erreichbar (lokal) und von außen nur über VPN.

Die Dateien auf der Platte selbst sind von außen auch ohne VPN erreichbar. Von außen am Besten mit den Apps (Mobil oder die Desktop Variante für PCs).

Über Webbrowser nur über zuvor erstellte Links, also beispielsweise die, die Du dann per E-Mail senden kannst damit Deine Freunde darauf zugreifen können (über Webbrowser).

Alternativ gibt es noch die WD 2 GO Webseite, dafür braucht es allerdings Java.

Also von außen ist alles erreichbar (auf Wunsch) bis auf die Konfigurationswebseite zum Einrichten der Cloud - außer Du nutzt VPN. Dann kannst Du auch von außerhalb neue Benutzer/Freigaben anlegen (so mache ich es auch mit VPN).

EDIT: am Router braucht es keine “Bastelleien” sofern er UPnP unterstützt und eingeschaltet ist. Andernfalls bedarfs es zweier Portweiterleitungen.

Ah super, danke, dann ist das alles so wie ich es brauche! :slight_smile:

Mit teamviewer meinte ich, dass ich damit ja auch auf andere Rechner zugreifen kann, ohne dass ich eine VPN habe. Teamviewer hat mit den wechselnden IP keine Probleme, wahrscheinlich Abgleich über teamviewer-Server o.ä.

Aber wenn das über die Apps funktioniert ist ja perfekt. Konfigurieren tu ich sie zuhause?

Zunächst: mit der WD My Cloud hast Du nur Zugang auf die Daten, die sich auf der Platte befinden. Die WD Apps geben keinen Zugang auf Platten, die sich auf Deinen Computern Zuhause befinden (eine Ausnahme bildet der “Sammelordner” vom Twonky, der in der Lage ist Bilder/Videos selbstständig von Deinen Computern auf die WD Platte zu kopieren).

Zu konfigurieren ist da ansich nichts, zumindest bei mir Zuhause (mit FritzBox und DSL von der Telekom):

  1. WD My Cloud anschließen

  2. WD My Cloud einschalten

  3. gute 20 Minuten warten bis die LED blau und durchgehend leuchtet

  4. die IP Adresse von WD My Cloud im Browser öffnen (http:///UI)

  5. Benutzer und Freigaben einreichten

  6. gewünschte Dateien auf die Platte kopieren

Dabei geht die Transferrate gerade am Anfang deutlich zurück. Aus 60MByte/Sekunde schreiben am Anfang kann dann der schreibende Transfer durchaus auf 1MByte/Sekunde abfallen. Ich vermute hier, dass der Twonky Server parallel gleich zu scannen beginnt. Aber nach 1-3 Tagen ist auch der Twonky Server dann mit Indizieren fertig und der volle Speed steht wieder zur Verfügung.

  1. gewünschte Apps auf das Tablet/Handy installieren

Meine WD My Cloud Platte hängt in einem GBit Netzwerk und erreicht zwischen 55-70MByte lesend pro Sekunde. Beim Schreiben sind es mindestens 50 MByte pro Sekunde. Kopiere ich allerdings sehr viele Dateien nacheinander auf die Platte, so geht aufgrund der vermuteten Twonky Indizierung der Durchsatz schnell nach unten.

Ist die Indizierung allerdings ersteinmal abgeschlossen, so bleibt bei mir der schnelle lesende Durchsatz erhalten.

Ich habe ein ähnliches Problem:
Solange ich mich mit meinen angemeldeten iOS-Geräten im eigenen WLAN bewege ist der Zugriff auf MyCloud möglich. Anmeldeinformationen siehe WD1.jpg und WD2.jpg.
Bei Zugang aus WLAN meiner Freunde oder aus dem 3G-Mobilfunk wird mir z.B. bei WD Photo zunächst meine Ordnerstruktur mit je einem Thumbnail angezeigt (WD_3g.jpg). Nach Auswahl eines Ordner sehe ich die korrekte Anzahl von Platzhaltern, aber nur ein Thumbnail (WD_3g_1). Egal, welches Icon ich dann auswähle, es führt zu einer Fehlermeldung zu Netzwerkverbindung (WD_3g_2). Im eigenen Netz sieht das dann so aus (WD_3g_all.jpg) und führt auch weiter.
Die zitierten Bilder sind auf dropbox hier zu finden: https://dl.dropboxusercontent.com/u/12040489/Desktop.zip

Was läuft hier falsch und was kann ich tun?

Ich befürchte letzteres, denn beim Absenden einer Supportanfrage erhalte ich eine 5-stellige Fehlernummer …

Du bist über eine “Relaisverbindung” verbunden.

Wie in “wd2.jpg” beschrieben, aktiviere UPnP an Deinem Router. Dann klappt es auch (abhängig von der Upload Geschwindigkeit Deines DSL Anschluß) besser.

Falls Du UPnP an Deinem Router nicht aktivieren kannst, dann mache ein Port-Forwarding auf Deine WD My Cloud.

Bin mir jetzt nicht sicher welche Ports weiter geleitet werden müssen, es sind aber auf jeden Fall zwei Ports die weiter geleitet werden müssen (ich glaube 80 und 447, bin mir aber nicht sicher).

Das klingt schon besser als die Wegschmeißstimmung des Vorredners.

Leider kenne ich mich mit UPnP und Forwarding überhaupt nicht aus. Das sollte ein Produkt aber auch nicht erforderlich machen, das an die Allgemeinheit verkauft wird.

Mein Router ist eine Fritzbox 7390, dort steht ein Haken bei "Statusinformationen über UPnP übertragen.

Das “Statusinformationen über UPnP übertragen” genügt nicht.

In der FritzBox muss zusätzlich folgende Option aktiviert sein:

“Änderungen der Sicherheitseinstellungen über UPnP gestatten”

zu finden unter “Internet” -> “Freigaben” -> “Portfreigaben”

EDIT: ggf. anschließend die WD My Cloud neu starten. Ich bin mir nicht sicher ob die WD My Cloud das automatisch erkennt wenn die FritzBox einstellungen geändert werden. Also ggf. die WD My Cloud anschließend neu starten.

Ach ja: bei mir habe ich in der FritzBox die WD My Cloud so eingestellt, dass diese immer die selbe IP vom DHCP (FritzBox) bekommt / zugewiesen wird. Also DHCP mit statischer IP :wink: Könnte sonst schwierig werden wenn nach 24 Stunden von der Telekom eine Zwangstrennung kommt. Bin mir nicht sicher ob das Wichtig ist, so ist es bei mir eingestellt und habe keinerlei Probleme mit Zugriff von außen.

Hinweis: der FTP Port wird nicht per UPnP angefordert. Ist ein FTP Zugang von außen erwünscht, MUSS der Port 21 manuell in der FritzBox an die WD MY Cloud weiter geleitet werden (hier fordert die WD My Cloud keine UPnP Portforwarding an).

Rückmeldung:

Zweiten Haken gesetzt, Neustart - große Hoffnung, das “Rädchen” dreht sich. Aber nach langer Wartezeit die gleiche Fehlermeldung. Ich habe auch die Stelle gefunden wo man für HTTP den Port 80 freigeben kann (Freigabe = Weiterleitung?). Aber für Port 443 findet sich nichts.

Prüfe nochmals ob die Einstellungen korrekt sind.

Hier meine Einstellungen der WD My Cloud:

  • Hier muss “Remotezugriff” auf “EIN” stehen (der oben sichtbare Primäre Server wird bei Dir nicht funktionieren bzw. hier handelt es sich um die lokale Netzwerkadresse meiner FritzBox und spielt auch keine Rolle).

Nachfolgend die Konfiguration von “Remotezugriff”:

  • diese sollte auf “Automatisch” stehen. Windows XP ist bei mir deaktiviert.

Hier die Einstellungen meiner FritzBox bezgl. UPnP:

  • wichtig hierbei “Änderungen der Sicherheitseinstellungen über UPnP gestatten” muss angekreuzt sein. 

Nach einigen Minuten findet sich dann von ganz alleine eine Port Weiterleitung für die WD My Cloud in der Liste wieder (muss nicht manuell hinzugefügt werden):

  • hier gut zu sehen der Eintrag “WDMyCloud” mit einer Port Weiterleitung auf 80 und 443. Diese zwei Einträge erscheinen hier automatisch sofern UPnP korrekt in der FritzBox aktiviert wurde und in der WD My Cloud die “Konnektivität” auf “Automatisch” steht.
1 Like

Sch#$%&

Die Einstellung in der Konsole scheint jetzt zu stimmen - keine Relaisverbindung mehr.

Dafür sagt mir jetzt WD Photo, dass keine Fotos vorhanden seien, weder bei Zugang im eigenen Netzwerk und auch nicht bei Internetzugang.

klappt bei euch alles ? 

Ähm worin liegen denn die Unterschiede für den Benutzer ob er nun relais oder Portweiterschaltung benutzt? Bei mir läuft es per relais und es klappt alles ohne Probleme. Und das auch schnell

kannst du auf deine cloud komplett zugreifen wen du in einem anderen netzwerk bist?

Jap. Sowohl über die App als auch über WD2GO und den WD2GO trick

welchen trick?

ich kann auch drauf zugreifen app,pc usw.

aber mich würde mal interessieren ob ich von außerhalb auf meine cloud zugreifen kann damit ich benutzer eine freigabe geben kann.

hat jemand eine idee wie es geht?

danke schonmal.,

MfG Patrick_1220

es gibt da einen trick wo du dir im angemeldeten WD2GO per Rechtsklick den Quelltext anzeigen lässt. Dann bekommst die reine Adresse da drin. 

Von außerhalb freigaben einrichten oder allgemein die MyCloud einrichten funktioniert meines wissens nicht.

Ein gesundes, neues Jahr an alle!

Bin seit ein paar Tagen Besitzer einer MyCloud mit 6 TB Speicher.

Soweit habe ich alles eingerichtet, im Homelan ist auch alles OK.

Nur beim Zugriff von außen gibt es permanente Probleme. Dabei sollte die Cloudlösung lt. den Pressemitteilungen ja sooo einfach sein.

Ports 80 und 443 sind eingerichtet, UPnP in der FritzBox eingeschaltet.

Remotezugriff (cloudzugriff) in der MC ebenso eingerichtet und freigeschaltet.

Leider funktioniert der externe Zugriff weder mit Apps (MyCloud) vom Smartphone oder W7 Desktop, noch über wd2go.com (nach der Anmeldeseite kommt ein “Seite nicht verfügbar”)

Was kann / muss ich noch tun, damit der Zugriff von außen klappt?

LG

Steve

Ich habe es mal Dank der obigen Tipps am Laufen gehabt. Macht aber überhaupt keinen sinn, da MyCloud seine Inhalte mit der ultralangsamen Uploadgeschwindigkeit meines/deines Anschlusses hochlädt und dann das externe Gerät erst wieder relativ schnell runter. In der Zeit bin ich nach Hause gefahren und habe mir die Daten auf einen Stick gezogen :smileyvery-happy: