My Cloud (Single-Bay) accessing dashboard outside my home network

I cannot access the dashboard outside my home network. Inside my home network accessing the dashboard is no problem. I would really appreciate it if someone can give me a clear answer what the problem is.
I would also like to know if there are people who are able to access their dashboard outside their home network.

My Cloud is directly connected with an ethernet cable to my modem router. No access points or switches between them.

I followed every single step from this page:
https://support-en.wd.com/app/answers/detail/a_id/2573/kw/remote%20location

  • My Cloud is on the latest firmware (2.31.204): CHECK

  • My Cloud is connected to the internet: CHECK
    image

  • My Cloud Port Forwarding is on: CHECK
    image
    image

  • Enable Dashboard Cloud Access: CHECK
    image

  • Turn UPnP On: CHECK
    (actief = active, beide = both TCP and UDP)
    image



    On the support page it says port 80 (HTTP) is port forward to 9091 and port 443 (HTTPS) is port forward to 9444
    I also tried that, same problem, so I changed them back to 80 and 443 to avoid confusion (pretty sure that doesn’t matter).

  • Router External IP Address: CHECK
    Port Forwarding Tester
    https://www.yougetsignal.com/tools/open-ports/

image
image

  • Access My Cloud Remotely: PROBLEM
    Both HTTP and HTTPS (80 and 443) don’t allow access to the dashboard
    403 Forbidden - You don’t have permission to access / on this server.


Firstly have you considered the security implications of actually doing this? Anyone on the internet can hit your login page if this is set up, so if you must do it make sure that usernames and passwords are strong and secure.

In many cases using a solution like a VPN server setup on your home network (a Raspberry Pi can be a cheap and easy host for one) and using a client to connect in via that is much more secure.

Anyway if you must do it this way, the first thing to check is what forwarding rule your MC is actually telling your router to set up. Essentially what’s happening is that you connect from the internet to your router via it’s public IP address (not it’s internal one within your network) on a given port number, and via the rule set up that traffic is then passed on to a given IP address (in this case the one for your MC) on a given port (which may or may not be the same as the one incoming from the internet).

So to take an examples, if the dashboard is on ports 80 and 443 (the standard HTTP and HTTPS ports) on your MC we can set (manually or via UPNP) forwarding rules on your router to pass incoming port 9091 to your MC IP address on port 80 and incoming port 9444 to your MC IP address on port 443.

Then if you connect to the public IP address of your router (again not its internal IP address (192.168.0.3 in this case), the seperate public IP address provided to it by your ISP) on either port 9091 or 9444 it should act as the equivalent of accessing ports 80 or 443 locally from your home network.

If all of that is correct and you’re using the correct IP addresses, the next step is to confirm if there are any firewalls or similar getting in the way, for example on your router. If so then you may need to add rules to them to allow the connection through.

Hi, yes I know how it works, I use:
http://mypublicip:80/
https://mypublicip:443/

Everything is correct in my router. Router firewall is off. Also everything in MC is correct.
Did you even read my post and toke a look at the screenshots? :face_with_raised_eyebrow:
Also the Port Forwarding Tool can access the ports meaning they are open.

Yes I did read them, but as I don’t know who you are and what you can do I erred on the side of first principles.

But as you know more than me and don’t want my help, then you can fix it…

I work in IT for a living, I have some basic network knowledge. I did set up my home network myself.

Of course there are other options like setting up a VPN server or maybe RDP to my computer. That all works fine, but that’s not the point. I just want to be able to access the dashboard through the internet.
I know that anyone on the internet can hit my login page this way (that is if it finally works) but if my password is secure enough, I don’t see the problem.

I never said I know more than you and that I don’t need your help :slight_smile: or else I wouldn’t be here.
If you have the solution to my problem I would love to hear it!

Can you for example access your dashboard through the internet?

Honestly I’m starting to think that WD disabled this feature with the latest firmware for security reasons.

Not being able to access the My Cloud Dashboard from a remote location is a known issue discussed in the past. The problem is the My Cloud Dashboard typically rejects connections from computers/devices that are outside of the IP address range of the My Cloud.

Use the forum search feature, magnifying glass icon upper right. to see the past discussions on this. Some have apparently hacked/modified the firmware using SSH to allow for remote access from non My Cloud IP subnet ranges.

Thanks!

Although there is a support page that explains how you can remotely access the dashboard this way.
WD should fix this :slight_smile: or just remove the support page.

Why does WD need to change the page? As indicated at the bottom of the page under Applied Products the single bay My cloud IS NOT supported when it comes to remote access of the Dashboard following the directions of that Support article. The single bay My Cloud Dashboard (at least the first gen v4.x firmware version) does not have the Dashboard Cloud Access option on the Dashboard > Settings > General tab.

Applied Products:

My Cloud Mirror
My Cloud Mirror (Gen 2)
My Cloud EX2
My Cloud EX2 Ultra
My Cloud EX4
My Cloud EX2100
My Cloud DL2100
My Cloud PR2100
My Cloud EX4100
My Cloud DL4100
My Cloud PR4100

You wouldn’t happen to have a server on your network that is available 24x7, would you? You could connect to that box and then http to your NAS from there. It’s a roundabout way, but it gets you there.

While everyone else appears to be getting offended, I thought I’d just go ahead and actually try and solve the issue :slight_smile:

No one seems to be “offended” rather just pointing out that the single bay My Cloud cannot do (and why) what the OP’s WD Support support link for other My Cloud models indicated. The single bay My Cloud doesn’t have the option in the Dashboard > Settings that the multi bay models have. As previously mentioned there are workarounds; from hacking the firmware (discussed in other threads) to fix the IP address lockout to using VPN to using SSH. For example two past discussions on using SSH to access the My Cloud Dashboard Remotely:

@Brellyn1 Thanks for your response. You are the first one to give me a decent option to my problem, I really appreciate it.
TBH I already gave up my Single-Bay, it’s already up for sale, it’s going to be someone else problem soon :slight_smile: the community was no help either. I have to agree with you on the fact that everyone here gets offended when just asking “simple” questions. Oh well… much what I excepted after reading all the other threads on the internet. :slight_smile: