Access dashboard remotely (internet

How to I connect through the internet to my dashboard.

Common question that is asked repeatedly. Short answer. Officially you cannot access the Dashboard from a remote computer.

Unofficially one can but it requires one to either use VPN or to use SSH and possibly modify the firmware to allow for remote Dashboard Access.

Here are just a few past threads to get you started:

I see this post is old, but the solution is easy, albeit with quite a few steps mind you…

  1. activate dyndns on your home router with a free Dyn IP service like
  2. create a user account at the above mentioned service provider
  3. you then receive a domain name that will be resolved to your routers current outside IP
  4. open port to your My Cloud for web access if your router’s firewall is blocking it (mine wasn’t)

On any browser, simply enter the domain name URL that your dyndns provider gave you and voila, you should have your My Cloud admin login screen in your browser. The URL will look something like <>. This will work whether you are on your local network (LAN), or remote (WAN)

Have you actually tried that? Generally the My Cloud is supposed to reject Dashboard access to computers that are not in the same local IP Address pool as the My Cloud.

Edit to add: The error message one gets with a single bay My Cloud when attempting to access the Dashboard from outside the local network is as follows:


You do not have permission is access / on this server UI.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

Yes! I have this working fine on my WDMC and have had for some months now. I just double checked and I was in error - I did make a port forward rule for the NAS on the router firewall. Is it possible that because the NAS is behind the router, it doesn’t ‘see’ the outside IP access due to the port forwarding? That’s nonsense, right?!

Are you actually outside of your local network when you perform the check? Reason I ask is because using a cell phone with mobile data connection only you get the error message I posted above, and its the same error message I get when outside my local network and try to access the Dashboard with port 80 port forwarded to the My Cloud. However from my local network if I input the DDNS address I have setup for remote access to my local network I can access the My Cloud using the DDNS address because the computer is using the same IP address range as the My Cloud on the local network.

Yes - I’m outside the local network. I’m at work. In terms of inside and outside addresses, I’m not sure I follow you, but I could be wrong. My understanding is that if you go the DynDNS route to login to your dashboard, your ‘inside’ IP address cannot be ‘seen’ by the DynDNS resolve service. You get what I mean? On your local network, your router is might have the address The WDMC might be And your I.P. might be So then the WDMC would see you are on the range 192.168.0.x and know this is local. If you use the DynDNS domain name, I believe then what the router sees is your outside WAN address which is then port forwarded to the WDMC. Right?

What My Cloud model do you have? The EX version? If you have a single bay version, what firmware version and have you made any modifications (like adding unsupported modules/apps) to the firmware?

Generally on the single bay My Cloud versions (I use a first gen v4.x) My Cloud the firmware is supposed to reject anyone trying to connect from a remote location. There are a number of threads (including the one’s posted above) that cover this with the single bay units. Here is another discussion on it.