My Cloud randomly going offline

Would really appreciate some help here! Have had a 6TB My Cloud Home up and running since February 2018. Four times it has gone into offline mode. It is easily rebooted by removing the power supply and waiting before reconnecting to power. That’s great if you have access to the drive, but twice it’s happened while I’ve been abroad, and I’ve lost access to my files - the very reason I bought it in the first place! WD Support suggested the issue was to do with the settings on my router, and - after hours of wrangling with the admin settings for my router - I managed to DHCP the IP address, which WD Support assured me would rectify the problem.
It’s jut happened again… and I’m abroad.

Any suggestions?

@peter61 I’ve sent you a private message

1 Like

I am also facing the same issue. It is so annoying that I am thinking of buying a new NAS and throwing this in the garbage.

Can the solution please be made public?

I’m also having this problem. It will even go randomly offline during a file copy to the drive.
The My Cloud Home webgui is next to useless.
It is a piece of junk.
My recommendation… return it and buy something else.

What I did was I connect the My Cloud device to smart plug which can be switched off / on remotely through a mobile app. If I cannot access the device what I do is switch the smart plug off and on using the mobile app of the smart plug.

May be it’s too late to reply your post but hope at least this would be useful to someone else who has the same issue.

Thanks - I’ve used that solution on other tech that has problems with going offline, and it works well. I think the drive I had was a rogue one - it was replaced under warranty and the new one has worked faultlessly. Thanks for replying. :pray:t2:

Hi dileepnk ,
your device had IP before ?
i facing the issue also since last week but the device is not getting any IP so i guess your solution wont help me , am i wrong ?


Finally I persuaded WD that there was a problem with my hard drive, and they replaced it under warranty - not without a fight! No problem with the new one, so I guess I was correct! Good luck!

Great news but whats happened to your DATA ? did they restore it ?

Ha! I wish!
After a LOT of pressure from me, they sent me a new drive (and held a deposit on a credit card in case I didn’t return the faulty drive), which allowed me to set up two WD accounts side-by-side on my PC, and I could transfer data manually. It took days, literally. Then I could send the faulty drive back.
Good luck.

hi peter61,
how did you manage to access the data by connecting the wd drive on to the PC?
What ive known is that my cloud home cant be connected locally to a pc to access data.
Please guide, as im also interested in getting the data out

A very time-consuming process! I had to set up two WD accounts (with 2 different email addresses), have both drives running in my desktop, then transfer a folder of files from the faulty drive to my desktop, then transfer it to the new drive. You can’t connect the drives directly to the PC. It took ages to transfer about 50Gb of data. But it worked.

But how did your faulty device got connected to your pc to transfer the data. Pls guide

Power the old drive off, then power it back on. This managed to bring it back to life long enough to download the content.

I have the same issue. Pain as I’m in Italy and the drive is in Milton Keynes. The drive seems to go offline every week or so. Seeing so many people have the same issue is it really fault drives?
Has anyone found how to fix this bug? It is driving me mad.

I lodged a support ticket for this same issue. The symptoms I received is a regular automatic restart of the WD device - at times it will remain offline and I need to power it up using the button at the back. I am certain these issues occurred since the last firmware as it has been working fine for well over a year.

Anyway - the WD response I received is as follows:

" I would suggest you to perform a 1-29 second reset on the drive. Please refer to the below link for more information. Please Note: Performing a 60+ Second reset on a My Cloud Home is “Data Destructive” process."

How ridiculous.

So the lazy response is to simply reset the device to factory settings - and go through the extra amount of time to recover all of my data again in the hope this resolves the issue.

So instead today I ordered a Synology DS220+ and will instead be spending my time moving over to a better quality product.