My Cloud Disk offline since 2 days

Hi all, my My cloud device is offline since two days. The light belt is slowly breathing. I performed the 60 seconds restart twice without success. Before that the device worked well for more than a year.

1 Like


I have a similar problem. Since yesterday the disk appears offline and today I discovered that it turns off and on, always showing a flashing light.

I have had it since July 2020 and it was working without problems.

I’ve managed to solve my problem! Can you put a new cable from your WD to your modem? Since I’ve changed the cable, waited for a minute, my WD was back online

I’ve found this, maybe this could help? I haven’t looked at it yet:
Can you please keep us/me posted when you can log in to your MyCloud again?

I have the same problem. I can’t get into my MyCloud, can’t reach my documents etc. I have had my device for over 3 years, I think.

Tried that without success

Hi, I’ve been having this problem for two weeks now and a bit frustrated. I have tried everything and at an end. Doesn’t WD have a support desk we could call? Has anyone found a solution yet? Please help. I was so excited when I purchased the MyCloud Home Duo but now I’m ready to post everywhere not to purchase this “waste of money”.

1 Like

same here

I have the same issue for two weeks. I’m despair. I have all my business inside. I did everything that WD says, but nothing works.


I found the error. For some reasons my router blocked the connection with the parental control function. Don’t know why. When I removed it Mycloud was back again.

Hi my My Cloud Home is offline for two weeks now. I’ve contacted WD support, they came up with several suggestions that did not work.
I have no port forwarding, nor parental controls configured. I even disabled the modem firewall. Still no connection with My Cloud Home via app or web. WD support now suggests to do a 60 s reset, but that will lead to loss of data. Unacceptable to me.

My My Cloud Home is starting up and after a few nuts shutting down, all the time. When I check connected devices in my modem, the WD is not displayed.

Hope someone has a suggestion that works for me.