My Cloud loses network connection


Bought the drive 3 days ago (WD MyCloud 3TB) and plugged it to my WR841n TP-Link router.

I disabled sleep mode using the dashboard.

I use windows 8.1 pc.

The drive appears in “my netowrk”, replies to ping and i can access it using my cifs \wdmycloud, iPhone and Android.

In the last couple of nights i copied lots of data from my pc to the \wdmycloud\share and left it copying during the night.

In the morning the following happens:

The wdmycloud does not appear in my network places, when i ping the wdmycloud i receive “destination host unreachable”, the copying process was interrupted at aroung 95%.

The led is blue.

I had to unplug the power in order to restart the wd my cloud and after it rebooted connection was restored.

It happened twice since i bought it 3 days ago.

I have the lateset firmware 3.04.01-230

going through the threads here I see that i’m not the only one has this problem with this drive.

Any leads on this isse ? anyone ?

Give it 24 hours to sort out its scanning, thumbnailing and others.

Hi Adija.

I’ve got excactly the same problem - its been 2 weeks now with no luck. It dissapears from the router and the only way to get it back is to pull the power and start again. The longest it has been up is 8 hours. I have had no luck with tech support so far - they have got their time zones mixed up. If you have any joy I would like to know - There was a massive thread a while ago about needing more information about the poble. Unfortunately WD has closed the thread without a solution - 22 Pages of users just left in the dark.

1 Like

Hi all,

using a smart TV or RaspBerry Openelec the same problem happens to me.

During the viewing of the Movie the connection become lost.

This is really bad behaviour .

does WD planning to fix the problem.

It was not present in the previous release of the software

Another problem is that on the smat TV I also see duplicate file of the same movie thata do not exist on the storage.


The first thing to try with drives that are disconnecting is to assign a fixed IP address. Better to do this (easier and less risky) from the router UI.

Dear Etupes,

myCloud already has a static IP address .

this strange behaviour started happens few  weeks ago.

It was not present 2 monts ago.

do you think it’s an hardware problem ?

How can I check the device ?

thnks for your help


I have been having the same problem and of course it happens while I am hundreds of miles away and I am unable to turn the power off.  Yesterday I uploaded a ton of photos, took a break and when I went back to upload more I was unable to connect.  This was fine because I was at home and able to reset the unit, but if I am away from the drive I am dead in the water.  I have about had it, I might as well unplug the thing and throw it away, it is no good if I am unable to use it.

Join the crowd.

If you like to be flicked of on a company troll’s runaround you can start fiddling with static IP adressing and switching sleep mode. How about disabling DHCP altogether and manually managing all your devices - that should keep you quiet for a couple of hours. It won’t solve your problem but it will give you something to do.  What you won’t get from WD tech support is an acknowledgement of the problem or a commitment to do something about it. If you do get an email from WD tech support it will be filled with garbage runaround workarounds and when you get an oppertunity to get a phone call it will be from a timezone that will be available between 1am and 6am which they will then decline to honour in anycase. Then they’ll close your request and let you start all over again with a new tech support request. I wonder if they do this by accident or by design. 


Hansie Bothma

Same here.  Static IP on router and MyCloud, sleep off.  Bought $540 worth of these pieces of trash in a volunteer effort to provide offsite backup for a local museum.  One is now a brick.  The other two lose connection with their respective routers on a very frequent basis.  I’ve been a WD user since the early days of my career back in the early '80’s, but unless they get off their arses and fix this problem, they’re of no use to me.

I am having the same issue “destination host unreachable”.  I can’t even get it to map the drive again.  I tried changing the name of device and reconnecting but that only worked until the next time it disconnected. now it’s lost again.  I can’t even begin to transfer files over.  Plus now it gives me a network login and it won’t take my PC’s password or any thing.

I think I need a refund this is useless.  I never had this problem with WD MyBook.  Some threads say the new firmware fixes it but it does not I have the newest firmware.  Others talk about changing ports, but no luck there so far for me and I don’t know what to do this is intolerable.:manmad:

1 Like

I bought a My Cloud in April this year and I really wanted to like this product!  I have perservered, buying several additional bits of kit including a TP-Link TD-W890 router but all to no avail. When it works it is a pleasure, so why would I change any settings…then it disappears! Not on LAN, can’t get to dashboard, no mobile access…nothing!  So the only option is to switch it off, keeping everything crossed it comes back again!  Access is so flakey I am very concerned about my data. I smiled when I read the latest firmware included a fix for connectivity issues…sorry WD it didn’t, I would be grateful though if you would reply to some of these threads even if to say you know there are problems and you are working on them!!

I bought mine yesterday and today the network connection was lost.  This thing is flaky.  After updating the firmware, the unit reboot itself and then the network connection was back.

From the threads, it appears that rebooting can restore the network connection.

Can WD tech people tell us how to remote boot this thing in case we are away from the unit?  

Same for me (after the application of 4.01.02-417 firmware). Typically these sorts of issues are fixed in firmware updates but this has had several and the issue still persists.

I would add that copy and paste from a USB3 connected drive (via the NAS USB socket) with many files failed to get started and only resulted in an error message with no useful information. If it has a USB socket then is it not natural that you may want to copy files from it to the drive using the MS Explorer interface (i.e. >40,000 files)?

There seem to be a lot of issues with this product, new firmware that addresses the persistent problem (loss of network connection) is required urgently please.

If you can make the copy and paste work through the MS Explorer then that would be really nice too.

same here. i am badly hard reboot (switch off). soft boot (by reset button with no respond…)

I bought the WD MyCloud box late in last summer, it was working well until the Christmas time. It became unreachable. Initially I found that my iPhone app could not connect to the MyCloud, then tried to connect from my PC on my LAN (same LAN where the MyCloud box is physically connected), no luck.  Can’t WD give a trouble-shooting process to resolve the issue? My whole family has put a lot of stuff on it, mostly family photos from smart phones and PC’s. I am in the hot spot since I was the one who persuaded everyone to buy this thing!!! Come on WD, don’t let me down!!!

Mine has been running perfectly fine for the last two years on firmware 3.x…
About half an hour ago, while I was watching a movie off the drive for the past 1hr, it suddenly lost network connection for the first time ever…I had to power it off and power it on to get connectivity back…
The only thing that has changed in my network is that I upgraded to a newer router 3 days ago… It’s running with the same settings as my old router. Static ip assignment from the router…

I don’t know what to make of this scenario… Could the issue be with certain routers? I know people here have been using all types of routers…
I’ll keep an eye on this now. Maybe it was a one time fluke,if it happens again, I would have to blame the router