WD My Cloud 4TB - Disconnecting from the network frequently

Hey there!

I just purchased the My Cloud 4TB version yesterday. I plugged it in and followed the instructions and it started up flawlessly. The first thing I did was update the firmware to the latest (v04.00.00-607). I created my users, made their folders not public and added passwords for them.

All was looking good - no problems.

I am going to use this as a backup drive I setup SmartWare and started to backup my storage drive. It was all going well and then it popped up with an error message in the tray, similar to “cannot find MYCLOUD/*user*”. I went to the network and tried to open up the Mycloud but it gave me an error message “Cannot access MYCLOUD” or something similar.

I could access the dashboard and everything looked fine. Green lights everywhere, but I could not access the drive on the network. I did some research and found out that this used to happen pre v04.00.00-607 and that this firmware update was meant to fix this kind of issue. I read that rebooting the unit sometimes fixes the issue.

I rebooted the My Cloud and it fixed the issue. I could access the drive via the network and I left it to do its work again and went to bed. When I woke up today, the drive was unresponsive again. I rebooted and it works.

15 minutes before writing this mail it did it for the 3rd time. Unresponseive drive -> Reboot fixed.

I cannot keep this drive if it keeps disconnecting itself from the network. It defeats the point of having a reliable NAS if you need to reboot it 3 times in a 24 hour period. I hope someone can help me with this issue!

I will activate email alerts so if anyone needs anymore information just step in and ask.

Thank you for your time,

Tom

EDIT: This is really strange. It happened again - I cannot open it via the network on the PC, but I can connect to it via my phone. Clearly its connected and working properly otherwise my phone wouldn’t be able to access it.

Must be a software issue messing up somehow.

I will try a factory reset and see if it fixes it - if not I might take it back. There’s no point using a NAS if it won’t stay connected for more than 3 hours.

I think this is typical of WD my cloud cos I have been also facing the same issue as u. If i had known this, i would have never bought this device. In case you can return it to the retailer, you better do so and then get a real NAS instead.

I’m not 100% sure if this a MyCloud NAS issue. The reason for this is that I’ve got one of these beasts and at times when transferring things wirelessly the transfer times out, yet if I connect the laptop to the the router by cable, it works fine.

Between the Router and the MyCloud there is a netgear switch.

There has also been chatter that the recent firmware upgrade may have introduced a problem.

As you’re having this disconnect problem, try something please.  Turn off the DNLA media server and try your back-up gain, but try a few times. Over two or three days, does the back-up work and the MyCloud not freeze with the DNLA media server turned off.

I am doing a full system disgnostic. Then I am going to do a full restore & turn everything off that I won’t use. I have also found a different (better) backup software that I will use instead (perhaps that was messing it up somehow, worth a try).

I will post back with my results.

The stupid thing is I have been doing a full diagnositc while my network connection from the PC doesn’t work - it makes no sense! It has been 10 hours and it still hasn’t fixed itself (so the only fix that I know so far is to do a reboot every time).

If my attempts don’t work I will take it back to the shop and get my money back. Perhaps I can build my own NAS and use ownCloud or something.

Sorry for the slow reply Myron, I was waiting to see if it disconnected after I did a restore — It did.

I managed to go almost 12 hours without a disconnect and even backed up 1.4TB of data in 1 session. When I woke up this morning it was disconnected again. I will try without the DNLA server (but that’s one of the major points for having it).

It went without hitch while backing up, then I added a second user last night - it was off by the morning. I will try and see if its the 2nd user that it causing it as well.

I also emailed WD support but still no reply from them. Its starting to get a bit rediculous.

Thanks for your help anyway!

there are a few things you can try.

is your PC going to sleep? change the power settings for now so it dosn’t

set a static IP address, which includes the subnet mask, gateway & DNS addresses. the IP address needs to be outside the DHCP pool on your router. you can get the last 3 values on a Windows system by opening a command prompt and entering ipconfig /all

if your comfortable going into ssh you can disable the thumbnail process:

/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop
update-rc.d wdphotodbmergerd disable
update-rc.d wdmcserverd disable

I am currently leaving it with only 1 user enabled. I noticed that it went the longest time (without disconnecting) when I had only 1 users.

I added my girlfriend last night and by the morning it had disconnected. I removed her from the drive this morning and so far it hasn’t disconnect again. Seeing as I wish to troubleshoot as fast as possible I am unfortunately trying multiple fixes at the same time so if something works I won’t be able to know which one fixed it.

  • I currently only have 1 user
  • I removed all useless shares (Only my folder and public exist)
  • Cloud is left on
  • Drive sleep is turned off
  • Mac Backups is turned off
  • Network services is left on   DHCP
  • SSH is left off
  • FTP is left off
  • Media Streaming is turned off
  • iTunes is off (can’t remember which setting is default)

Embolded  text denotes which items in the list I have changed since last disconnect.

Now to reply to your post Larryg0:

  1. My PC is not going to sleep - Power settings are set to high (or custom) without the monitor or PC going to sleep.
  2. I will continue to try DHCP until the next disconnect. If it does it again I will try static IP next.
  3. I will take a look at the SSH if No.2 doesn’t work and if it doesn’t void my warranty.

Thank you for your help. My fingers are crossed.

The same exact thing happened to me read this post before you load any data to the drive or take it back.

http://community.wd.com/t5/WD-My-Cloud/ALL-OF-MY-Cloud-Problems-Solved/td-p/776603

I’ll add that to the list of things to try - thank you for dropping in! (I have already done a restore, just not a full restore)

Hi,

I have had this problem for quite some time now and hopefully have resolved the issues.

I found that after 3-12 hours network shares would no longer work when connecting to My Cloud 3TB model.

I have a number of PC’s and they all exhibited the same problem so I knew if wasn’t a PC issue.

I tried many of the fixes previously suggested, such as using DHCP and Static network addressing, switching off power save and content sharing, ensuring NetBIOS over TCP was on, time was synchronised etc.

I have a Sky SR101 box which has 100Mb/s ports, so I connect this to a Gigabit switch, where all my PC’s and the My Cloud box connect through. This allows my network to effectively run at 1Gb/s

What fixed it for me is to swap out a Tenda TEG108 switch and replace it with a Netgear GS108T managed switch. I imagine some switches work differently with some hardware and as the Tenda was quite old maybe did not understand some of the newer protocols ? The swap out also fixed a PC which refused to connect at Gigabit speeds, this has resolved this thorn which was a problem when you are trying to backup to My Cloud.

For now all seems fine…been running for over 12 hours

Paul

…and this morning same problem, my PC network shares do not connect to My Cloud.

I can ping My Cloud and manage it but it has stopped offering SMB shares, if I reboot I am certain it will work, but that does not resolve the issue.

I am now going to take someone else’s recommendation and SSH to the box and prevent a couple of services starting, I’ll let you know how I get on.

Paul

It is definitely the samba service causing the issue as looking in the samba log files of My Cloud there looks to be errors, whether they cause this issue I’m not sure but if I execute

service samba restart

when I SSH to the box, my drives all come back !

One thing I have changed in the /etc/samba/smb.conf is modifing realm to be the same as my workgroup which was defaulting to WORKGROUP - again I don’t see this causing the issue but it is an anomaly.

So i guess we need to find out why the samba service is falling over ?

The log file /var/log/samba/log.smbd has the following entries when I think it failed

[2014/08/30 20:55:43.179858, 0] (fault_report)

[2014/08/30 20:55:43.180462, 0] (fault_report)
INTERNAL ERROR: Signal 7 in pid 11804 (4.0.0rc5)
Please read the Trouble-Shooting section of the Samba HOWTO
[2014/08/30 20:55:43.180912, 0] (fault_report)

[2014/08/30 20:55:43.181165, 0] (smb_panic_s3)
PANIC (pid 11804): internal error
[2014/08/30 20:55:43.181855, 0] (log_stack_trace)
BACKTRACE: 0 stack frames:
[2014/08/30 20:55:43.182198, 0] (dump_core)
Exiting on internal error (core file administratively disabled)
[2014/08/30 20:55:43.200487, 0] (fault_report)

Just seen this entry but I don’t think it applied to my problem but will look at it if it happens again.

Samba running out of space

What version of firmware is on yourt MyCloud NAS?  Single drive NAS or dual drive NAS?

I have the latest version as my cloud checks and automatically installs every night

It is single drive nas 3tb

Tom,

Thank you for your text!

That very same hassle here as well!

I have had my Wd Cloud some months and during the last

few days Wd Cloud has vanished from the explorer of my laptop on daily basis! (Win 7)

It is so extremely frustrating!

How ever modem “client list” shows that Wd Cloud is “online” and has it’s own IP address.

Wd should take some kind of active responsibility on this matter!

All Wd Cloud owners have paid quite a sum to get one!

At least for students like me the money paid for this item

does not benefit the way it was supposed to!

Please Wd!

Do get your customers out of this daily hassle!

Thank you!

My firmware is v04.00.00-607

so I have the problem again…doing a df from ssh I have the following:-

Filesystem      1K-blocks      Used  Available Use% Mounted on
rootfs            1968336    637092    1231256  35% /
/dev/root         1968336    637092    1231256  35% /
tmpfs               23296     23296          0 100% /run
tmpfs               40960        64      40896   1% /run/lock
tmpfs               10240         0      10240   0% /dev
tmpfs                5120         0       5120   0% /run/shm
tmpfs              102400      2624      99776   3% /tmp
/dev/root         1968336    637092    1231256  35% /var/log.hdd
ramlog-tmpfs        20480      4928      15552  25% /var/log
/dev/sda4      2879644152 380629968 2440503152  14% /DataVolume
/dev/sda4      2879644152 380629968 2440503152  14% /CacheVolume
/dev/sda4      2879644152 380629968 2440503152  14% /nfs/admin
/dev/sda4      2879644152 380629968 2440503152  14% /nfs/SmartWare
/dev/sda4      2879644152 380629968 2440503152  14% /nfs/Paul
/dev/sda4      2879644152 380629968 2440503152  14% /nfs/Jo
/dev/sda4      2879644152 380629968 2440503152  14% /nfs/Public
/dev/sda4      2879644152 380629968 2440503152  14% /nfs/TimeMachineBackup

Note - I have no disk space at /run ?!

After I restart the samba service, I have disk space

Filesystem      1K-blocks      Used  Available Use% Mounted on
rootfs            1968336    637092    1231256  35% /
/dev/root         1968336    637092    1231256  35% /
tmpfs               23296     16448       6848  71% /run

and it all works again !

I have manually updated the firmware to the same level as before which is meant to stop this behaviour, so will see if this improves anything.

Perhaps there is an issue with the auto-update ?

I’m guessing WD may not be that up-front at replying to stuff, but this information is on their system beyond this forum/community.

The question is what is different between your installation and other installations. I got one of these beasts and I can’t get SAMBA to panic like you’ve shown from the logs.

the question is:  What’s different on the failing SAMBA daemons that causing the errors.