My Cloud is losing connection

Hi - I’ve been using My Cloud for over a year now and everything was working fine. However, for the last 2 months, its having connection problems. It works (and discoverable in all my device) for 5/10 mins after unplugging and plugging it back…but after that looses connection and none of my devices are able to discover it. Not even able to get to the dashboard. I havent changed anything with the device, so not sure how this is happening automatically.

Reached out to my Internet provider to check if the router is working as it should…and after few checks (remotely) they confirmed there is nothing wrong with the router.

Appreciate your inputs to get it working again.

@p.ravishankar Do you have a 1st generation or 2nd generation My Cloud? What type of modem/router do you have? Have you tried a different connection and/or cable on the My Cloud to router?

Hey @cat0w - Am a novice here…how do I know what generation is my device:-(

Its a Virgin Media Router (UK based) and my device is connected to the router via an Ethernet cable.

Any help would be great.

@p.ravishankarvv First generation has firmware 04.xx.xx and second has 02.xx.xx. Are you using Apple, Microsoft, Linux or what type of devices to connect to it? How many devices are on your network?

@cat0w my firmware version is 2.30.193 and am on Mac…i have only a couple of devices on this wifi

Looks like reserving the IP in DHCP in my router and opting for Static IP on My Cloud did the trick…Its been up for a couple of hrs now…if the connection is alive tomorrow morning then I guess that did the trick!

All - I did two things and it solved my problem:

  1. In my Internet Router - Reserved the IP assigned to my cloud (device) under the DHCP section
  2. In the My cloud dashboard - Under Network settings, changed from DHCP to Static IP.

All good so far…ts been 2 days with no connection problems!