MyCloud (Gen2) disconnects after about 30 min from network

My new “My Cloud Mirror Gen2” 2x4TB disconnects always after about 30 min from the network. Then I have to cycle power and it runs again for 30 min. I’ve read some older threads from June 2014 with the same issue but I’m using the newest firmware and a static ip (it doesn’t work with dhcp, too). My router is a RT-AC66U from Asus all other network devices are working fine.

Thanks for any help!


Hi, have you tried doing a system restore? What about if you connect it to a different router or a switch? Is there a way that you can set a rule on the router to reserve the IP of the My Cloud?


no, I have not tried to do a system restore because the My Cloud is new I’ve just installed it a few days ago. I can not install it to a different router because I have only one but I can try to install it on a different switch (but I don’t think that the switch is the problem - do you?). I have reserved the My Cloud IP on the router. I have also tried to put the reserved number outside of the dhcp range of the router. But it doesn’t matter if the reserved IP is within dhcp range or outside.