Losing connection

I have a 4 TB mycloud and over the last week I have been experiencing some problems with it. It will show up as offline and I have to remove Ethernet cable and put it back in again. This will get it working again for a few hours and then it goes offline again. I’ve rebooted it and I get the same thing. It will work for a few hours and then lose connection. I’ve only had this thing for about two months so it is virtually brand new.

Any ideas?

1 Like

Have you tried reserving an IP address for the My Cloud within teh router or configure the My Cloud for a static IP address?


If you changed to or have AT&T Uverse there is a known issue with AT&T Uverse routers causing problems with the My Cloud unit. The workaround is to use a switch/hub in between the My Cloud and the AT&T Uverse router.

I tried the static ip. No change

Does your router have a dchp reservation? If so setup the router to always assign the same ip address to the My Cloud.

I’ve tried that. I’ll check back later and see if it works for longer than a few hours


That didn’t work either.

I’m thinking that maybe it has difficulty waking up from power saving mode. I’ll turn off that feature and see what happens

When the device is no longer connected. What do the leds on the back indicate. What does the led on the front

The lights in the back are solid amber and blinking green. The light in the front is solid blue.

I turned off sleep mode but that didn’t help.

It seems now that I’m only getting about 5 minutes of run time whereas before it would stay online for a few hours.

Is there a number I can call if this is defective? I sent a support email a few days ago and didn’t hear back. It is still under warranty.

Any other suggestions?


You said you have rebooted, but you haven’t said whether you’ve done a 4-second, or 40-second reset; I’d certainly try these.

The blinking green light on the back indicates link activity. The amber light as you call it. Indicates that the link is
connected at 100M. The manual says that it should be yellow for 100M. If it was 1000M it would be green. The fact that the front light is blue says that the network is connected. If you pull the network cable. The front light should start blinking yellow. When you put it back the front light will turn blue after a few seconds. Are you saying that when you pull the cable and put it back. The amber light on the back turns green?

When you do have a valid connection try to SSH into the device and run ethtool eth0
It will give you information about your nic in the My Cloud. It is also possible to turn off auto negotiation
and set the speed to 1G always.

Bennor, you mentioned known issues with AT&T Uverse-We just got new Uverse router/internet and since unable to connect to My Cloud. can you explain the switch/hub workaround or advise where I can find that info? Your assistance is appreciated.

You can use the forum search feature, magnifying glass icon upper right, to find the various discussions on the Uverse/My Cloud issue. Here is one such discussion.


The workaround involves using a cheap gigabit switch (or spare gigabit router if one is available) and connecting the My Cloud to the switch then connect the switch (or spare router) to the AT&T Uverse router/gateway.

Got it, thank you

Ok, I may have figured it out. I had the device connected to an Ethernet switch. I connected it directly to the router this morning and it is still working. The funny thing is that it was always connected to the Ethernet switch and only recently did it start acting up. I’ll report back in the morning to confirm that this issue is resolved.

So it is still working. I guess it was just the Ethernet switch.

Try a different switch port, or a different cable. It may just have needed unplugging re-plugging to clear dust or oxide on the connector.