[My Cloud Gen2] Using an 8TB HDD and Formatting Failure (Error Code: 600)

TL;DR:

  • Using an 8TB drive for a Gen2 MyCloud works
  • Using virtualbox + system-rescue-cd (live linux) + usb3.0-to-sata HDD adapter for preparing the drive and the wdrecovery-stuff CAN WORK if you power of the drive while still attached to the live-linux WITHOUT giving windows the oppurtunity to f**k up the partitions

Long story:
Hi there everyone,
i read a couple of threads here on how to replace a drive in a MyCloud or how to unbrick a device, e.g.

So i was confident that my plan (buy an empty case and 8TB wd red, setup the partitions, copy the wdrecovery and fire it up with the current firmware) will work smoothly and could be archieved in a couple of hours. In the end it works but not as easy as i thought. I encountered an error which was not that obvious for me. So i decided to write down my experience, in case others are struggeling with a similar problem and to provide new food for their thoughts.
The methods to setup the harddrive in a Mycloud and get it running with the current firmware (e.g. described in the threads mentioned above), could be summarized like:

  • Boot up a Linux system
  • Prepare some partitions on the drive following a particular schema, if they’re not present anyways
  • Copy the wdrecovery-files (keywords: uImage and uRamdisk) onto a particular partition OR copy a raw-image of Mycloud drive back onto the drive (which includes the software, e.g. see here)

I tested both methods, but i prefered (and in the end i used) the method with the wdrecovery-files, cause it feels more like setting up the device from scratch. Using an image could also be another source of error.
While reading all the threads in the WD community, a couple of times a Google Drive with a lot of information is mentioned and many thanks to user Fox_exe to gather all the information.

In the subdir WDMyCloud-Gen2, there is a textfile (_Unbrick_en.txt) with a full description of the method/commands i followed and the required wdrecovery-files (usbrecovery.tar.gz) i used.

Hardware i bought and used to setup the Mycloud device:

  • An empty MyCloud case (P/N: WDBCTL0060HWT-10 … original 6TB Gen2 using FW=2.xx)
  • 8TB WD Red drive (WD80EFZX)

Used OS environment:
While my main machine is running Windows 10 x64, i tried to boot an older laptop with a Live-Linux via USB but this fails. I thought about why not using Linux in a VM. So i used Virtualbox (current sw: 5.2.6-120293-Win) without the guest extensions and a ISO of SystemRescueCd (current version: 5.2.0 x86).
Setup VM:

  • OS type=Linux; Version=Other Linux (64-bit)
  • RAM=1024MB; Virtual hard disk with fixed size of 1GB (not required so could be less)
  • USB: enable USB controller; USB 3.0 (xHCI) controller - required so i can use my usb-sata-adapter at the USB3.0 ports of my machine and give the control of the device to the VM (error message: failed to attach the USB device to the virtual machine )

Start VM:

  • Attach the ISO to the optical drive, boot-up the VM and select Option #6 (start graphical environment) … wait till GUI is loaded
    vm-linux_1
  • Attach the usb-sata-adapter to the VM
    vm-linux_2_usb-attach
  • I got the following error and had to activate the USB3.0 controller in the VM settings

    vm-linux_2_usb-settings

Prepare the paritions on the drive:

  • Find out which device is the drive (e.g via gparted)
    gparted_1_dev_no-partitions

  • Create partitions following the commands in the instruction
    Hint: Use the cmd ‘print device’ in parted in terminal to check you selected the correct drive before messing something up
    terminal_parted_1_device
    Created partitions in GParted (including swap on sdX1)
    gparted_2_dev_with-partitions_2

  • Copy wdrecovery-files to sdX3: I used a USB stick to transfer them into the VM (attach USB stick to VM, mkdir and mount device to dir)

  • Unmount drive from mounting-point and DO NOT DETACH the drive from to VM back to Windows, cause this f***ed up the partitions somehow (maybe when discovering the new drive/partitions) an lead into errorcode=600 later on. I just turned off the power from the usb-sata-adapter

Upload firmware and set up storage

  • Attach the curcuitboard back onto the drive, attach network and power cable and fire it up
  • Wait some minutes until the mycloud has booted into “Safe Mode” (the blinking LED switchs from blue to red)
  • the device will use try to get an IP via DHCP (or if not avaible if think it will use the IP-range of zeroconf) and is accessible via Web-Gui (LED is still blinking red)
  • Log onto the Web-Gui and upload current firmware for Gen2 (for me it was My_Cloud_GLCR_2.30.181.bin)
    safe_mode
  • Wait some minutes till the firmware is uploaded and the device has rebooted
    reboot
  • Reload the Web-Gui to get to the known WD dashboard and start the initial setup process ‘first steps’ (accept license, set password for admin and so on)
  • When done with the initial setup, the dashboard asks to set up the RAID Mode for the storage

    If you switch to Home it shows that no capacity is available at the moment and the diagnostics says ‘Caution’ but nothing is shown when displayed

    diag_1
    Reload Web-Gui to get back to the RAID Mode dialog
  • Set up RIAD Mode: Select ‘Switch to JBOD’, press next
    storage_2
  • Wait till drive self test is finished, press next
    storage_3_init
    storage_3_finished
  • Check summary, press next
    storage_4
  • Understand text, agree re-format with ‘Finish’
    storage_5
  • Partitioning, Initializing format of drive … Hard Drive Formatting Failure (Error Code: 600) … f****k -_-
    storage_5_format1
    storage_5_format2
    storage_5_format3_error600

This error occurs if i detach the drive from Linux back to Windows after creating the partitions and shutdown the power of the usb-sata-adapter after ejecting it under windows. This error occurs NOT if i power down the usb-sata-adapter while still attachted to the Linux-VM. It is possible to activate SSH before setting up the RAID stuff, so maybe it would be possible to fix this error via SSH on the device, but i didn’t tried so far.

It seems that pre-formatting all partitions to ext4 (except swap) could avoid the error.
gparted_2_dev_with-partitions

  • Wait until volume if formatted (if no error occurs), click close
    storage_6
    storage_7
  • Switch to Home tab to check available storage

I hope somebody is getting a clue via this text about what to do and maybe also a little help.
So long …

1 Like

mcmetrox, Fox_exe,
guys thank you for the fantastic guides and resources!

Using your methods I just successfully upgraded to 10TB :slight_smile:

Luckily I did not have the Error 600 problem, but anyway whole procedure took me some 1.5 days.
I have done everything via USB SystemRescueCD

Your infos were really helpful, so once again thank you for the great work!

This sounds great and all but is there ANY way that this can be performed on a Mac Book Pro running Sierra? I can’t seem to find anywhere on how to do all this for the Mac. If someone knows of a link that shows how to perform this on a Mac, PLEASE, post it here.

Thanks!!

Sorry to revive this topic, but I hope someone is still online on this problem.
I tried everything to replace the damaged disk if my 4TB MyCloud gen2
-I copied a 4TB image and a 3TB image, but all I got was a red blinking light
-I used FOX_exe’s directions to connect via Telnet. I did it over 10 times. The partitioning goes OK, I load the original firmware, I manage to enter the GUI of the device. But when I restore factory defaults or when I change RAID mode it reports the error 600, goes to Hybernate and the disk is a mess. That means that if I connect the disk to gParted it all the partition that I had created are gone.
-I connected the disk to a laptop running VirtualBox. Created the partition using gparted, copied uImage and uRamdisk to the /mnt/root/boot dir of sdX3. And I turned off the power of the USB-to-SATA where my 4TB disk is connected. But nothing again.
The only thing I can imagine that is different, is the original firmware. I download the most recent "My_Cloud_GLCR_2.31.174.bin". As I can see you use this file: "My_Cloud_GLCR_2.30.181.bin" . Do you think I should use the earlier version too? I do not want to destroy my board using an older firmware in case that is not alowed by the system
What should I do? I am copletely stuck.

Finally I did it.
The solution is a mix of the two methods
I created the partition directly on the Disk (system rescue CD in Virtualbox) and (pre)formated them to ext4 except from the swap partition. There was an error while creating the sda3—> I chose to continue.
After that I connected the disk to the board and boot it with usb stick (FOX_EXE)
Using telnet, I see that the partition table is not recognized (strange because gparted did it in both cases). I use “mklabel gpt” and then I see that the partitions appear formated.
I follow the rest and when I come to “mount /mnt/sda3 /mnt/usb” there is an error again. (invalid argument). So I use “mkfs.ext4 /dev/sda3” which completes OK and I can mount it.
I finish, reboot, find it in browser (you may need a 40sec reset), load the old firmware "My_Cloud_GLCR_2.30.181.bin" and success. Format completes and all is OK.
When I try to autoupdate the firmware it reports error. I manually update it and all seems OK. Still the auto udate reports a failure.
Thank you all. it was a very frustrating experience. I learned some things about unix. I am very dissapointed though from WD. My device was working for only 2.5 years and it failed. I lost a big collection of pfotos and videos.
I think that we are all guided to online storage.

mkswap /dev/sda1
mkfs.ext4 /dev/sda3
mkdir /mnt/boot
mount /dev/sda3 /mnt/boot
mkdir /mnt/boot/boot
cp uImage-wdrecovery /mnt/boot/boot/uImage
cp uRamdisk-wdrecovery /mnt/boot/boot/uRamdisk

I think your problem is virtualbox, I dunno… Not a fan of it.