Hoping someone here can help me with a build

I have a MyCloud 3TB (v2) case and I was hoping to use it for a build. I bought a 3TB red drive and attempted to set it up today, but there are so many “guides” for soft debricking, full rebricking etc, I just don’t know which to use. Here’s how I’ve gotten on so far.

First I used this guide [GUIDE] How To Unbrick your 2TB/3TB/4TB My Cloud. I got as far as step 12 and then things just started going sideways.

So I had a look at this one https://drive.google.com/file/d/0B_6OlQ_H0PxVQVhnLVJOdDZISUU/view. This seems to rely on getting a network connection to the enclosure, which I can’t get. I followed the steps to creating the partitions, only using Parted on the systemrescuecd instead of via telnet. But I can’t find the WDMyCloud/WDMyCloud-Gen2/Developing: uImage-wdrecovery and uRamdisk-wdrecovery the author refers to. Can anyone suggest where I might find that file?

Success reported only a couple of days ago:

1 Like

Ah, cheers man. I managed to get the 2 files required from Bennor’s reply there. Hopefully it’ll get me going now.

Oh one other thing - what file extensions are the 2 files? Or which application do I use to unpack them?

That’s a good question… Not zip. Not tar…

I’ve not done it; i have a gen1…

Maybe @tuckerl can help? Or @Bennor

Maybe they don’t actually need unpacking…

1 Like

If the file ends in tgz then gunzip the file. If the resultant file is a tar then untar the file.

1 Like

Not sure. I suppose one could run the Linux unpack command on the files even though they don’t have file extensions and see if they actually unpack into a directory or into new/larger files.


1 Like

I tried unpack on my Android media box, but Android doesn’t have it. I forgot that it’s not a full linux…

It does have zip and tar…

1 Like

These are the final files. Follow the cp commands.

1 Like

Ah, so the instructions may be out of date a bit? From some point when fox had the images packed?

No unpacking required, then: just download and copy.

1 Like

I had a feeling this would be the case. No file extension would normally suggest that they have no associated program.

So thank you for your help. And to everyone else to replied here.

just to let you all know that I have now completed this, 100% working. I had to make a few adjustments to the guide and I will detail them in that thread.

Thanks guys.

Well that was short lived. After around an hour, I noticed the led was blinking really slowly. I tried connecting in but got an error. And when I browsed to the gui, the drive was showing as 0mb, with a red notification that there was a volume failure. I tried running a system restore and nothing happened. I removed the drive and connected it to my pc, and mini tool partition wizard picked up all the volumes, as shown in the attached pic. Looking at the partition structure, is it possible the drive or main partitiion has become corrupted and needs set up again? Does the main partition need formatted maybe? What format should it be in? Can I use a pc tool such as mini tool partition wizard to set the partition up again?

What format is the D: drive. It should be ext4.

Well its strange that partition K: is showing as ext4 but partition D: is showing as “other”.And why all those unformatted partitions? Are they all proprietary partitions created by WD?

On a Gen1 system partition 1,2 is ext3 raid
On a gen2 system partitions 2,3,4,5,6,7 are ext4 part1 is swap

Sizes will vary depending on the size of the disk.