My Cloud connection is Failed

I can’t remote access to My Cloud, I check in the status of could access is show failed. What happens? I set Cloud access connection Options is Auto. I check with my ISP It network is OK and he open the Internal Port now. Help me please.

@boonlaer Who is your ISP? What are the LED’s on the back of your My Cloud doing, if anything? What is the front LED doing? How is your My Cloud connected? The more information you provide the better chance of someone being able to help you. What kind of router do you have?

I from Thailand My ISP is 3bb LED is doing and the front is blue light and my router is fiber optic model EchoLife HG8145V. I connected my cloud with LAN line and connected at LAN 1 on the router. I think everything is Ok but can’t remote access to my cloud sometime it can access but today can not. Connected is work in same cycle LAN (Same land band).

Hi boonlaer!! Do you have an answer for your issue? I have the same problem…

Stop Cloud service from Cloud Access and switch on again

I just did it, but still no access

I solved the problem!!!
I changed my user email, and changed again into the original.
It Works!!!
I’m sure the problem comes when I created a new user that never worked, I thing I made something wrong and the system “get anoyed” with me…haha.
Now we are friend again!!
Thank you for your help. We can give this issue as a resolved.