WD My Cloud not accessible

My WD My Cloud 3TB was connected to my downstream router and worked fine until recently. It is almost exactly 2 years old (purchased 23/12/2015). I noticed that the front panel LED was off so I turned it off and then on again and a yellow light comes on for awhile and then flashes a bit and goes off again. This is what I’ve tried this far:
Connected it via a different network cable
Connected it to my laptop via the ethernet port
Connected it to my main router
Tried the 4 sec reset
Tried the 40 sec reset
All with the same result. It seems as though it is out of the limited 2 year warranty. Is there anything that I can do to bring it back? I’m thinking it may be a network port failure. I’m quite disappointed in this drive, it is kept out of the way and is hardly ever used - I do weekly backups from my phone to it. It is also kept out of the way so it couldn’t have been kicked or bumped. Lastly, it is on a circuit with surge protection.
Any help or advice would be appreciated.

What are the LEDs on the rear doing, if anything? My front blue LED has not worked for a while now but my My Cloud works just fine. Mine is three years old.

Hi cat0w

The LEDS on the rear are green, one solid and the other flashing.

It seems you are correct - the front LED is just not working - re-scanned the network and the drive is there, just under a different IP address.