My Cloud Blinking Red Light

Hi All,

First post and I was hoping to get some advice.

Got an 8TB My Cloud unit from family but the drive wasn’t working anymore, they bought it a while ago and it’s just been standing there.

So I have a WD Blue 2TB drive which hasn’t been used and I followed this post:

How to unbrick your My Cloud

That all worked fine granted the new drive is much smaller than the 8TB one it had in before but the process worked as they described.

Yet now that I have put the whole thing back together and power it up connected to my router I get a blinking blue light whilst I hear the drive spinning up and then the light turns red and keeps blinking.

I’ve tried the 4/40 sec resets but they don’t appear to do anything, also changed the ethernet cable and port on the router but it stays blinking red. It’s not showing on my network so I cannot access it via the dashboard.

The first question is can I use a WD Blue drive with the My Cloud?

If so, what could possibly be wrong?

Thanks for any input!

Try another unbricking procedure. Its possible you have the newer gen 2 single bay My Cloud using the v2.x firmware. If so that unbricking process (for the older first gen v3.x/v4.x My Cloud) probably won’t work. Try the following for v2.x firmware versions:

For other versions of the My Cloud see the main directory:

Edit: Those links were hosted/create by another user here.

I’d also ask: how old is the 8TB drive? Is it not within the two year warranty period? What happened to it that you needed to replace the HDD, rather than get a warranty replacement?

Yes that’s what I said but the drive is removed it was taken out by my cousin.

That obviously voided the warranty. :rage:

Not sure which generation it is:

Looks like this one from this link.

Thanks for your response.

How do I know it’s Gen 1 or 2?

Takes a single drive.

I used your advice you posted and was able to telnet into the mycloud but once I had done all those steps it booted up and then started with the red light flashing. :confused:

I believe that the newer generation (gen 2) single bay My Clouds using v2.x firmware are denoted by having a P/N number on the bottom of the My Cloud enclosure that ends with “-10”. For example: p/n: wdbctl0080hwt-10

1 Like

Thanks took a bit of fiddling but with that info I managed to get it working.

Is a gen2 and seems fine now.

Appreciate the help Bennor