My Cloud 3TB "Device offline WDMyCloud is not accessible.Local documents are available"

So…it was working for the most part over the last year or so(other than a few WD issues). Now, as of a few weeks ago, it is giving me this message when trying to access the drive from outside my network. It did work when within my network when I was hooked up to wifi(Iphone and IPad). I have an Apple Airport extreme base station, wired network through an ethernet switch,  a port forwarding connection established, remote access enabled, static IP address for the WD, and a successful test email received to ensure internet connection. I can access the WD MyCloud through the MacBook Pro which is wirelessly connected to the Apple router. All content is accessible from the Mac, just none of my other Apple products.

I opened a case with WD, and they recommended a “system only restore” which I completed last night. I reestablished a static IP address on the WD, reenabled the port forwarding connection and email notifications and tested, and added myself as a user. All other users went away during the restore. None of this worked. AND…I am unable to access the WD on my own network with the Iphone or Ipad. I tried rebooting. Nothing. I shutdown the device, unplugged it, waited 10 seconds, and plugged it back in. Let it come up to speed…Nada!

I see other people are having the same issue. Is this a firmware problem? If so, do I just wait for a new firmware to correct this?  I have responded to WD support with the unsuccessful results of a system only restore. Thanks!


Are you running the latest firmware version?

Have you tried reinstalling the mobile app?

Firmware v04.01.00-408 which I believe is the latest. I will try deleting and reinstalling the app. Thanks!

Hey…It works now! Thanks so much. Overlooked the simple solution once again!