My Book and Windows 10


#1

Just purchesed a My Book and it does not work with Windows 10. Is there a fix? When will there be a fix? I don’t want a workaround.

How long has the Windows 10 been around for WD to integrate their products with this operating system - answer is quite awhile. I am angry that “so called technology companies” cannot coordinate their products together - same old problem over and over again.


#2

I have four WD My Book drives working with Windows 10 and no problems. Does your drive show up anywhere? If not, look in “disk management” and locate the drive by drive letter. If it indicates the drive is “off line”, click “off line” and a menu will pop up with an option to change the drive to “on-line”.


#3

I had the same issue. Upgraded to Win 10 and the drive quit being seen.

It turned out that I had added a USB 3.0 card to my PC. That card did not get updated drivers so it quit working. 

I swapped to a USB 2.0 port that was part of the original hardware and can now see the drive.


#4

Same problem here, I’ve got 4 my book drives and they appear to be “raw”, there’s no way to see what’s inside them since I upgraded to windows 10. I unplugged them (safely) I restarted the pc and plugged them back again an there’s no way to make them work

The drives have no problem since I connected them to my mac computer and I can see them in NTFS format with no problem

¿Are you guys going to release any driver to be able to read drives in windows 10?

Thanks


#5

Hi again, the funny thing about what’s happening is that I realized the problems come with drives who use a usb 3.0 cable, when I plug a drive with a usb 2.0 cable I have no problem, could it be the issue?


#6

Are there new drivers for Windows 10? What I have does not work.


#7

Been having the same issues…Upgraded win 7 to 10…My Book no longer is identified …tried what people said in the threads…nadda…ugh


#8

Have you installed this driver  “WD SES Driver” ?

Windows 10 does not automatic install.


#9

How does one install the SES Driver in Windows 10?  I see it in a folder in my My Book drive, but don’t know how to install it.


#10

In Wn10, MYbook shows up in devices, but not in file manager. disk management shows it as ‘unknown’, unallocated, not initialized. I’ve been using it for a while for my graphics files. I have thousands of photos and art files. I cannot afford to reformat or do anything that loses the files. I loaded the SES file, but when I click on it, I don’t see anything happening. WD’s drive diagnostic doesn’t ‘see’ the drive. In disk management, a popup gives me the option of initializing using MBR or GPT. I have unplugged, replugged, moved from USB 3 to USB2, still nothihg. What next?


#11

Five computers, two printers, LAN, WIN-10 on all.  Lost dashboard and all control to My Book.  Read everything that I could find about a fix.  No solutions work.  Win-10 keeps “yelling at me”, back up now.  Kind of stupid to back up data to the same hard-drive.  (My opinion), but better than no fix.  Anybody have any good news before I go off looking for a better solution?


#12

I have My Book on an LAN. It stopped backing up when I installed Win 10. Chrome was my default browser and the latest version doesn’t support some required Java components. Switched to Firefox that still supports all Java components and at least I can read My Book, but still not performing backups. Hope this helps someone smarter than I to find a fix.


#13

I have a surface pro 3 that was installed with Windows 10 recently. When I connect the WD My Book to the laptop, it was shown in the list of my devices but there is no drive detected. The driver is updated. The cable is USB 2.0 but it is suppose to be compatible with either USB 2.0 or 3.0 ports. What can I do to get My Book to work?


#14

So here is the answer for everyone. I had the same issue as all of you. The drive would show up in Device Manager as well as Computer Management but not in My Computer. It would show up as “Drive 0” in Computer Management.

Now because the computer does not know what it is really, the “Right Click” and format is not an option.

However if you right click on it in Computer management and select 'Create Simple Volume" I believe is the option it will walk you through a setup to assign a drive letter, an option to format or not format and when it is done you will see your drive and be able to use it in “Computer”.

Hope this helps those that are not getting an answer from the company.


#15

I had My Book connected to a desktop running Windows Vista. It worked fine for backing up my files. The old desktop recently died. I need to restore my files to a laptop running Windows 10. I can see the files in File Manager when I connect via USB on my Windows 10 laptop, However,I want to use the Restore Feature that I bought and paid Western Digital for. The whole point of me paying my hard earned money to Western Digital for this device was to be able to rescue my files when needed. Now this cannot be done because operating systems changed…like this is the first time that’s ever happened. Geez

I cannot do the restores manually (at least not in this lifetime) because the files are of course under many separate backup folders that you have to drill down to to get to the photos and documents I want to restore.

So I need a Windows 10 driver for the My Drive…I guess that’s what I need.

So I am saying to Western Digital, get with it please and find a way for me to restore my hundreds of files in a quick, seamless manner. Resurrecting my old Windows Vista desktop is not an option. It’s forever dead.


#16

I tried a 3.0, cable from a working Seagate Drive and that did not get the drive working. I thought it might be a bad cable causing the issue. Has anyone gotten past this issue? My drive is one of the New My Book drives kind of designed like the box shaped Seagate drives.


#17

Just a thought, but could the issue people are having with these drives be a simple BIOS setting for USB drives. I have to admit I have never had this issue with a WD My Book in the past.


#18

I have had a My Book Essentials for many years now. It has never worked on a USB 3 port. I check the USB 3 with another
USB 3 device and the port works fine.
Only USB 2 worked with the My Book
So I took the hard drive out of the enclosure and put it a Vantec NexStar HX.
Works perfect on USB 3 and 2
Mark


#19

I have been searching and reading trying to solve a similar problem and doing any recommendations that do not involve programming or BIOS. After a Windows 10 update last July I can not see the drive in File Explorer. USB recognize MY Book (Essential Edition 2.0 - is kind of old, but worked)

Always get this message:
This device is working properly.There is a secondary device connected to this hardware that Windows cannot identify because it does not have a valid hardware identification number.

For assistance, contact the hardware manufacturer.

Also: Device not Migrated.

I have not change the USB cable.

My Passport Ultra is working perfect

Pleeease help!!! I have hundreds of photos


#20

I have had the “not migrated error”, but I can access my drive. I my case this error seems to occur after the drive goes into a power save state and then wakes up, an error occurs (probably a timeout on the device) so the OS place it into a compliance mode and keeps it available for use. One thing I have done is uninstall the device and then scan for devices. The device is found again and is in a working state without being forced in to a compliance mode.