Messed up my WDMC, can't go into dashboard, can't use SSH

Hello there.

Long story short: I tried to change ownership of some files in a share because the software used to create them was messing with it. Unfortunately, I miraculously managed to change ownership across the WHOLE filesystem. This resulted in many issues: Content Scan no longer worked, and trying to do anything in the dashboard settings was displaying one ore more errors (400162, 400255, 200000 and more). I could still SSH, so I tried to chown again as “root” but this didn’t solve the issues (obviously but I had to try). Eventually I decided to go for the 40 Second Reset / System Only Restore.

Now, when I visit the wdmc url, I am greeted by this:

If I accept the terms and click on continue, I get this:

Despite all that, I still have access to the shares and all. But I still want to restore the device to a proper state. So, now that the settings have been reset and I can’t enter the dashboard, I can’t enable SSH either and I’m kind of stuck. At this point I don’t care about saving any shares and data, so I’m trying to figure a way to properly restore the device to a normal state. At this point I imagine I’d have to remove the disks from the case and fiddle directly with them? I’m blank from this point on.

Any help appreciated.

Cheers

Have you contacted WD Support? Use the link at the top left of the page, Support!!

Here is a link too.

Oh my, you’re a smart one aren’t you. I suppose you’ve had tons of luck with WD support in the past and especially on self-inflicted issues that void your warranty. If you have nothing actually useful to share, please stay out of this, but if you do think you’re helping, you may need to get some help yourself. Cheers.

Boy, you have an attitude! Try using the Knowledge Base.

Have you read the User Manual for your version of My Cloud?

Before making any changes to a share did you read all the Help information provided in the Dashboard?

Your the one who messed up your My Cloud, not me, mine is working just fine and has been for several years now.

What happens if you click on OK and then Continue, if possible?

1 Like

Nevermind, I’m going to try this https://eriffoorp.wordpress.com/2015/05/29/restore-your-wd-my-cloud-by-image/ and will probably report back how it went, in case another fiddler cares for a real solution. As for your questions, 1) yes, 2) yes, 3) same thing.

https://community.wd.com/search?context=category&context_id=105&q=Debrick
1 Like

Thanks! The first result seems to be a similar solution to the one above, but the provided image file seems to be more appropriate and some things make more sense. It didn’t occur for me to look for bricking solutions since I’m not actually bricked. Cheers!

The first solution to solving a problem is to troubleshoot, that’s what I have been offering along with places to search for a solution. Only you know exactly what you did to cause this problem.

I’m not sure what you meant by changing ownership to a file in a share on the My Cloud. If you own the My Cloud then you are the administrator. Instructions are provided as to what you can and can’t do.

I use WD SmartWare for my backups and haven’t had any problems.

Reading between the lines, and using the references to SSH and chown, I concluded that the OP had logged in via SSH, and used chown to modify the ownership.

Well, you are half-bricked… Not being able to access the Dashboard or SSH, and with file permissions that are now screwy, you have a device that is well on the way to being bricked. Since you can’t get in via SSH to fix the permissions problem (see below), and you don’t care about the data, the easiest resolution is probably going to be an unbrick.

I remembered a fix to a permissions problem that got introduced with one of the firmware upgrades. The solution was to run a recursive chgrp:

Admittedly, that was a problem with groups…

Hello again! Many efforts and guides later, I can now say that I finally restored my myCloud (or should I just say my Cloud?). After many failed attempts with several disk-dump images laying around which resulted in being stuck with a white light forever, the guide that worked for me was in here: http://forum.openmediavault.org/index.php/Thread/5522-WD-MyCloud/

From that page, I visited the Google Drive link > WDMyCloud-Gen1 folder and followed the instructions in the file “Replace HDD - English.txt”. Instead of just flashing a whole disk image on the disk, this guide explained how to structure a disk from scratch and flash each partition separately. I don’t know what specific step made the difference (the creation of a “.fresh_install” file seems interesting), but all that matters right now is that the device works and already downloading the latest firmware in the dashboard.

Thanks for taking the time to reply and help here!