I have a My Cloud that has been sitting un-used or a while. I dusted her off and noticed that NOTHING in the UI was functioning, throwing out errors for every single function. There was nothing I could do/change/access. I did a 40 sec reset and went back to factory.

Upon trying to set up the device I now can not even accept the licensing agreement. I am completely locked out of the device. No, I did not install the dashboard software, and have no plans to as it shouldn’t be needed. I need help getting my device functional again, any ideas? Please and thank you. Pics of issue included.

Can you access the MyCloud by typing in the IP address in your Browser? (Check you router for the ip address of the MyCloud)

I am wondering if the persistent partitions have become corrupt. Sadly, I believe SSH access is disabled after 40sec reset, right? (needs to be re-enabled?) I would love to see the dmesg output of this device.

The web ui, and quite a few other things are hosted by a read only cramfs container on the gen2, which gets mounted on the root filesystem, which is hosted by an initial ramdisk. Even if the hdd inside went belly up, it would still “partially” boot, or at least that is my impression. I am guessing that HD_a7, or HD_a2 are not mounting.

Does the HDD spin up? Does it make any strange clicking sounds, etc?

The drive is indeed spinning. I even have access to the original shares that were on the drive before the reset. I can see them and get into them but can not change/administrate them. So I know the hard drive itself is operational. It seems that, for whatever reason, the ‘operating system’ on top of the drive is not doing its job at all. . .I wouldn’t mind using this as a simple storage drive without the cloud function but I can’t even do that because I can’t get to the operations that would give me administrative access to the shares and drive. I am completely clock-bocked at the darn license screen.

40 second reset does clear the admin user name to ‘admin’, with no password. Are you trying to access the Dashboard with your older user and password? I’m assuming you’ve got past the licence T&Cs page now.

I have not gotten past it. It simply will not allow me to accept and move on. The access I mention is through simple samba shares. I can see the shared folders on my network. I still can not access any function of the device though.

So can anyone tell me anything about this? So far the idea that Wierd_w presented about corrupted persistents is the is the most likely. . .So do I just scrap the drive and toss it? Is there anyway to repair this [Deleted] thing?

If you can SSH into the box, please collect the dmesg output, and post it here with preformatted text. That will greatly increase our knowledge of what your box’s problem is. If the box is having difficulty reading its internal HDD (bad sectors, et al)-- that failure will be recorded in the dmesg system log.

Sadly, I do not know if you can get an SSH shell up and running without first configuring the dashboard. We might be able to FORCE the sshd to run using the USB startup script trick.

We can manually invoke the sshd and force it to run (even manually configure it if needed), using this startup script methodology, and then be able to get in, and collect the dmesg output. Failing that, we can use the script itself to collect the dmesg output by passing its output to a file on the usb stick, then reading the stick in a computer.

Please collect dmesg output, and post it here. :stuck_out_tongue:

Alright then. I gave this a try but my script game is pretty weak. Plus I have no idea what the actually directory structure looks like since I am only seeing the basic shares.

my mfg_WDMyCloud file contains:


my fun_plug (teehee) file looks like this:

chown -R nobody:shares /DataVolumes/shares/*
dmesg 2>&1 /DataVolumes/shares/Public/dmOutput.txt

This did effectively. . .nothing. . .I was hoping to connect and see the newly created file sitting there for the copypasta but nope. nothing. Didn’t change any ownerships either. I didn’t see any more infos about how this is supposed to work so I have no idea where to go from here. It would be nice if I could run a led blink style script just so I know the script is being read and executed.

What would be the best way to actually get the ssh up and running and with set authentications?

If there is a problem mounting the drive, it will mount RO!!

That is why I suggested saving it to the USB device.

Understand that the mfg_. The somename is the result of A=‘xml -g /hw_ver’
On my system it was WDMyCloud but it could be different on other systems.
Also the sn00py is spelled with two zeros.

Well. . .I have tried everything imaginable and I can not get any kind of script to run nor can I get any kind of dmesg output. . .I am officially p.o’d beyond comprehension. . .If there is (supposedly) a way to run a script from a usb, then why is there no way to run a factory image reinstall from said usb. . .no that I can get any thing to happen. btw, I am screaming expletives at my screen as I type this. Fantastic piece trash they have engineered here. can’t even rip it open to salvage the actual drive. Unless anyone else can think of something I am just going to take it outside and put her down ‘old yeller’ style.

Why not? You can open the case and remove the drive, either to recover the data using a linux machine, or an ext4 file system reader on a PC, or you can try one of the ‘unbricking’ methods to restore operation. Plenty of threads on both data recovery and unbricking.

Opening the case involves inserting shims (E.g. credit cards) in four place on the rear of the case. Insert to about 1cm to release the retaining tabs, then use some force to slide the white cover off. Google for YouTube videos.

Why not? Opening up the My Cloud enclosure is actually relatively easy. There are a number of YouTube videos detailing the general process.

I had heard that they drives were hard soldered into the device. I didn’t realize it was as simple as any other external enclosure. That will have to be the way I go about this. I may or may not try to format it, reinstall factory image and set it back in. . .It’s not the fastest or best NAS solution but I do like it…when it functions. I will crack her open and experiment from there. Thank you guys for letting me know its possible!

SPECTACULAR!! Thank you guys so much for all your help! Thanks to the revelation of being able to gank the drive out, I carried it over to a linux machine and basically rebuilt the whole drive from the ground up. Wipe, repartition, reformat, install IMGs, and do a 40s reset. I know have this silly bastage working again like new! I followed the guide below:

By doing the complete restore I basically started from zero again. Glad my investment didn’t go to waste and so glad Linux is a thing ;p

Thank you guys again for all your help, I really appreciate it :smile:

the same problem with me

Hi XaberTheBlade. I had a similar problem than you. Only tried to add a new user to MyCloud. But had to reset my password. Thereafter I was no longer able to access the drive. I tried as much as I could to get access again, but all attempts have failed. Seems I will have to set it up from scratch again, as you said you had do to. Do you have any info on how to get started? First problem is how to set up anything if you can’t access the MyCloud. How did you manage it?