Lost access to MYCLOUDEX2 via Windows

I am no longer able to access my MYCLOUDEX2ULTRA storage via Windows Explorer. It shows up as an icon under “Network” on Windows Explorer, but if I click on it, I get an error message “Windows cannot access \MYCLOUDEX2ULTRA”. If I click “diagnose”, then I get another error message “file and print sharing resource (MYCLOUDEX2ULTRA) is online. Detected but isn’t responding to connection attempts” This started suddenly 3 or 4 days ago. I have tried turning it on and off. I think that the MYCLOUDEX2ULTRA is working OK, I can access it and see my files via Internet Explorer, but I want to access it via Windows Explorer so that I can add, copy and delete files easily. Yesterday, one a error message that came said that the Router was experiencing difficulties. How can I work out if the problem is the router and if I need a new one? Turning the Router on and off doesn’t sort the problem out either.

Hi JokerOhNo,

You should try mapping the shares of the device by referring the link given below. This way, all the shares can be mapped in the Windows Explorer of the computer and data can be easily transferred, shared and deleted from the device directly.

https://support-en.wd.com/app/answers/detail/a_id/9323

Thank you. I have had a bit of success with this since I posted my question. I started Googling NAS drives and network issues and I came across a Youtube video which suggested a fix, and it worked:


So, after ticking the SMB box, I am now able to ‘see’ the MYCLOUDEX2ULTRA drive through Windows Explorer. Then, as suggested to me on here, I went further and mapped my MYCLOUDEX2ULTRA to a Network Drive. Now, these are changes which I have made on my SurfacePro 6, and everything is working fine on that now. But, I also made the same fix to my laptop and that doesn’t seem to have worked - so I am going to have to keep on working on that. At least I seem to have eliminated Router problems as a possible source of the problem, I now suspect it is something to do with Windows 10.
Thanks a lot