Mapping Drive MyCloud EX2 Ultra

Today I formatted my Win10 PC and Win10 laptop.

I easily remapped again the NAS on my laptop via WIFI using this process that I found on the website:

“Map Drive by Device Name in Windows”

Unfortunately I can’t do the same on my PC, which is connected directly to the router. When I paste “\MYCLOUDEX2ULTRA” on the address bar, I get this error message:

Network Error
Check the spelling of the name. Otherwise there might be a problem with your network.

The same steps worked with my laptop and I don’t know why it doesn’t work on my PC
Does anyone know what to do?


Can you ping your NAS by IP?
Can you access the admin UI using the browser?
Can you see your NAS as a storage device when you click on Network in Windows Explorer?
If yes to all 3 questions and you cannot access it through “\\MYCLOUDEX2ULTRA” or “\\<IP_ADDRESS>” you might have the same issue as I experienced.
Check this thread I gave 2 ways of solving the issue.
Basically it boils down to adding windows credentials for your NAS or forcing windows to accept guest logons (I added windows credentials on mine).
Hope it helps. Let us know if that solved the issue.

Try puitting in \\wdmycloudex2ultra\public. Don’t know why it worked on your laptop without the share name (public).

Hey hey adding windows credentials worked!


Thanks a lot for you time :slight_smile:

Nah, didn’t work. I receive the message “Windows cannot access \wdmycloudex2ultra\public” It then asks that I check the spelling or Diagnose

Not sure how to ping the NAS by IP.
Yes, can access via the browser.
I can see “MyCloudEX2Ultra” under storage. But when I double click on the “MyCloudEX2Ultra” it takes me to the browser. But still no good.

I have tried the accept guest logon but still didnt solve the issue.

The NAS icon under “storage” will only ever take you to the dashboard. You need to click on the NAS icon at the top under “Computers” (which probably isn’t there). Your problem is with windows 10. You need to find out which default settings (eg SMB) are preventing this.

ok, thank you. I’m looking at another youtube clip now. The Network Profile on the browser (under settings) has all these different IPv4 settings as well as showing “internet” but mine only shows IPv4… and that is it (update, it displays status “no Internet access”.)

Also, on the browser in the top left it indicates “Not secure”. Think I need to bight the bullet and take it to someone.

If it doesnt work on W10, then do I buy a chromebook or something to move my files?

What NAS will work with Windows 10?

Thanks so much for your efforts. I cant even view it from my Samsung Note10 anymore. The connectivity has deteriorated since I first posted. I think its time to ask a network specialist to visit the home office. effing windows 10!!! (shakes fist in the air) :slight_smile:

I think they all show “Not Secure” (at least mine do). WD just hasn’t bothered to update their securty certificates. You have two problems - local access, which is a windows thing, and remote access, which is a port forwarding/UPNP thing. You may or may not find someone who can fix this for you(?!)

I’ll let you know! someone is dropping by tomorrow to inspect. I’ll provide him this thread and update you all.

I want the media folders on the NAS particularly pictures to be included in my Windows Libraries. When I try to add them, I get an error saying that they cannot be added because they are in a location that is not indexed.

Windows 11 - (1) Right click on ‘This PC’ in Windows Explorer and click on ‘Show More Options’. (2) Click on Map Network Drive. (3) A new Window will be launched, click on Browse. (4) A new window will launch click on your MyCloud device. (5) This will show a list of all folders on the drive. (6) Click on the folder you want then click on ‘OK’. (7) Click on Finish. Your required folder should now be in your main list and be accessible. This worked for me.